ID do artigo: 250343 - Última revisão: terça-feira, 2 de maio de 2006 - Revisão: 4.0

"Comando inválido" ou "Assistente para instalação de" erros durante a instalação após o aviso chave de CD

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Depois de iniciar a instalação do Visual Studio 6 (ou um produto Visual Studio autônomo), o Visual Studio 6 Service Pack 5 ou o Visual Studio 6 Service Pack 6 no Windows NT, no Microsoft Windows 2000 ou no Microsoft Windows XP, você pode receber uma das seguintes mensagens de erro antes ou depois de inserir a chave do CD:
O programa de instalação encontrou um problema e precisa ser fechado
Assistente de instalação não pôde localizar ACME o programa de instalação
Assistente de instalação não é possível localizar ACME o programa de instalação
Instalação erro 530 linha de comando inválido
Opção de comando inválido erro 530 na \administrators\localsettings\temp\vs60wiz.exe configurações de instalação
Instalação erro 725 linha de comando inválido
Erro de aplicativo no VS60wiz.exe
Erro de inicialização de instalação; não há memória suficiente para executar o programa de instalação
Erro de inicialização de instalação; não há espaço em disco insuficiente para executar a instalação
O caminho especificado não existe. Verifique o caminho e tente novamente

Causa

O programa de instalação não terá êxito no nível do Windows NT virtual DOS Machine (NTVDM) como a instalação é entregue a Acmsetup. Isso é causado por um subsistema de 16 bits corrompido.

Resolução

Em plataformas Windows 2000, inicialize no Modo de segurança pressionando F8 quando solicitado durante a inicialização do sistema e selecionando o Modo de segurança . Tente instalar novamente.

Se a instalação não terá êxito e retorna um dos erros listados na seção "Sintomas" deste artigo, continue com as seguintes etapas:
  1. Limpar a pasta Temp, removendo qualquer instalação anterior incompleta.
    • O local padrão para a pasta TEMP no Windows 2000 é C:\Documents and Settings\ Profile \Local Settings\Temp C:\Winnt\Temp ou, se atualizou a partir do Windows 98, C:\Windows\Temp.
    • O local padrão para a pasta TEMP no Windows NT 4 é C:\WINNT\Temp C:\Temp.
    Observação : para descobrir a localização da sua pasta TEMP: no menu Iniciar , clique em Executar , digite % temp % e em seguida, clique em OK .

  2. Tente iniciar manualmente Acmsetup digitando a seguinte linha de comando:
    E : \SETUP\ACMSETUP.EXE /T *.STF /S E:\ /n "" /o""/k" YYYYYYYYYY" /b1
    onde E é a letra de unidade de CD-ROM ou DVD-ROM e YYYYYYYYYY é a chave de CD do produto (as opções de /k e o argumento devem ser omitidos para instalações de Service Pack).

    Observação: O arquivo *.stf específico que é necessário para a linha de comando manual irão variar dependendo o produto específico, que você está instalando. Pesquise a pasta \setup no CD-ROM do produto que você está instalando para *.stf usar. Por exemplo, para Visual Basic 6.0 Professional, use VB98Pro.stf.
Se você ainda não é possível instalar o produto, passando a linha de comando manualmente, continue com o seguinte para reparar o NTVDM processo.

Anular as configurações não padrão nos arquivos Config.NT e Autoexec.NT na pasta system root \System32. Para fazer isso, use uma instrução REM para marcar cada entrada , exceto as seguintes entradas padrão:
config.NT

dos = high, umb
device=%SystemRoot%\system32\himem.sys
arquivos = 20

Autoexec.NT

lh %SystemRoot%\system32\mscdexnt.exe
lh %SystemRoot%\system32\redir
lh %SystemRoot%\system32\dosx
lh %SystemRoot%\system32\nw16 (somente se o CSNW estiver instalado) *
lh %SystemRoot%\system32\vwipxspx (somente se o CSNW estiver instalado) *

* CSNW é Serviços de cliente para NetWare
Observação: Outra maneira de fazer isso é expandir Autoexec.nt_ e Config.nt_ do Windows NT ou CD-ROM do Windows 2000 para a SystemRoot \System32:
  • Para expandir um único arquivo compactado, use o expand.exe programa. Este programa está localizado no CD do Windows no I386 pasta.
  • Para expandir os arquivos necessários:
    1. Insira o CD-ROM do Windows na unidade de CD-ROM ou DVD-ROM.
    2. No prompt de comando, digite o seguinte e pressione ENTER:
      C:\WINDOWS\System32\Autoexec.NT
    3. No prompt de comando, digite o seguinte e pressione ENTER:
      EXPAND X:\i386\Config.NT_ C:\WINDOWS\System32\Config.nt
    4. Reinicie o computador e tente instalar o produto novamente.

Mais Informações

Setup.exe passa o seguinte para Acmsetup.exe:
X : \disk1\SETUP\ACMSETUP.EXE /T VS98Ent.STF /S E : \ /n "" /k" YYYYYYYYYY " /o"" /b 1

onde:
  • X é o caminho para Acmsetup.exe
  • E é a letra da unidade CD-ROM ou DVD-ROM
  • YYYYYYYYYY é a chave de CD
Você pode verificar as opções de linha de comando executando a instalação em um computador que você sabe que está funcionando corretamente, assim, criar um log de instalação.

O arquivo *.stf específicos irão variar dependendo o produto específico, que você está instalando. Pesquise a pasta \setup do produto que você está instalando para *.stf usar. Por exemplo, para Visual Basic Professional 6.0, ele é VB98Pro.stf

Gerar um arquivo de log

Você pode dizer a parte ACME da instalação para gerar um arquivo de log. Para fazer isso, inicie a instalação com o seguinte comando:
X : \setup /gc path \ file name
onde X é o local da unidade de CD-ROM ou DVD-ROM e path\file name é o nome caminho e arquivo para o arquivo de log. O caminho e o nome do arquivo deve estar no formato de nome curto 8.3 e deve não estar em entre aspas.

Referências

Para obter mais informações, clique nos números abaixo para ler os artigos na Base de dados de Conhecimento da Microsoft:
196453  (http://support.microsoft.com/kb/196453/ ) Solucionando problemas de erros de inicialização WOW e NTVDM
220155  (http://support.microsoft.com/kb/220155/ ) Solucionando problemas de erros de inicialização WOW e NTVDM
165214  (http://support.microsoft.com/kb/165214/ ) Solução de problemas MS DOS programas baseados no Windows
222975  (http://support.microsoft.com/kb/222975/ ) Não é possível instalar programa usando o utilitário de instalação
260513  (http://support.microsoft.com/kb/260513/ ) Um erro ocorre ao instalar produtos do Visual Studio
192392  (http://support.microsoft.com/kb/192392/ ) Como solucionar problemas de instalação do Visual Studio 6.0
192731  (http://support.microsoft.com/kb/192731/ ) Erro: Travar ou erro de aplicativo na instalação

A informação contida neste artigo aplica-se a:
  • Microsoft Visual Studio 6.0 Enterprise Edition
  • Microsoft Visual Basic 6.0 Learning Edition
  • Microsoft Visual Basic 6.0 Professional Edition
  • Microsoft Visual Basic Enterprise Edition for Windows 6.0
  • Microsoft Visual C++ 6.0 Enterprise Edition
  • Microsoft Visual C++ 6.0 Professional Edition
  • Microsoft Visual C++, 32-bit Learning Edition 6.0
  • Microsoft Visual InterDev 6.0 Standard Edition
  • Microsoft Visual FoxPro 6.0 Professional Edition
  • Microsoft Visual J++ 6.0 Standard Edition
  • Microsoft Visual SourceSafe 6.0 Standard Edition
Palavras-chave: 
kbmt kbprb KB250343 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine Translation ou MT), não tendo sido portanto traduzido ou revisto por pessoas. A Microsoft possui artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais, com o objetivo de oferecer em português a totalidade dos artigos existentes na base de dados de suporte. No entanto, a tradução automática não é sempre perfeita, podendo conter erros de vocabulário, sintaxe ou gramática. A Microsoft não é responsável por incoerências, erros ou prejuízos ocorridos em decorrência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza atualizações freqüentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 250343  (http://support.microsoft.com/kb/250343/en-us/ )