You receive a "One or more users need an assigned license in order to retain an Exchange Online mailbox or archive" message on the Users page of the Office 365 pre-upgrade portal

Article translations Article translations
Article ID: 2506570 - View products that this article applies to.
Not sure what release of Office 365 you're using? Go to the following Microsoft website:
Am I using Office 365 after the service upgrade?
Expand all | Collapse all

PROBLEM

When you view the Users page of the Office 365 pre-upgrade portal in Microsoft Office 365 pre-upgrade, you receive the following message:
One or more users need an assigned license in order to retain an Exchange Online mailbox. Create a new view and select “Users with mailboxes and no licenses.” Select all users in the list, and then click “Edit” to assign licenses.

Additionally, you experience the following symptoms:
  • Exchange Online licenses are missing for users who were created in Exchange Control Panel or in Exchange Online PowerShell.
  • Sudden mailbox loss for users who were created in Exchange Control Panel or Exchange Online PowerShell.

CAUSE

This occurs if the user mailboxes are created in the Exchange Control Panel, and the users aren't yet assigned a license.

SOLUTION

Create a view in the Office 365 pre-upgrade portal to display a list of users who have mailboxes but who don't have a license. To do this, follow these steps:
  1. Sign in to the Office 365 pre-upgrade portal (https://portal.microsoftonline.com).
  2. In the left navigation pane, under Management, click Users.
  3. On the Users page, click New view in the View drop-down list.
  4. On the "New view" page, follow these steps:
    1. In the Name your view box, type Users with no mailboxes and no licenses.
    2. Under Select an account status to further restrict the view, click to select the Users with mailboxes and no licenses check box.
    3. Click Save.
  5. On the Users page, click Users with mailboxes and no licenses in the View drop-down list to view the list of users who have mailboxes but who aren't yet assigned a license.
Note To assign a license to a user, click to select the check box next to the name of the user, and then click Edit. On the "Assign licenses" page, click to select the check boxes next to the items that you want to assign, and then click Save.

MORE INFORMATION

Users must be assigned a license, or the mailbox is deleted. From the time that the user mailbox is created in Exchange Control Panel, admins have 60 days to assign the user a license in the Office 365 pre-upgrade portal.

Still need help? Go to the Office 365 Community website.

Properties

Article ID: 2506570 - Last Review: November 15, 2013 - Revision: 15.0
Applies to
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for small businesses  (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Microsoft Exchange Online
Keywords: 
o365 o365a o365e o365p o365m o365062011 pre-upgrade KB2506570

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com