Códigos de error de "0x8007066A" o "66A" se producen al instalar las actualizaciones de.NET Framework

Seleccione idioma Seleccione idioma
Id. de artículo: 2507641 - Ver los productos a los que se aplica este artículo
El período de soporte técnico para Windows Vista sin ningún service Pack instalado finalizó el 13 de abril de 2010. Para seguir recibiendo actualizaciones de seguridad para Windows, asegúrese de que está ejecutando Windows Vista con Service Pack 2 (SP2). Para obtener más información, consulte esta página Web de Microsoft: Finaliza el soporte técnico para algunas versiones de Windows
Expandir todo | Contraer todo

Síntomas

Cuando intenta instalar actualizaciones para el.NET Framework mediante Windows Update o Microsoft Update, puede recibir un error que tiene uno de los códigos de error siguiente:
  • código de error 0x8007066A
  • código de error 66A
Nota Si no va a instalar las actualizaciones de.NET Framework cuando reciba el código de error 0x8007066A, visite el siguiente artículo de pasos para solucionar problemas:
2545723 Cómo habilitar Microsoft instalador y un registro detallado para recopilar información adicional de solución de problemas

Causa

Este problema puede deberse a daños en el sistema en el equipo. Esto puede ocurrir por varios motivos, incluyendo pero sin limitarse a los sectores dañados en el disco duro o cualquier otra aplicación sobrescriba los archivos. NET.

Solución

Para solucionar este problema, siga los pasos de estos métodos, empezando por el método 1.
Método 1: Reparar la instalación de.NET Framework 4
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Si está ejecutando Windows Vista o Windows 7, siga estos pasos:
  1. Cierre todos los programas.
  2. Haga clic en Inicio, tipo Desinstalar en la búsqueda de la caja y, a continuación, haga clic en desinstalar un programa.
  3. Haga doble clic en el perfil del cliente 4 de Microsoft.NET Framework.
  4. Seleccione Reparar.NET Framework 4 Client Profile a su estado originaly, a continuación, haga clic en siguiente.
  5. Una vez finalizada la reparación, haga clic en Finalizar.
  6. Haga clic en Reiniciar ahora para reiniciar el equipo.
  7. Para instalar las actualizaciones más recientes de Windows, haga clic en Inicio, haga clic en Todos los programasy, a continuación, haga clic en Windows Update.

Si está ejecutando Windows XP, siga estos pasos:
  1. Cierre todos los programas.
  2. Haga clic en Inicio, haga clic en Panel de Controly, a continuación, haga clic en Agregar o quitar programas.
  3. Haga clic en Microsoft.NET Framework 4 Client Profile en la lista de las aplicaciones instaladas y, a continuación, haga clic en Change\Remove.
  4. Seleccione Reparar.NET Framework 4 Client Profile a su estado originaly, a continuación, haga clic en siguiente.
  5. Una vez finalizada la reparación, haga clic en Finalizar.
  6. Haga clic en Reiniciar ahora para reiniciar el equipo.
  7. Después de iniciar sesión en Windows, haga clic en Inicio, haga clic en Todos los programas, haga clic en Actualizaciones de Windowsy, a continuación, haga clic en Buscar actualizaciones.
  8. Una vez finalizada la exploración, haga clic en Instalar actualizaciones de Windowsy, a continuación, siga las instrucciones.

Si no se hubiera resuelto, vaya al método 2.
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed
Método 2: Corregir problemas de daños en el registro MSI software update
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Para corregir el registro de actualización de software MSI problemas de daños, ejecute el automatizado corregirlo herramienta en el artículo 971187 en Microsoft Knowledge Base.

Después de ejecutar la revisión la herramienta, haga clic en Inicio, haga clic en todos losprogramasy, a continuación, haga clic en Windows Update. Intente volver a instalar las actualizaciones.

Si no se hubiera resuelto, vaya al método 3.
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed
Método 3: Descargar e instalar la actualización manualmente
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
Para descargar e instalar las actualizaciones manualmente, siga estos pasos:
  1. Haga clic en Inicio, haga clic en Todos los programasy, a continuación, haga clic en Windows Update o Actualización de Microsoft.
  2. Para ver el historial de actualizaciones, realice una de las opciones siguientes según su versión de Windows:
    • Si está ejecutando Windows XP, haga clic en Revisar el historial de actualizacionesen el panel izquierdo del Panel de Control.
    • Si está ejecutando Windows Vista o Windows 7, haga clic en Ver historial de actualizacionesen el panel izquierdo del Panel de Control.
  3. En la lista de actualizaciones, busque la actualización que contiene el mensaje de error y tenga en cuenta el número de artículo de Knowledge Base (KB) para la actualización que desea instalar.
  4. Vaya a la Descargas de Windows .
  5. En el Centro de descarga de la búsqueda cuadro en la parte superior de la página, tipo KB y, a continuación, escriba el número de artículo para la actualización.
    Contraer esta imagenAmpliar esta imagen
    Centro de descarga de la búsqueda


  6. Presione ENTRAR o haga clic en el icono de búsqueda.

    Por ejemplo, si el número de artículo KB que se muestra para la actualización es 123456, escriba KB123456 en la búsqueda de la caja y, a continuación, presione ENTRAR o haga clic en el icono de búsqueda (el icono de búsqueda tiene una lupa blanca sobre un cuadrado de color naranja).
  7. En la lista de Resultados de la búsqueda , busque el artículo de KB que busca y, a continuación, vaya a dicho artículo.
  8. Haga clic en Descargary, a continuación, haga clic en Guardar en el cuadro de diálogo Descarga de archivos .
    Contraer esta imagenAmpliar esta imagen
    Cuadro de diálogo de descarga


  9. En la lista Guardar en , haga clic en escritorioy, a continuación, haga clic en Guardar.
  10. En el escritorio, busque el archivo que ha descargado y, a continuación, haga doble clic en el archivo para instalar la actualización.

Nota Si la actualización no es adecuada para su equipo, todavía puede fallar la instalación.
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed
Método 4: Reparación de.NET Framework
Contraer esta imagenAmpliar esta imagen
assets folding start collapsed
 

Para reparar el.NET Framework, primero debe desinstalar varias versiones de la de.NET Framework mediante la herramienta de limpieza de.NET Framework. A continuación, vuelva a instalar los componentes.

Para ello, siga estos pasos:
  1. Para descargar la herramienta, vaya a la siguiente entrada de blog MSDN:
    Guía del usuario de herramienta de.NET Framework Liberador de espacio
  2. Una vez finalizada la descarga, haga clic en Ver las descargas.

    Contraer esta imagenAmpliar esta imagen
    DotNetfx Liberador de espacio
  3. En la carpeta de descargas, haga clic en dotnetfx_cleanup_tool.zip, haga clic en extraer todoy, a continuación, haga clic en Extraer.
  4. En la lista de los archivos extraídos, haga doble clic en Cleanup_tool.exe.

    Nota Si se le pide una contraseña de administrador o de confirmación, proporcionar la contraseña o la confirmación o haga clic en Continuar.
  5. En el ¿Desea ejecutar la herramienta de limpieza del programa de instalación de.NET Framework el mensaje, haga clic en .

    Nota Esta herramienta puede estar sólo en inglés, pero también funciona para otras versiones de idioma de Windows.
  6. Haga clic en para aceptar el contrato de licencia y, a continuación, espere a que la herramienta de limpieza de.NET Framework iniciar.
  7. En productos de limpieza, haga clic en la lista, seleccioneNET Framework - todas las versionesy , a continuación, haga clic en Liberador de espacio.

    Nota
    la herramienta Liberador de espacio no permite quitar la versión 2.0 de.NET Framework en Windows Vista o versiones posteriores de Windows porque el.NET Framework se instala como un componente del sistema operativo.
  8. Después de quitar el.NET Framework, reinicie el equipo.
  9. Descargue e instale los siguientes componentes:

    El.NET Framework 1.1:
    http://www.Microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=262d25e3-f589-4842-8157-034d1e7cf3a3

    El .NETFramework 1.1 SP1:
    http://www.Microsoft.com/downloads/details.aspx?FamilyID=a8f5654f-088e-40b2-bbdb-a83353618b38&displaylang=en

    ElNET Framework 3.5 SP1 (Esto también instala.NET Framework 2.0 Service Pack 2 y el de.NET Framework 3.0 Service Pack 2)
    http://www.Microsoft.com/downloads/details.aspx?FamilyID=AB99342F-5D1A-413D-8319-81DA479AB0D7&displaylang=en
  10. Apague y reinicie el equipo.
  11. Haga clic en Inicio, haga clic en Todos los programas, haga clic en Windows Updatey, a continuación, intente volver a instalar las actualizaciones.

Para obtener más información acerca de la herramienta de limpieza de.NET Framework, vaya a la Guía del usuario de herramienta de.NET Framework Liberador de espacio entrada de blog.
Contraer esta imagenAmpliar esta imagen
assets folding end collapsed


Obtener más información:

Si estos pasos no resolvió su problema, debe recopilar información de registro adicional para solucionar el problema. Para ello, siga los pasos descritos en el siguiente artículo de Microsoft Knowledgebase:

¿AÚN NECESITA AYUDA?

Si este artículo no responde a su pregunta, haga clic en este botón para pedir a otros miembros de la Comunidad en el Microsoft Community:
Formule una pregunta

Propiedades

Id. de artículo: 2507641 - Última revisión: viernes, 12 de julio de 2013 - Versión: 16.1
La información de este artículo se refiere a:
  • Microsoft Windows XP Home Edition
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Starter Edition
  • Windows Vista Starter
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Business
  • Windows Vista Ultimate
  • Windows Server 2008 Standard
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Foundation
  • Windows 7 Starter
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
Palabras clave: 
kbmt KB2507641 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2507641

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com