"LogonUser() Failed with error code: 1789" after you enter enterprise administrator credentials in the Directory Sync Tool Configuration Wizard in Office 365

Article ID: 2508225 - View products that this article applies to.

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PROBLEM

After you enter your enterprise admin credentials in the Windows Azure Active Directory Sync Tool Configuration Wizard, you receive the following error message:

LogonUser() Failed with error code: 1789

This issue occurs in an Office 365 environment.

CAUSE

This issue typically occurs when the computer on which you are running the Directory Sync Tool can't authenticate with Active Directory.

SOLUTION

To resolve this issue, use one or more of the following methods:
  • Restart the computer.
  • Join the computer to a workgroup and then join the computer back to the domain. To do this, follow these steps:
    1. Click Start, right-click Computer, and then click Properties.
    2. Under Computer name, domain, and workgroup settings, click Change Settings.
    3. Click the Computer Name tab, and then click Change.
    4. Select the Workgroup option, and then type a workgroup in the Workgroup dialog box.
    5. Restart the computer.
    6. Repeat steps 1 through 3.
    7. Select the Domain option, and then type the domain name in the Domain dialog box to add the computer back to the domain.
    8. Restart the computer.

Still need help? Go to the Office 365 Community website.

Properties

Article ID: 2508225 - Last Review: May 31, 2013 - Revision: 14.0
Applies to
  • Microsoft Office 365 for enterprises (pre-upgrade)
  • Microsoft Office 365 for education  (pre-upgrade)
  • Windows Azure Active Directory
Keywords: 
o365 o365a o365e o365m o365022013 after upgrade o365062011 pre-upgrade KB2508225

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