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Symptoms

Consider the following scenario:

  • You create a task sequence on a Microsoft System Center Configuration Manager 2007 Service Pack 2 (SP2) site server to install many updates.

    For example, the task sequence installs 80 updates.

  • You advertise the task sequence to a client computer.

In this scenario, the task sequence stops responding when the "Download <sequence number> of <total number> updates" message is displayed on the screen of the client computer.

Notes

  • <sequence number> is a placeholder that represents the update number for the update that is currently being downloaded.

  • <total number> is a placeholder that represents the total number of updates that are scheduled to be downloaded.

Cause

This issue occurs because a deadlock occurs when the task sequence retrieves content locations for the updates.

Resolution

To resolve this issue, install the following hotfix package on a System Center Configuration Manager primary site. This hotfix package cannot be installed on a secondary site.

You must install the hotfix package on the site server and then deploy the generated packages to the client computer.

Note You can install this hotfix package (Sccm2007-sp2-2509007-x86-enu.msi) on a System Center Configuration Manager 2007 SP2 site server that is running an x86-based or x64-based version of a Windows operating system.

For more information about how to install a System Center Configuration Manager 2007 hotfix, click the following article number to view the article in the Microsoft Knowledge Base:

2477182 System Center Configuration Manager 2007 Hotfix Installation Guidance

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running System Center Configuration Manager 2007 Service Pack 2 (SP2).

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You do not have to restart the computer after you apply this hotfix.

Note Before you install this hotfix package, you have to close the Configuration Manager administrative console.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The English (United States) version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

System Center Configuration Manager 2007 SP2 file information notes

File name

File version

File size

Date

Time

Platform

Sccm2007ac-sp2-kb2509007-x86-enu.msp

Not applicable

594,944

01-Feb-2010

16:15

Not applicable

Updateshandler.dll

4.0.6487.2188

389,992

01-Feb-2010

16:15

x86

Note Some other files may be updated because of dependencies. However, the binary code of these files is not changed.

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

Install KB2509007 during a task sequence

The KB2509007 hotfix must be installed during a ConfigMgr 2007 OSD task sequence in the Setup Windows and ConfigMgr task. Otherwise, the problem will continue to occur while the task sequence is executed. The hotfix cannot be installed by using an "install software task." Doing that would cause the ConfigMgr 2007 client service to stop, which will cause the task sequence to fail. 

To install the KB2509007 hotfix during a ConfigMgr 2007 OSD task sequence, use the PATCH= option that is described in the following Microsoft Knowledge Base article:

907423 How to include an update in the initial installation of Systems Management Server 2003 Advanced Client


To install the KB2509007 hotfix during a ConfigMgr 2007 OSD task sequence, follow these steps:

  1. Apply this hotfix on the site server.

  2. After the hotfix is applied on the site server, the Configuration Manager 2007 client installation files are updated to include this hotfix in the \i386\hotfix\KB2509007\ directory of the Configuration Manager 2007 client installation files. Because the Configuration Manager 2007 client installation files are updated, make sure that you update the distribution points where the Configuration Manager 2007 client installation package resides.

  3. Right-click the task sequence that you have to change, and then click Edit.

  4. Click Setup windows and ConfigMgr.

  5. In the Installation properties box, type the following:

    PATCH="C:\_SMSTaskSequence\OSD\<Package_ID>\i386\hotfix\KB2509007\sccm2007ac-sp2-kb2509007-x86-enu.msp"Notes

    • The <Package_ID> placeholder represents the package ID of the Configuration Manager 2007 client installation package in Configuration Manager 2007.

    • Make sure that you include the quotation marks as part of the path. However, do not include the brackets that are around the placeholder.

    • Make sure that the package ID of the Configuration Manager 2007 client installation package is used instead of the package ID of the KB2509007 hotfix package.

    • The _SMSTaskSequence cache folder will reside on the drive that has the most disk space. If the computer has multiple drives or partitions, the _SMSTaskSequence folder may end up on a drive other than drive C. In this scenario, change the path to point to the drive that contains the _SMSTaskSequence folder. It is not recommend to use the variable _SMSTSMDataPath in the path because the drive letter in this path can enumerate differently in Windows PE than in the full Windows operating system.

    • As an alternative to the local path that points to the Configuration Manager 2007 client installation files in the local Task Sequence cache, you can specify a UNC path that points to the Configuration Manager 2007 client installation files in the original package source or on a distribution point.

    • Verify the name of the .msp file that is located in the \i386\hotfix\KB\2509007\ directory of the ConfigMgr 2007 client installation files. The name may differ depending on the locale. If the name differs from the name of the .msp file name that is used in the PATCH= command line in this step, adjust the name accordingly.

  6. Click Apply or OK to save the task sequence.

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684

Description of the standard terminology that is used to describe Microsoft software updates

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