Odebrání duplicitních složek v aplikaci Outlook při připojení k poštovní schránce Exchange Server

Příznaky

V aplikaci Microsoft Outlook uvidíte duplicitní složky v poštovní schránce Microsoft Exchange Server, když zobrazíte seznam složek aplikace Outlook nebo když zobrazíte seznam složek pomocí aplikace Outlook Web App (OWA).

Příčina

U mobilního zařízení nebo serverové aplikace jiného výrobce, která se synchronizuje s Exchange Server poštovní schránkou, může dojít k neočekávanému zdvojení. Neočekávaná duplikace může být také výsledkem údržby Exchange Server poštovní schránky nebo jiných změn provedených v počítači, na kterém běží Exchange Server. K problému popsanému v části Příznaky v tomto článku můžou přispívat i další faktory.

Řešení

Následující kroky můžou vést ke ztrátě dat, pokud je nedodržujete přesně tak, jak jste napsali. Než budete pokračovat v těchto krocích, doporučujeme zálohovat data Outlooku nebo se ujistit, že je poštovní schránka Exchange Server zálohovaná.

Chcete-li odstranit duplicitní položky, postupujte takto:

  1. Ukončete aplikaci Outlook a zavřete aplikaci OWA na všech pracovních stanicích, které jsou připojené k poštovní schránce uživatele.

  2. Použijte MFCMapi k identifikaci duplicitních složek. Postupujte takto:

    1. Stáhněte si MFCMAPI (posuňte se dolů a vyberte Nejnovější verze).
    2. Spusťte MFCMAPI.exe.
    3. Vyberte nabídku Nástroje a pak vyberte Možnosti.
    4. Povolte následující možnost:
      • Použití MDB_ONLINE při volání OpenMsgStore
    5. Vyberte OK.
    6. V nabídce Relace vyberte Přihlásit.
    7. Pokud se zobrazí výzva k zadání profilu, vyberte název profilu a pak vyberte OK.
    8. V horním podokně vyhledejte řádek, který odpovídá vaší poštovní schránce, a poklikejte na něj.
    9. V navigačním podokně (podokno vlevo) rozbalte kořenový kontejner a pak rozbalte horní část úložiště informací.
    10. Pokud chcete identifikovat duplicitní složku, vyberte jednu z duplicitních složek v levém podokně. V pravém podokně vyhledejte sloupec Hodnota vlastnosti PR_CREATION_TIME . Porovnejte tuto hodnotu s duplicitní složkou se stejným názvem. Duplicitní složka bude mít novější datum a čas vytvoření. Pracujte s jednou dvojicí složek najednou (začněte například dvěma složkami Kalendáře, které se zobrazí).
  3. Pomocí MFCMAPI zkopírujte všechny položky z duplicitní složky do původní složky. Jedná se o položky vytvořené po vytvoření duplicitních složek. To může zahrnovat e-maily přijaté ve složce Doručená pošta, vytvořené kontakty, události kalendáře, které jste naplánovali, a schůzky, které jste přijali.

    1. V levém podokně MFCMAPI poklikejte na duplicitní složku, která má novější datum a čas vytvoření.

    2. V okně, které se otevře, vyberte horní podokno a stisknutím kombinace kláves CTRL+A vyberte všechny položky.

      Pokud se v horním podokně nezobrazí žádné položky, složka je již prázdná; přejděte ke kroku 7.

    3. Vyberte nabídku Akce a pak vyberte příkaz Kopírovat zprávy .

    4. Zavřete okno složky a poklikejte na původní složku se starším datem a časem vytvoření.

    5. Vyberte nabídku Akce a pak vyberte příkaz Vložit zprávy .

    6. Zaškrtněte políčko MESSAGE_MOVE a pak vyberte OK.

    7. Zavřete okno složky.

  4. V MFCMAPI přepněte zpět do duplicitní složky, která je nyní prázdná. Pomocí MFCMAPI ho odstraňte.

    1. Klikněte pravým tlačítkem na duplicitní složku a pak vyberte Odstranit složku.
    2. Povolte možnost Pevného odstranění a pak vyberte OK.
  5. Opakujte kroky 2 až 4 pro další běžné složky Outlooku (Kontakty, Odstraněná pošta, Koncepty, Doručená pošta, Deník, Nevyžádaná pošta, Poznámky, Odeslaná pošta a Úkoly).

  6. Zavřete MFCMAPI.

  7. Spusťte Outlook pomocí resetfolders přepínače:

    1. Otevřete dialogové okno Spustit. Chcete-li to provést, použijte jeden z následujících postupů, který je vhodný pro vaši verzi systému Windows.

      Windows 10, Windows 8.1 a Windows 8: Stiskněte klávesy Windows+R.
      Windows 7 a Windows Vista: Vyberte tlačítko Start , přejděte na Všechny programy, vyberte Příslušenství a pak vyberte Spustit.
      Windows XP: Vyberte tlačítko Start ve Windows a pak vyberte Spustit.

    2. V dialogovém okně Spustit zadejte následující příkaz a pak vyberte OK :

      Outlook.exe /resetfolders

Další informace

Další informace o přepínačích příkazového řádku v Outlooku najdete v tématu Přepínače příkazového řádku pro produkty Microsoft Office.