Impossible d'installer les mises à jour dans Windows Vista, Windows 7, Windows Server 2008 et Windows Server 2008 R2

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Sommaire

Symptômes

Lorsque vous essayez d'installer une mise à jour Windows, vous essayez d'installer un composant Windows, ou vous essayez d'installer un Microsoft ou un logiciel tiers, vous rencontrez un ou plusieurs des problèmes suivants :
  • Vous ne pouvez pas afficher les rôles de Windows ou des fonctionnalités.
  • Installation du service pack échoue.
  • Lorsque vous essayez de vous connecter au site Web Microsoft Windows Update ou au site Web de Microsoft Update, un des codes d'erreur suivants est enregistré dans le journal de Windows Update (windowsupdate.log) ou dans le journal Component Based Servicing (CBS.log) :
    • 0xC80001FE
    • 0x80200010
    • 0 x 80070643
    • 0 x 80246002
    • 0 x 80070490
    • 0x80070420
    • 0 x 80073712
    • 0 x 80246007
    • 0x8000ffff
    • 0 x 80070424
    • 0x80248007
    • 0x8007064C
    • 0x8024D00C
    • 0x8007066A
    • 0 x 80245003
    • 0x8024402C

Cause

Ce problème peut se produire si une ou plusieurs des conditions suivantes sont remplies :
  • La base de données mise à jour de Windows est endommagé.
  • Un logiciel antivirus est configuré pour analyser le dossier %Windir%\SoftwareDistribution.
  • Le service Service de transfert Intelligent en arrière-plan (BITS) ne reçoit pas un en-tête lien de contenu.
  • Un fichier système requis est incorrectement enregistré.
  • Windows Installer a rencontré une erreur.
  • Le manifeste Component Based Servicing (CBS) est endommagé.
  • Le service Windows Opdate arrêté lors de l'installation.
  • Il existe un conflit de version de fichier avec les fichiers de l'agent Windows Update.

Résolution

Pour résoudre ce problème, essayez les méthodes suivantes. Après avoir effectué les étapes de chaque méthode, effectuez un test pour voir si le problème est résolu avant de passer à la méthode suivante. Si le problème est résolu par n'importe quelle méthode, vous n'avez pas à utiliser les autres méthodes.

Méthode 1: redémarrez votre ordinateur, puis essayez de nouveau d'installer les mises à jour

Fermez tous les programmes en cours d'exécutant et redémarrez votre ordinateur puis essayez de nouveau d'installer les mises à jour.

Remarque Redémarrage de l'ordinateur va s'assurer que toutes les installations précédentes ont terminé et qu'aucun processus restants ne nécessitent un redémarrage du système avant, il peut terminer.

Méthode 2: Exécuter l'outil de préparation de mise à jour système (CheckSur.exe)

Téléchargez et exécutez l'outil de préparation de mise à jour système. Cet outil s'exécute une analyse ponctuelle des incohérences qui peuvent empêcher les futures opérations de maintenance. Pour plus d'informations sur la façon de télécharger et d'exécuter l'outil CheckSur.exe, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
947821 Description de l'outil de préparation de mise à jour système pour Windows Vista, Windows Server 2008, Windows 7 et Windows Server 2008 R2
Essayez d'installer les mises à jour à nouveau.

Remarque Après avoir exécuté l'outil, le fichier CheckSur.log est enregistré à l'emplacement suivant :
%SystemRoot%\Logs\CBS

Méthode 3: Exécution de l'outil Vérificateur des fichiers système (SFC.exe)

Exécutez l'outil Vérificateur des fichiers système (SFC.exe). Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d'invite de commandes d'administration.
  2. À l'invite de commandes, tapez sfc/scannow, puis appuyez sur entrée.
  3. Une fois l'analyse terminée, essayez de réinstaller les mises à jour.

Méthode 4: Réinitialiser le contenu du dossier Catroot2

Réinitialiser le contenu du dossier Catroot2. Pour ce faire, procédez comme suit :
  1. Tapez les commandes suivantes et appuyez sur ENTRÉE après chaque commande :
    • net stop cryptsvc
    • MD %systemroot%\system32\catroot2.old
    • xcopy %systemroot%\system32\catroot2 %systemroot%\system32\catroot2.old /s
  2. Supprimez tout le contenu du dossier catroot2, mais ne supprimez pas le dossier catroot2.
  3. Tapez la commande suivante et appuyez sur Entrée :
    Net start cryptsvc
  4. Quittez la fenêtre d'invite de commandes.

Méthode 5 : supprimez les valeurs de Registre incorrectes

Supprimez les valeurs incorrectes qui peuvent exister dans le Registre. Pour ce faire, procédez comme suit :
  1. Cliquez sur Démarrer, puis tapez Regedit dans la zone Démarrer la recherche .
  2. Dans la liste desprogrammes , cliquez sur regedit.exe.
  3. Recherchez, puis sélectionnez la sous-clé de Registre suivante :
    HKEY_LOCAL_MACHINE\COMPONENTS
  4. Cliquez surcomposants.
  5. Cliquez sur Exporter.
  6. Dans la zoneNom de fichier , tapez composants.
  7. Dans la zone Enregistrer dans , cliquez sur Bureau, sur Enregistrer, puis enregistrez le fichier sur votre Bureau.
  8. Dans le volet d'informations, cliquez avec le bouton droit sur PendingXmlIdentifier, puis cliquez sur Supprimer. Si cette valeur n'existe pas, passez à l'étape suivante.
  9. Dans le volet de détails, droit de la souriscliquez sur NextQueueEntryIndex, puis cliquez sur Supprimer. Si cette valeur n'existe pas, passez à l'étape suivante.
  10. Dans le volet de détails, cliquez avec le bouton droit de la souris surAdvancedInstallersNeedResolving, puis cliquez sur Supprimer. Si la valeur n'existe pas, passez à l'étape suivante.
  11. Redémarrez l'ordinateur.
  12. Essayez de nouveau d'installer les mises à jour.
Méthode 6 : enregistrez les fichiers de mise à jour de Windows
Enregistrez les fichiers de mise à jour de Windows. Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d'invite de commandes d'administration.
  2. À l'invite de commandes, tapez la commande suivante :
    REGSVR32 WUPS2.DLL /S
    REGSVR32 WUPS.DLL /S
    REGSVR32 WUAUENG.DLL /S
    REGSVR32 WUAPI.DLL /S
    REGSVR32 WUCLTUX.DLL /S
    REGSVR32 WUWEBV.DLL /S
    REGSVR32 JSCRIPT.DLL /S
    REGSVR32 MSXML3.DLL /S
  3. Essayez d'installer les mises à jour à nouveau.

Méthode 7 : assurez-vous que votre application antivirus n'analyse pas certains fichiers

Assurez-vous que votre application antivirus n'analyse pas les fichiers dans le répertoire %windir%\SoftwareDistribution sur n'importe quel ordinateur sur lequel est installé l'Agent Windows Update.

Pour les ordinateurs qui exécutent Windows Server 2003, Microsoft Windows 2000, Windows XP, Windows Vista ou Windows Server 2008, n'analysez pas les fichiers et dossiers suivants.

Remarque : Ces fichiers ne sont pas soumis au risque d'infection. Si vous analysez ces fichiers, de graves problèmes de performances peuvent se produire car certains fichiers peuvent être verrouillés. Si un jeu spécifique de fichiers est identifié par son nom, excluez uniquement ces fichiers au lieu du dossier entier. Parfois, le dossier complet doit être exclu. N'excluez pas ces éléments en fonction de l'extension de nom de fichier. Par exemple, n'excluez pas tous les fichiers ayant une extension .dit. Microsoft n'a aucun contrôle sur les autres fichiers qui peuvent utiliser les mêmes extensions que ces fichiers.
  • Fichiers qui sont liés à Microsoft Windows Update ou à la mise à jour automatique
  • Le fichier de base de données de Windows Update ou le fichier de base de données de mise à jour automatique

    Remarque : Ce fichier (Datastore.edb) se trouve dans le répertoire suivant :
    %windir%\SoftwareDistribution\Datastore
  • Les fichiers journaux des transactions

    Remarque : Ces fichiers sont situés dans le dossier suivant :
    %windir%\SoftwareDistribution\Datastore\Logs
Excluez les fichiers suivants :
  • Edb*.log

    Remarque : Le caractère générique indique la présence possible de plusieurs fichiers.
  • Res1.log
  • Res2.log
  • Edb.chk
  • Tmp.edb

Méthode 8 : renommez le dossier SoftwareDistribution

Renommez le dossier SoftwareDistribution temporaire de Windows Update. Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d'invite de commandes d'administration.
  2. Exécutez les commandes suivantes et appuyez sur Entrée après chaque commande :
    • Net stop wuauserv
    • CD %systemroot%
    • Ren SoftwareDistribution SoftwareDistribution.old
    • Net start wuauserv
  3. Essayez d'installer les mises à jour à nouveau.
Important : Les problèmes suivants se produisent lorsque vous utilisez cette méthode :
  • Les mises à jour qui sont actuellement téléchargées mais qui n'ont pas encore été installées doivent être téléchargées à nouveau à l'aide de Windows Update ou Microsoft Update.
  • Lorsque vous supprimez le dossier SoftwareDistribution, l'historique des téléchargements est supprimé.
  • Si vous recevez actuellement des mises à jour de Microsoft Update et de Windows Update, vous devrez resélectionner cette option depuis le site Web de Windows Update.
Remarque : Si le problème est résolu et que vous pouvez télécharger et installer les mises à jour, vous pouvez supprimer en toute sécurité le dossier SoftwareDistribution.old pour récupérer l'espace disque.

Méthode 9 : effacez la file d'attente BITS de tous les travaux en cours

Désactivez tous les travaux en cours de la file d'attente BITS. Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d'invite de commandes d'administration.
  2. À l'invite de commandes, tapez les commandes suivantes et appuyez sur Entrée après chaque commande :

    Net stop bits
    Net stop wuauserv
    Ipconfig /flushdns
    cd \documents and settings\all users\application data\microsoft\network\downloader
    Del qmgr0.dat
    Del qmgr1.dat
    Net start bits
    Net start wuauserv
    Remarque :
    Après avoir effectué ces étapes, la file d'attente BITS est désactivée.
  3. Essayez d'installer les mises à jour à nouveau.

Méthode 10 : téléchargez et installez manuellement la mise à jour 958056

Téléchargez et installez manuellement la mise à jour KB 958056. Pour ce faire, procédez comme suit :
  1. Déterminez le numéro de l'article de Base de connaissances Microsoft relatif à l'échec de la mise à jour. Pour ce faire, effectuez l'une des opérations suivantes : afficher le message de code d'erreur.
    • Permet d'afficher le message du code d'erreur.
    • Afficher l'historique de mise à jour sur le site Web de Windows Update ou sur le site Web de Microsoft Update. Pour ce faire, procédez comme suit :
      1. Visitez le site Web de Microsoft Update suivant :
        http://Update.Microsoft.com
      2. Sous Options, cliquez sur consulter l'historique des mises à jour.
      3. Dans la colonne Mise à jour, déterminez le numéro de l'article de Base de connaissances Microsoft relatif à l'échec de la mise à jour.
  2. Visitez le site Web de téléchargement de Windows suivant :
    http://www.Microsoft.com/Windows/downloads/default.aspx
  3. Dans la zone Rechercher dans la page Web de téléchargement, tapez le numéro que vous avez localisé à l'étape 1, puis cliquez sur Go.
    Remarque : N'incluez pas les lettres « kb » lorsque vous tapez le numéro de l'article. Par exemple, tapez « kb123456 » en tant que 123456.
  4. Parcourez la liste de contenu renvoyé pour rechercher l'article de la Base de connaissances qui comporte un lien vers le téléchargement.
    Remarque : Vous pouvez être invité à valider Windows. Si c'est le cas, suivez les instructions pour valider Windows, puis continuez à télécharger la mise à jour.
  5. Cliquez sur Télécharger, puis cliquez sur Enregistrer lorsque vous êtes invité à enregistrer le fichier téléchargé. Enregistrez le fichier téléchargé sur votre Bureau.
  6. Une fois le téléchargement terminé, cliquez sur Ouvrir pour installer la mise à jour.
    Remarque L'installation de la mise à jour peut échouer si la mise à jour est inappropriée pour votre version de Windows.

Méthode 11 : renommez Pending.xml

Renommez le fichier Pending.xml. Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d'invite de commandes d'administration.
  2. À l'invite de commandes, tapez la commande suivante :
    takeown /f C:\Windows\winsxs\pending.xml
  3. Renommez le chemin d'accès c:\windows\winsxs\pending.xml à l'aide de la commande suivante :
Ren c:\windows\winsxs\pending.xml pending.old

Méthode 12 : exécutez Chkdsk sur la partition Windows

Exécutez une vérification de disque sur la partition Windows. Pour ce faire, procédez comme suit :
  1. Ouvrez une fenêtre d'invite de commandes d'administration.
  2. À l'invite de commandes, tapez la commande suivante :
    Chkdsk volume: /f /r

Propriétés

Numéro d'article: 2509997 - Dernière mise à jour: samedi 17 mai 2014 - Version: 24.0
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  • Windows Vista Entreprise
  • Windows Vista Édition Familiale Basique
  • Windows Vista Édition Familiale Premium
  • Windows Vista Starter
  • Windows Vista Édition Intégrale
  • Windows 7 Entreprise
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  • Windows 7 Professionnel
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