Windows Vista、Windows 7、Windows Server 2008、Windows Server 2008 R2 で更新プログラムをインストールできない

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文書番号: 2509997 - 対象製品
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目次

現象

Windows または Windows コンポーネントの更新プログラムのインストール時、またはマイクロソフトやサードパーティ製のソフトウェア プログラムのインストール時に、以下のいずれかまたは複数の現象が発生することがあります。
  • Windows の役割と機能を表示できない。
  • Service Pack のインストールに失敗する。
  • Microsoft Windows Update Web サイトまたは Microsoft Update Web サイトへの接続時に、次のいずれかのエラー コードが Windows Update のログ (windowsupdate.log) またはコンポーネントベース サービスのログ (CBS.log) に記録されます。
    • 0xC80001FE
    • 0x80200010
    • 0x80070643
    • 0x80246002
    • 0x80070490
    • 0x80070420
    • 0x80073712
    • 0x80246007
    • 0x8000FFFF
    • 0x80070424
    • 0x80248007
    • 0x8007064C
    • 0x8024D00C
    • 0x8007066A
    • 0x80245003
    • 0x8024402C

原因

この問題は、以下のいずれかまたは複数の条件に該当する場合に発生することがあります。
  • Windows Update データベースが破損している。
  • ウイルス対策ソフトウェアが %Windir%\SoftwareDistribution フォルダーをスキャンするよう構成されている。
  • バックグラウンド インテリジェント転送サービス (BITS) がコンテンツ リンク ヘッダーを受信しない。
  • 必要なシステム ファイルが正しく登録されていない。
  • Windows インストーラーでエラーが生じた。
  • コンポーネントベースのサービス (CBS) マニフェストが破損している。
  • Windows Update サービスがインストール中に停止した。
  • Windows Update エージェント ファイルのバージョンで競合が生じている。

解決方法

この問題を解決するには、次の方法を実行します。それぞれの方法の手順を実行した後、次の方法に進む前に、問題が解決したかどうかを確認してください。問題が解決した場合、残りの方法を実行する必要はありません。

方法 1: コンピューターを再起動し、更新プログラムを再度インストールする

実行中のすべてのプログラムを終了し、コンピューターを再起動してから、更新プログラムを再度インストールする。

注: コンピューターを再起動すると、以前のインストールがすべて終了し、終了する前にシステムの再起動を必要とする残りのプロセスがなくなります。

方法 2: システム更新準備ツール (Checksur.exe) を実行する

システム更新準備ツールをダウンロードして実行します。このツールは、今後のサービス操作を妨げる可能性のある不整合のスキャンを 1 回実行します。Checksur.exe ツールをダウンロードして実行する方法の詳細については、以下のサポート技術情報番号をクリックしてください。
947821 Windows Vista、Windows Server 2008、Windows 7、Windows Server 2008 R2 のシステム更新準備ツールについて
更新プログラムのインストールをもう一度試みます。

注: ツールを実行すると、CheckSur.log ファイルが
%systemroot%\logs\cbs
に保存されます。

方法 3: システム ファイル チェッカー ツール (SFC.exe) を実行する

システム ファイル チェッカー ツール (SFC.exe) を実行します。これを行うには、次の手順を実行します。
  1. 管理コマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで「sfc /scannow」と入力し、Enter キーを押します。
  3. スキャンが終了したら、更新プログラムを再度インストールします。

方法 4: Catroot2 フォルダーのコンテンツをリセットする

Catroot2 フォルダーのコンテンツをリセットします。これを行うには、次の手順を実行します。
  1. 次のコマンドを入力し、各コマンドの後に Enter キーを押します。
    • net stop cryptsvc
    • md %systemroot%\system32\catroot2.old
    • xcopy %systemroot%\system32\catroot2 %systemroot%\system32\catroot2.old /s
  2. Catroot2 フォルダーの内容をすべて削除します。ただし、Catroot2 フォルダーは削除しないでください。
  3. コマンド
    net start cryptsvc
    を入力し、Enter キーを押します。
  4. コマンド プロンプト ウィンドウを終了します。

方法 5: 誤ったレジストリ値を削除する

レジストリに存在する誤った値を削除します。これを行うには、次の手順を実行します。
  1. [スタート] ボタンをクリックし、[検索の開始] ボックスに「regedit」と入力します。
  2. [プログラム] ボックスの一覧の [regedit.exe] をクリックします。
  3. レジストリ キー
    HKEY_LOCAL_MACHINE\COMPONENTS
    を見つけてクリックします。
  4. [COMPONENTS] を右クリックします。
  5. [エクスポート] をクリックします。
  6. [ファイル名] ボックスに「COMPONENTS」と入力します。
  7. [保存する場所] ボックスの [デスクトップ] をクリックし、[保存] をクリックしてファイルをデスクトップに保存します。
  8. 詳細ウィンドウで、[PendingXmlIdentifier] を右クリックし、[削除] をクリックします。この値が存在しない場合は、次の手順に進みます。
  9. 詳細ウィンドウで、[NextQueueEntryIndex] を右クリックし、[削除] をクリックします。この値が存在しない場合は、次の手順に進みます。
  10. 詳細ウィンドウで、[AdvancedInstallersNeedResolving] を右クリックし、[削除] をクリックします。この値が存在しない場合は、次の手順に進みます。
  11. コンピューターを再起動します。
  12. 更新プログラムを再度インストールします。
方法 6: Windows Update ファイルを修復する
Windows Update ファイルを修復する。これを行うには、次の手順を実行します。
  1. 管理コマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで次のコマンドを入力します。
    REGSVR32 WUPS2.DLL /S
    REGSVR32 WUPS.DLL /S
    REGSVR32 WUAUENG.DLL /S
    REGSVR32 WUAPI.DLL /S
    REGSVR32 WUCLTUX.DLL /S
    REGSVR32 WUWEBV.DLL /S
    REGSVR32 JSCRIPT.DLL /S
    REGSVR32 MSXML3.DLL /S
  3. 更新プログラムのインストールをもう一度試みます。

方法 7: ウイルス対策アプリケーションが特定のファイルをスキャンしないことを確認する

ウイルス対策アプリケーションが、Windows Update Agent がインストールされているコンピューター上の %windir% \SoftwareDistribution ディレクトリにあるファイルをスキャンしないことを確認します。

Windows Server 2003、Microsoft Windows 2000、Windows XP、Windows Vista、または Windows Server 2008 を実行しているコンピューターでは、次のファイルおよびフォルダーをスキャンしないでください。

注: これらのファイルは感染のリスクがありません。これらのファイルをスキャンすると、一部のファイルがロックされて深刻なパフォーマンスの問題が発生する場合があります。特定のファイル セットを名前で指定している場合は、フォルダー全体ではなく、名前を記載したファイルのみを除外します。フォルダー全体を除外する必要がある場合もあります。除外の際は、ファイル名の拡張子を使用しないでくださいたとえば、.dit 拡張子が付いたすべてのファイルを除外するのは避けます。以下のファイルと同じ拡張子を使用している可能性がある他のファイルについては、マイクロソフトは管理できません。
  • Microsoft Windows Update または自動更新に関連するファイル
  • Windows Update データベースまたは自動更新のデータベース ファイル

    注: このファイル (Datastore.edb) は、次のディレクトリにあります。
    %windir%\SoftwareDistribution\Datastore
  • トランザクション ログ ファイル

    注: これらのファイルは次のフォルダーにあります。
    %windir%\SoftwareDistribution\Datastore\Logs
除外するファイルを以下に示します。
  • Edb*.log

    注: ワイルドカード文字は、複数のファイルが存在する可能性があることを示します。
  • Res1.log
  • Res2.log
  • Edb.chk
  • Tmp.edb

方法 8: SoftwareDistribution フォルダーの名前を変更する

Windows Update の一時 SoftwareDistribution フォルダーの名前を変更します。これを行うには、次の手順を実行します。
  1. 管理コマンド プロンプト ウィンドウを開きます。
  2. 次のコマンドを実行し、各コマンドの後に Enter キーを押します。
    • Net stop wuauserv
    • cd %systemroot%
    • Ren SoftwareDistribution SoftwareDistribution.old
    • Net start wuauserv
  3. 更新プログラムのインストールをもう一度試みます。
重要: この方法を使用した場合、次の問題が発生します。
  • 現在ダウンロードされて、まだインストールされていない更新プログラムは、Windows Update または Microsoft Update を使用して再度ダウンロードする必要があります。
  • ソフトウェア配布フォルダーを削除すると、ダウンロードの履歴が削除されます。
  • 現在、Microsoft Update および Windows Update から更新プログラムを受信している場合は、Windows Update Web サイトからこのオプションを再び選択する必要があります。
注: 問題が解決し、更新プログラムを正常にダウンロードしてインストールできた場合は、SoftwareDistribution.old フォルダーを安全に削除してディスク領域を回復できます。

方法 9: 現在のジョブの BITS キューをクリアする

BITS キューの現在のジョブをクリアします。これを行うには、次の手順を実行します。
  1. 管理コマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで、次のコマンドを入力します (各コマンドの後で Enter キーを押します)。

    Net stop bits
    Net stop wuauserv
    Ipconfig /flushdns
    cd \documents and settings\all users\application data\microsoft\network\downloader
    Del qmgr0.dat
    Del qmgr1.dat
    Net start bits
    Net start wuauserv
    注:
    上記の手順を完了すると、BITS キューがクリアされます。
  3. 更新プログラムのインストールをもう一度試みます。

方法 10: 更新プログラム 958056 をダウンロードして手動でインストールする

更新プログラム 958056 をダウンロードして手動でインストールします。これを行うには、次の手順を実行します。
  1. 失敗した更新プログラムのサポート技術情報番号を確認します。これを行うには、以下のいずれかの操作を実行します。エラー コード メッセージを確認します。
    • エラー コード メッセージを確認します。
    • Windows Update Web サイトまたは Microsoft Update Web サイトで更新履歴を表示します。これを行うには、次の手順を実行します。
      1. 次の Microsoft Update Web サイトにアクセスします。
        http://update.microsoft.com
      2. [オプション] で、[更新履歴の表示]. をクリックします。
      3. 更新列で、失敗した更新プログラムのサポート技術情報番号を確認します。
  2. 次の Windows Download Web サイトにアクセスします。
    http://www.microsoft.com/windows/downloads/default.aspx
  3. Downloads Web ページの検索ボックスに、手順 1 にあるサポート技術情報番号を入力し、[検索] をクリックします。
    注: サポート技術情報番号を入力するときに「kb」という文字を含めないでください。たとえば、「kb123456」の場合は「123456」と入力します。
  4. 返されたコンテンツのリストを参照し、ダウンロードのリンクが記載されているサポート技術情報を検索します。
    注: Windows を検証するように求められることがあります。メッセージが表示された場合は、指示に従って Windows を検証し、更新プログラムのダウンロードを続行します。
  5. [ダウンロード] をクリックし、ダウンロードしたファイルの保存を求められたら [保存] をクリックします。ダウンロードしたファイルをデスクトップに保存します。
  6. ダウンロードが終了したら、[開く] をクリックして更新プログラムをインストールします。
    注: Windows のバージョンが正しくない場合は、更新プログラムのインストールに失敗する可能性があります。

方法 11: Pending.xml の名前を変更する

Pending.xml ファイルの名前を変更します。これを行うには、次の手順を実行します。
  1. 管理コマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで次のコマンドを入力します。
    takeown /f C:\Windows\winsxs\pending.xml
  3. 次のコマンドを使用して、c:\windows\winsxs\pending.xml パスの名前を変更します。
Ren c:\windows\winsxs\pending.xml pending.old

手順 12: Windows パーティションに対して Chkdsk を実行する

Windows パーティションに対してディスク チェックを実行します。これを行うには、次の手順を実行します。
  1. 管理コマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで次のコマンドを入力します。
    Chkdsk volume:/f /r

プロパティ

文書番号: 2509997 - 最終更新日: 2014年6月18日 - リビジョン: 30.0
この資料は以下の製品について記述したものです。
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Foundation
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Standard
キーワード:?
KB2509997
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