Windows Vista、Windows 7、Windows Server 2008 と Windows Server 2008 R2 に更新プログラムをインストールすることができません。

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文書番号: 2509997
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目次

現象

Windows の更新プログラム、Windows コンポーネント、または Microsoft やサードパーティー製のプログラムをインストールする際、次の中の一つ以上の現象が発生することがあります。
  • Windows の役割や機能を表示することはできません。
  • Service pack のインストールは失敗します。
  • Microsoft Windows Update web サイトまたは Microsoft Update web サイトに接続しようとすると、次のエラー コードのいずれかで、Windows Update ログ (windowsupdate.log) またはコンポーネント ベースのサービス ログ (CBS.log) に記録されます。
    • 0xC80001FE
    • 0x80200010
    • 0x80070643
    • 0x80246002
    • 0x80070490
    • 0x80070420
    • 0x80073712
    • 0x80246007
    • 0x80000FFF
    • 0x80070424
    • 0x80248007
    • 0x8007064C
    • 0x8024D00C
    • 0x8007066A
    • 0x80245003
    • 0x8024402C

原因

この問題は次の条件に一つ以上当てはまる場合に発生する可能性があります。
  • Windows Update データベースが壊れている。
  • %Windir%\SoftwareDistribution フォルダーをスキャンするウイルス対策ソフトウェアが構成されている。
  • バック グラウンド インテリジェント転送サービス (BITS) サービスは、コンテンツ リンク ヘッダーを受信していない。
  • 必要なシステム ファイルが正しく登録されていない。
  • Windows インストーラーにエラーが発生している。
  • コンポーネント ベース サービシング (CBS) マニフェストが破損している。
  • インストール中に Windows の Update サービスが中止された。
  • Windows Update エージェントのファイルで、ファイル バージョンの競合が存在している。

解決方法

この問題を解決するには、以下の方法を試してください。各方法の手順を実行後、次の方法を実行する前に問題が解決したかを確認してください。問題が解決した場合、残りの方法を行う必要はありません。

方法 1: コンピューターを再起動し、再度更新プログラムをインストールしてください

実行しているすべてのプログラムを閉じて、コンピューターを再起動し、更新プログラムを再度インストールしてください。

注 コンピューターの再起動により、すべての以前のインストールが終了していること、実行完了のためにシステムの再起動を必要とするプロセスが残っていないことを確認します。

方法 2: システム更新準備ツール (CheckSur.exe) を実行します。

システム更新準備ツールをダウンロード、実行します。このツールは、今後のサービス操作を妨げる可能性がある不整合を一回だけスキャンします。CheckSur.exe ツールをダウンロード、および実行する方法の詳細については、「サポート技術情報」資料を参照するには、次の資料番号をクリックしてください。
947821 Windows Vista、Windows Server 2008 を Windows 7、および Windows Server 2008 R2 のシステム更新準備ツールの説明
更新プログラムを再度インストールしてください。

このツールを実行すると、次の場所に CheckSur.log ファイルが保存されます。
%systemroot%\logs\cbs

方法 3: システム ファイル チェッカー ツール (SFC.exe) を実行します。

システム ファイル チェッカー ツール (SFC.exe) を実行します。以下が手順例となります:
  1. 管理者権限でコマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで、 sfc/scannow を入力し、Enterキーを押します。
  3. スキャンの完了後、再度更新プログラムをインストールしてください。

方法 4: Catroot2 フォルダーの内容をリセットします。

Catroot2 フォルダーの内容をリセットします。以下が手順例となります:
  1. 次のコマンドを入力し、各コマンドの後 Enter をキーを押します。
    • net stop cryptsvc
    • md %systemroot%\system32\catroot2.old
    • xcopy %systemroot%\system32\catroot2 %systemroot%\system32\catroot2.old /s
  2. Catroot2 フォルダー内にあるすべての内容を削除します。この際、catroot2 フォルダー自身は削除しないでください。
  3. 次のコマンドを入力し、Enter キーを押します。
    net start cryptsvc
  4. コマンド プロンプト ウィンドウを終了します。

方法 5: 不正なレジストリ値を削除します。

レジストリに不適切な値が存在している場合には削除します。以下が手順例となります:
  1. スタートボタン をクリックし、[検索の開始] もしくは [プログラムとファイルの検索] ボックスに、regedit と入力します。
  2. [プログラム] ボックスの一覧にある、 [regedit.exe] をクリックします。
  3. 次のレジストリ サブキーを選択します。
    HKEY_LOCAL_MACHINE\COMPONENTS
  4. COMPONENTS を右クリックします。
  5. エクスポート をクリックします。
  6. [ファイル名] ボックスで、COMPONENTS と入力します。
  7. [保存先] ボックスで、をク デスクトップ をクリックして [保存] をクリックし、ファイルをデスクトップに保存します。
  8. 詳細ペインで、 PendingXmlIdentifier を右クリックし、、[削除]をクリックします。 この値が存在しない場合は、次の手順に進みます。
  9. 詳細ペインで、 NextQueueEntryIndex をクリックし、[削除]をクリックします。 この値が存在しない場合は、次の手順に進みます。
  10. 詳細ペインで、AdvancedInstallersNeedResolvingを右クリックし、[削除]をクリックします。 この値が存在しない場合は、次の手順に進みます。
  11. コンピューターを再起動します。
  12. 更新プログラムを再度インストールしてください。

方法 6: Windows Update ファイルを登録します。


Windows Update ファイルを登録します。以下が手順例となります:
  1. 管理者権限でコマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで、次のコマンドを入力します。
    REGSVR32 WUPS2.DLL /S
    REGSVR32 WUPS.DLL /S
    REGSVR32 WUAUENG.DLL /S
    REGSVR32 WUAPI.DLL /S
    REGSVR32 WUCLTUX.DLL /S
    REGSVR32 WUWEBV.DLL /S
    REGSVR32 JSCRIPT.DLL /S
    REGSVR32 MSXML3.DLL /S
  3. 更新プログラムを再度インストールしてください。

方法 7: アンチ ウィルス アプリケーションが特定のファイルをスキャンしていないことを確認します。

Windows Update エージェントがインストールされている任意のコンピューターでは、アンチ ウィルス アプリケーションが %windir%\SoftwareDistribution ディレクトリ内のファイルをスキャンしていないことを確認してください。

Windows Server 2003、Microsoft Windows 2000、Windows XP、Windows Vista、または Windows Server 2008 を実行しているコンピューターの場合は、以下のファイルとフォルダーもスキャンしません。

これらのファイルは、感染の危険ではありません。これらのファイルをスキャンする場合は、いくつかのファイルがロックされる可能性があるため、深刻なパフォーマンス上の問題が発生することがあります。特定の一連のファイルが名前で識別される場合は、フォルダー全体ではなくファイルのみを除外します。場合によっては、フォルダー全体を除外する必要があります。いずれのアイテムにおいても、ファイル名の拡張子に基づいた除外はしないでください。たとえば、.dit 拡張子を持つすべてのファイルを除外しないでください。Microsoft はファイルが同じ拡張子を使用する可能性がある他のファイルを制御ができません。
  • Microsoft Windows Update または自動更新に関連するファイル
  • Windows の更新プログラムのデータベース ファイル、または自動更新のデータベース ファイル

    このファイル (Datastore.edb) は、次のディレクトリにあります。
    %windir%\SoftwareDistribution\Datastore
  • トランザクション ・ ログ ・ ファイル

    これらのファイルは、次のフォルダーにあります。
    %windir%\SoftwareDistribution\Datastore\Logs
次のファイルを除外します。
  • Edb*.log

    ワイルドカード文字は、複数のファイルが存在する可能性があることを示します。
  • Res1.log
  • Res2.log
  • Edb.chk
  • Tmp.edb

方法 8: [SoftwareDistribution] フォルダーの名前を変更します。

Windows Update の一時的な SoftwareDistribution フォルダーの名前を変更します。以下が手順例となります:
  1. 管理者権限でコマンド プロンプト ウィンドウを開きます。
  2. 次のコマンドを実行し、各コマンドの後 Enter をキーを押します。
    • Net stop wuauserv
    • cd %systemroot%
    • Ren SoftwareDistribution SoftwareDistribution.old
    • Net start wuauserv
  3. 更新プログラムを再度インストールしてください。
重要このメソッドを使用すると、以下の問題が発生します。
  • これまでにダウンロードしたものの、まだインストールしていない更新については、Windows Update か Microsoft Update を使用して再度ダウンロードを行ってください。
  • ソフトウェアの配布フォルダーを削除すると、ダウンロードの履歴が削除されます。
  • もし Windows Update と Microsoft Update から更新を受信する場合、Windows Update web サイトからこのオプションを再度選択する必要があります。
問題が解決し、正常にダウンロードして更新プログラムをインストールできた場合は、ディスク領域を元に戻すために SoftwareDistribution.old フォルダーを安全に削除することが可能です。

方法 9: 現在までのジョブに関する BITS キューをクリアします。

BITS キューにある現在のジョブをクリアします。以下が手順例となります:
  1. 管理者権限でコマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで、次のコマンドを入力し、各コマンドの後 Enter をキーを押します。

    Net stop bits
    Net stop wuauserv
    Ipconfig /flushdns
    cd \documents and settings\all users\application data\microsoft\network\downloader
    Del qmgr0.dat
    Del qmgr1.dat
    Net start bits
    Net start wuauserv
    これらの手順を完了すると、BITS キューがクリアされます。
  3. 更新プログラムを再度インストールしてください。

方法 10: 958056 の更新プログラムを手動でダウンロード、インストールします。

KB 958056 の更新プログラムを手動でダウンロードおよびインストールします。以下が手順例となります:
  1. 更新に失敗したマイクロソフト サポート技術情報の文書番号を確認します。 これを行うには、次のいずれかの操作を行います:
    • エラー コードのメッセージを表示します。
    • Windows Update web サイトまたは Microsoft Update web サイトの更新履歴を表示します。以下が手順例となります:
      1. 次の Microsoft Update Web サイトを参照します。
        http://update.microsoft.com
      2. [オプション]から、[[更新履歴の確認]] をクリックします。
      3. [更新プログラム] 列で、更新に失敗したマイクロソフト サポート技術情報の文書番号を確認します。
  2. 次の Windows ダウンロード Web サイトを参照してください。
    http://www.microsoft.com/windows/downloads/default.aspx
  3. ダウンロード Web ページ上の [検索] ボックスに、手順 1 で確認した文書番号を入力し、[Go] をクリックします。
    記事番号を入力する際、"kb"の文字を含めないでください。たとえば、"kb123456"を 123456として入力します。
  4. ダウンロードへのリンクを持つサポート技術情報の記事を見つけるため、検索結果のリストを参照します。
    Windows の検証を求めるメッセージが表示される可能性があります。ダイアログ ボックスが表示されたら、Windows を検証するかどうかを指示し、更新プログラムのダウンロードを続行します。
  5. ダウンロード をクリックし、ダウンロードを保存するメッセージが表示されたら、[保存] をクリックします。 デスクトップにダウンロードしたファイルを保存します。
  6. ダウンロードの完了後は、更新プログラムをインストールするには、ファイルを開く をクリックします。
    更新が Windows のバージョンに対して適切ではない場合、更新プログラムのインストールが失敗することがあります。

方法 11: Pending.xml の名前を変更します。

Pending.xml ファイルの名前を変更します。以下が手順例となります:
  1. 管理者権限でコマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで、次のコマンドを入力します。
    takeown /f C:\Windows\winsxs\pending.xml
  3. C:\windows\winsxs\pending.xml のパスは、次のコマンドを使用して名前を変更します。
Ren c:\windows\winsxs\pending.xml pending.old

方法 12: Windows パーティション上で Chkdsk を実行します。

Windows パーティションにディスク チェックを実行します。以下が手順例となります:
  1. 管理者権限でコマンド プロンプト ウィンドウを開きます。
  2. コマンド プロンプトで、次のコマンドを入力します。
    Chkdsk volume: /f /r

プロパティ

文書番号: 2509997 - 最終更新日: 2012年4月20日 - リビジョン: 29.0
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