ไม่สามารถติดตั้งโปรแกรมปรับปรุงใน Windows Vista, Windows 7, Windows Server 2008 และ Windows Server 2008 R2

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2509997 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

เมื่อคุณพยายามติดตั้งการปรับปรุง Windows คุณพยายามติดตั้งคอมโพเนนต์ของ Windows หรือคุณพยายามติดตั้ง Microsoft หรือโปรแกรมซอฟต์แวร์ของบริษัทอื่น คุณพบกับอาการอย่างใดต่อไปนี้:
  • คุณไม่สามารถดูหน้าที่ของ Windows หรือลักษณะการทำงาน
  • การติดตั้งชุดบริการล้มเหลว
  • เมื่อคุณพยายามเชื่อมต่อ ไปยังเว็บไซต์ของ Microsoft Windows Update หรือ ไปเว็บไซต์ Microsoft Update รหัสข้อผิดพลาดต่อไปนี้อย่างใดอย่างหนึ่งถูกบันทึกไว้ ในแฟ้มบันทึกของ Windows Update (windowsupdate.log) หรือ ในแฟ้มบันทึกคอมโพเนนต์พื้นฐานการบริการ (CBS.log):
    • 0xC80001FE
    • 0x80200010
    • 0x80070643
    • 0x80246002
    • 0x80070490
    • 0x80070420
    • 0x80073712
    • 0x80246007
    • 0x80000FFF
    • 0x80070424
    • 0x80248007
    • 0x8007064C
    • 0x8024D00C
    • 0x8007066A
    • 0x80245003
    • 0x8024402C

สาเหตุ

ปัญหานี้อาจเกิดขึ้นหากเงื่อนไขอย่างใดอย่างหนึ่งต่อไปนี้เป็นจริง:
  • ฐานข้อมูลการปรับปรุงของ Windows เสียหาย
  • มีการกำหนดค่าซอฟต์แวร์ป้องกันไวรัสให้สแกนโฟลเดอร์ %Windir%\SoftwareDistribution
  • บริการ Background Intelligent Transfer Service (BITS) ไม่ได้รับการเชื่อมโยงเนื้อหาหัวข้อ
  • แฟ้มระบบที่จำเป็นต้องมีการลงทะเบียนอย่างไม่ถูกต้อง
  • โปรแกรมติดตั้ง Windows พบข้อผิดพลาด
  • รายการคอมโพเนนต์พื้นฐานให้บริการ (CBS) เกิดความเสียหาย
  • บริการ Windows Opdate หยุดการทำงานในระหว่างการติดตั้ง
  • ความขัดแย้งของรุ่นของแฟ้มที่มีอยู่ ด้วยแฟ้มของบริษัทตัวแทนการปรับปรุงของ Windows

การแก้ไข

เมื่อต้องการแก้ไขปัญหานี้ ลองใช้วิธีต่อไปนี้ หลังจากที่คุณดำเนินการขั้นตอนในแต่ละวิธี ทดสอบเพื่อดูว่า จะแก้ปัญหาก่อนที่คุณเข้าไปในวิธีการต่อไป ถ้าจะแก้ปัญหา ด้วยวิธีใด คุณไม่มีปัญหา

วิธีที่ 1: เริ่มระบบคอมพิวเตอร์ของคุณ และลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง

ปิดโปรแกรมทั้งหมดที่กำลังทำงาน รีสตาร์ทเครื่องคอมพิวเตอร์ และลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง

หมายเหตุ เริ่มการทำงานของคอมพิวเตอร์จะตรวจสอบให้แน่ใจว่า การติดตั้งก่อนหน้านี้ทั้งหมดเสร็จสมบูรณ์แล้ว และว่า กระบวนการที่เหลือไม่จำเป็นต้องรีสตาร์ทระบบก่อนที่จะให้เสร็จ

วิธีที่ 2: เรียกใช้เครื่องมือการเตรียมพร้อมในการปรับปรุงระบบ (CheckSur.exe)

ดาวน์โหลด และเรียกใช้เครื่องมือการเตรียมพร้อมในการปรับปรุงระบบ เครื่องมือนี้เรียกใช้การสแกนแบบครั้งเดียวสำหรับความไม่สอดคล้องที่อาจทำให้การดำเนินการบริการในอนาคต สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการดาวน์โหลด และเรียกใช้เครื่องมือ CheckSur.exe ให้คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
947821 คำอธิบายของเครื่องระบบมือ สำหรับ Windows Vista, Windows Server 2008 สำหรับ Windows 7 และ สำหรับ Windows Server 2008 R2
ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง

หมายเหตุ หลังจากที่คุณเรียกใช้เครื่องมือ CheckSur.log แฟ้มจะถูกบันทึกในตำแหน่งที่ตั้งต่อไปนี้:
%systemroot%\logs\cbs

วิธีที่ 3: เรียกใช้เครื่องมือ System File Checker (SFC.exe)

เรียกใช้เครื่องมือ System File Checker (SFC.exe) ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. เปิดหน้าต่างพร้อมรับคำสั่งจัดการ
  2. ที่พรอมต์คำสั่ง พิมพ์ sfc /scannowจากนั้น กด ป้อน.
  3. หลังจากการสแกนเสร็จสมบูรณ์ พยายามที่จะติดตั้งโปรแกรมปรับปรุงอีกครั้ง

วิธีที่ 4: การตั้งค่าเนื้อหาของโฟลเดอร์ Catroot2

ตั้งค่าเนื้อหาของโฟลเดอร์ catroot2 ได้ใหม่ ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. พิมพ์คำสั่งต่อไปนี้ และกด Enter หลังจากแต่ละคำสั่ง:
    • cryptsvc net stop
    • md %systemroot%\system32\catroot2.old
    • xcopy %systemroot%\system32\catroot2 %systemroot%\system32\catroot2.old /s
  2. ลบเนื้อหาทั้งหมดของโฟลเดอร์ catroot2 ได้ แต่ไม่ได้ลบโฟลเดอร์ catroot2
  3. พิมพ์คำสั่งต่อไปนี้ และจากนั้น กด Enter:
    เริ่มต้นสุทธิ cryptsvc
  4. ออกจากหน้าต่างพร้อมรับคำสั่ง

วิธีที่ 5: ลบค่ารีจิสทรีใด ๆ ไม่ถูกต้อง

เอาค่าที่ไม่ถูกต้องใด ๆ ที่อาจมีอยู่ในรีจิสทรี ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. คลิก เริ่มและจากนั้น พิมพ์ regedit ในการ เริ่มต้นค้นหา กล่อง
  2. ในการโปรแกรม รายการ คลิก regedit.exe.
  3. ค้นหา และเลือกคีย์ย่อยของรีจิสทรีต่อไปนี้:
    HKEY_LOCAL_MACHINE\COMPONENTS
  4. คลิกขวาคอมโพเนนต์.
  5. คลิก การส่งออก.
  6. ในการชื่อแฟ้ม กล่อง ชนิด คอมโพเนนต์.
  7. ในการ บันทึกใน กล่อง คลิก เดสก์ท็อปคลิก บันทึกจากนั้น ให้บันทึกแฟ้มไปยังเดสก์ท็อปของคุณ
  8. คลิกขวาในบานหน้าต่างรายละเอียด PendingXmlIdentifierแล้ว คลิก ลบ. ถ้าค่านี้ไม่มี ไปขั้นตอนถัดไป
  9. ในบานหน้าต่างรายละเอียด ขวาคลิก NextQueueEntryIndexแล้ว คลิก ลบ. ถ้าค่านี้ไม่มี ไปขั้นตอนถัดไป
  10. ในบานหน้าต่างรายละเอียด คลิกขวาAdvancedInstallersNeedResolvingแล้ว คลิก ลบ. ถ้าไม่มีค่า ไปขั้นตอนถัดไป
  11. รีสตาร์ทคอมพิวเตอร์
  12. ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง
วิธีที่ 6: การลงทะเบียนแฟ้ม Windows Update
ลงทะเบียนแฟ้ม Windows Update ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. เปิดหน้าต่างพร้อมรับคำสั่งจัดการ
  2. ที่พรอมต์คำสั่ง พิมพ์คำสั่งต่อไปนี้:
    REGSVR32 WUPS2.DLL /S
    REGSVR32 WUPS.DLL /S
    REGSVR32 WUAUENG.DLL /S
    REGSVR32 WUAPI.DLL /S
    REGSVR32 WUCLTUX.DLL /S
    REGSVR32 WUWEBV.DLL /S
    REGSVR32 JSCRIPT.DLL /S
    REGSVR32 MSXML3.DLL /S
  3. ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง

วิธีที่ 7: ตรวจสอบให้แน่ใจว่า โปรแกรมประยุกต์ที่มีการป้องกันไวรัสของคุณไม่ต้องสแกนแฟ้มบางแฟ้ม

ตรวจสอบให้แน่ใจว่า โปรแกรมประยุกต์ที่มีการป้องกันไวรัสของคุณไม่ต้องสแกนแฟ้มในไดเรกทอรี% windir % \SoftwareDistributionบนเครื่องคอมพิวเตอร์ใด ๆ ที่มีการติดตั้ง Windows Update Agent

สำหรับคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Server 2003, Microsoft Windows 2000, Windows XP, Windows Vista หรือ Windows Server 2008 ไม่ต้องสแกนแฟ้มและโฟลเดอร์ต่อไปนี้

หมายเหตุ แฟ้มเหล่านี้ไม่ได้อยู่ในความเสี่ยงของการติดไวรัส ถ้าคุณสแกนแฟ้มเหล่านี้ ปัญหาประสิทธิภาพการทำงานที่ร้ายแรงอาจเกิดขึ้นได้เนื่องจากแฟ้มบางแฟ้มอาจถูกล็อก ถ้าชุดของแฟ้มเฉพาะจะถูกระบุ ด้วยชื่อ ไม่รวมเฉพาะแฟ้มแทนที่โฟลเดอร์ทั้งหมด บางครั้ง โฟลเดอร์ทั้งหมดต้องถูกแยกออก ไม่ยกเว้นใด ๆ ของรายการเหล่านี้ขึ้นอยู่กับส่วนขยายชื่อแฟ้ม ตัวอย่างเช่น แยกแฟ้มทั้งหมดที่มีนามสกุลเป็น.dit Microsoft มีแฟ้มอื่น ๆ ที่อาจใช้นามสกุลเดียวกันที่เป็นแฟ้มเหล่านี้ไม่สามารถควบคุม
  • แฟ้มที่เกี่ยวข้อง กับ Microsoft Windows Update หรือ การปรับ ปรุงอัตโนมัติ
  • แฟ้มฐานข้อมูลการปรับปรุงของ Windows หรือแฟ้มฐานข้อมูลการปรับปรุงอัตโนมัติ

    หมายเหตุ แฟ้มนี้ (Datastore.edb) จะอยู่ในไดเรกทอรีดังต่อไปนี้:
    %windir%\SoftwareDistribution\Datastore
  • แฟ้มล็อกธุรกรรม

    หมายเหตุ แฟ้มเหล่านี้จะอยู่ในโฟลเดอร์ต่อไปนี้:
    %windir%\SoftwareDistribution\Datastore\Logs
ยกเว้นแฟ้มต่อไปนี้:
  • Edb*.log

    หมายเหตุ อักขระสัญลักษณ์ตัวแทนบ่งชี้ว่า อาจมีแฟ้มหลาย ๆ แฟ้ม
  • Res1.log
  • Res2.log
  • Edb.chk
  • Tmp.edb

วิธีที่ 8: เปลี่ยนชื่อโฟลเดอร์ SoftwareDistribution

เปลี่ยนชื่อโฟลเดอร์ SoftwareDistribution ชั่วคราวของ Windows Update ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. เปิดหน้าต่างพร้อมรับคำสั่งจัดการ
  2. เรียกใช้คำสั่งต่อไปนี้ และกด Enter หลังจากแต่ละคำสั่ง:
    • Net stop wuauserv
    • ซีดี% systemroot %
    • Ren SoftwareDistribution SoftwareDistribution.old
    • เริ่มต้นสุทธิ wuauserv
  3. ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง
สิ่งสำคัญ ปัญหาต่อไปนี้เกิดขึ้นเมื่อคุณใช้วิธีนี้:
  • โปรแกรมปรับปรุงที่จะถูกดาวน์โหลด แต่ที่ยังไม่ได้ติดตั้งต้องถูกดาวน์โหลดมา โดยใช้ Windows Update หรือ Microsoft Update อีกครั้ง
  • เมื่อคุณลบโฟลเดอร์การกระจายซอฟต์แวร์ ประวัติการดาวน์โหลดจะถูกเอาออก
  • ถ้าคุณอยู่ในขณะนี้รับการปรับปรุง จาก Microsoft Update และปรับ ปรุงของ Windows คุณจะต้องเลือกตัวเลือกนี้จากเว็บไซต์ Windows Update
หมายเหตุ ถ้าปัญหาได้รับการแก้ไข และคุณสามารถดาวน์โหลด และติดตั้งการปรับปรุง คุณสามารถลบโฟลเดอร์ SoftwareDistribution.old การกู้คืนเนื้อที่ว่างบนดิสก์ได้อย่างปลอดภัย

วิธีที่ 9: ล้างคิวบิตของงานใด ๆ ที่ปัจจุบัน

ยกเลิกเลือกใด ๆ งานปัจจุบันออกจากคิวบิต ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. เปิดหน้าต่างพร้อมรับคำสั่งจัดการ
  2. ที่พรอมต์คำสั่ง พิมพ์คำสั่งต่อไปนี้ และกด Enter หลังจากแต่ละคำสั่ง:

    Net stop bits
    Net stop wuauserv
    Ipconfig /flushdns
    cd \documents and settings\all users\application data\microsoft\network\downloader
    Del qmgr0.dat
    Del qmgr1.dat
    Net start bits
    Net start wuauserv
    หมายเหตุ
    หลังจากที่คุณทำตามขั้นตอน คิวบิตถูกเลือกไว้
  3. ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง

วิธีที่ 10: ดาวน์โหลด และติดตั้งการปรับปรุง 958056

ดาวน์โหลด และติดตั้งการปรับปรุง KB 958056 ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. กำหนดหมายเลขบทความฐานความรู้ของ Microsoft โปรแกรมปรับปรุงล้มเหลว เมื่อต้องการทำเช่นนี้ ให้ทำวิธีใดวิธีหนึ่งต่อไปนี้: ดูข้อความรหัสข้อผิดพลาด
    • ดูข้อความรหัสข้อผิดพลาด
    • ดูประวัติการปรับปรุง บนเว็บไซต์ Windows Update หรือ ในเว็บไซต์ Microsoft Update ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
      1. แวะไปที่ Microsoft Update เว็บไซต์ต่อไปนี้:
        http://update.microsoft.com
      2. ภายใต้ตัวเลือก คลิกตรวจทานประวัติการปรับปรุงของคุณ
      3. ในคอลัมน์การปรับปรุง กำหนดหมายเลขบทความฐานความรู้ของ Microsoft โปรแกรมปรับปรุงล้มเหลว
  2. เยี่ยมชมไซต์เว็บการดาวน์โหลด Windows ต่อไปนี้:
    http://www.microsoft.com/windows/downloads/default.aspx
  3. ในกล่องค้นหาในการดาวน์โหลดเว็บเพจ ชนิดหมายเลขบทความ ที่คุณอยู่ในขั้นตอนที่ 1 แล้ว คลิก ไป
    หมายเหตุ ไม่รวมตัวอักษร "กิโล" เมื่อคุณพิมพ์หมายเลขบทความนี้ ตัวอย่างเช่น พิมพ์ "kb123456" เป็น 123456.
  4. เรียกดูผ่านรายการของเนื้อหาที่ส่งคืนเพื่อค้นหาบทความฐานข้อมูลองค์ความรู้ที่มีการเชื่อมโยงไปยังการดาวน์โหลด
    หมายเหตุ คุณอาจได้รับการพร้อมท์เพื่อตรวจสอบ Windows ถ้าคุณได้รับพร้อมท์ ทำตามคำแนะนำในการตรวจสอบ Windows และจากนั้น ดำเนินต่อเมื่อต้องการดาวน์โหลดการปรับปรุง
  5. คลิก ดาวน์โหลดแล้ว คลิก บันทึก เมื่อคุณได้รับพร้อมท์ให้บันทึกการดาวน์โหลด บันทึกการดาวน์โหลดไปยังเดสก์ท็อปของคุณ
  6. หลังจากเสร็จสิ้นการดาวน์โหลด คลิก เปิด เมื่อต้องการติดตั้งการปรับปรุง
    หมายเหตุ การติดตั้งการปรับปรุงอาจล้มเหลวถ้าการปรับปรุงไม่ถูกต้องสำหรับ Windows รุ่นของคุณ

วิธีที่ 11: เปลี่ยนชื่อ Pending.xml

การเปลี่ยนชื่อแฟ้ม Pending.xml ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. เปิดหน้าต่างพร้อมรับคำสั่งจัดการ
  2. ที่พรอมต์คำสั่ง พิมพ์คำสั่งต่อไปนี้:
    takeown /f C:\Windows\winsxs\pending.xml
  3. เปลี่ยนชื่อเส้นทาง c:\windows\winsxs\pending.xml โดยใช้คำสั่งต่อไปนี้:
Ren c:\windows\winsxs\pending.xml pending.old

วิธีที่ 12: Chkdsk การเรียกใช้บนพาร์ติชัน Windows

เรียกใช้การตรวจสอบดิสก์บนพาร์ติชัน Windows ในการดำเนินการดังกล่าว ให้ทำตามขั้นตอนต่อไปนี้
  1. เปิดหน้าต่างพร้อมรับคำสั่งจัดการ
  2. ที่พรอมต์คำสั่ง พิมพ์คำสั่งต่อไปนี้:
    Chkdsk volume: /f /r

คุณสมบัติ

หมายเลขบทความ (Article ID): 2509997 - รีวิวครั้งสุดท้าย: 29 เมษายน 2556 - Revision: 6.0
ใช้กับ
  • Windows Vista Business
  • Windows Vista Enterprise
  • Windows Vista Home Basic
  • Windows Vista Home Premium
  • Windows Vista Starter
  • Windows Vista Ultimate
  • Windows 7 Enterprise
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Professional
  • Windows 7 Starter
  • Windows 7 Ultimate
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 Foundation
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Standard
Keywords: 
kbmt KB2509997 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2509997

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com