Article ID: 251002 - Last Review: September 4, 2007 - Revision: 3.11

Loading Invalid Image Using OLE Automation Displays Assertion

This article was previously published under Q251002

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SYMPTOMS

When you run a program that handles Graphic Interchange Format (GIF) images by using the support of the OLE Automation libraries, you may receive the following error message with certain images:
Assertion failed!
File: d:\OA\src\stdtypes\filtgif.cpp
Line: 1524
Expression: code != m_decompress_info.code_table[0][code]

CAUSE

Because of different coding guidelines and build options, this part of the libraries still had additional debugging code in the shipping version.

RESOLUTION

Windows 2000

To resolve this problem, obtain the latest service pack for Windows 2000. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
260910  (http://support.microsoft.com/kb/260910/EN-US/ ) How to Obtain the Latest Windows 2000 Service Pack
This update is part of the Windows 2000 Critical Update, February 17, 2000 that is available on the following Microsoft Web site:
http://windowsupdate.microsoft.com/ (http://windowsupdate.microsoft.com/)
You can also download this critical update (for installation later or on a different computer) from the following Microsoft Web site:
http://support.microsoft.com/kb/253934 (http://support.microsoft.com/kb/253934)
NOTE: To view the version, right-click the file in Windows Explorer, click Properties, and then click Version.

Windows NT Server or Workstation 4.0

To resolve this problem, obtain the latest service pack for Windows NT 4.0 or the individual software update. For information on obtaining the latest service pack, please go to:
152734  (http://support.microsoft.com/kb/152734/EN-US/ ) how to obtain the latest windows nt 4.0 service pack

For information on obtaining the individual software update, contact Microsoft Product Support Services. For a complete list of Microsoft Product Support Services phone numbers and information on support costs, please go to the following address on the World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)

Windows NT Server 4.0, Terminal Server Edition

To resolve this problem, obtain the latest service pack for Windows NT Server version 4.0, Terminal Server Edition. For additional information, click the following article number to view the article in the Microsoft Knowledge Base:
152734  (http://support.microsoft.com/kb/152734/EN-US/ ) How to Obtain the Latest Windows NT 4.0 Service Pack

Windows 98

The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download 251002usa8.exe now (http://download.microsoft.com/download/win98/update/7050/w98/en-us/251002usa8.exe)
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/EN-US/ ) How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

Windows 95

The following file is available for download from the Microsoft Download Center:
Collapse this imageExpand this image
Download
Download 251002usa5.exe now (http://download.microsoft.com/download/win95/update/7050/w95/en-us/251002usa5.exe)
For additional information about how to download Microsoft Support files, click the following article number to view the article in the Microsoft Knowledge Base:
119591  (http://support.microsoft.com/kb/119591/EN-US/ ) How to Obtain Microsoft Support Files from Online Services
Microsoft scanned this file for viruses. Microsoft used the most current virus-detection software that was available on the date that the file was posted. The file is stored on security-enhanced servers that help to prevent any unauthorized changes to the file.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. This problem was first corrected in Windows 2000 Service Pack 1.

Windows NT Server 4.0, Terminal Server Edition

This problem was first corrected in Windows NT Server version 4.0, Terminal Server Edition Service Pack 6.

MORE INFORMATION

For additional information about what this patch fixes, click the article number below to view the article in the Microsoft Knowledge Base:
253342  (http://support.microsoft.com/kb/253342/EN-US/ ) Year Is Reported Incorrectly on Some Non-Gregorian Calendars
For additional information about Windows 95 hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
161020  (http://support.microsoft.com/kb/161020/EN-US/ ) Implementing Windows 95 Updates
For additional information about Windows 98 and Windows 98 Second Edition hotfixes, click the article number below to view the article in the Microsoft Knowledge Base:
206071  (http://support.microsoft.com/kb/206071/EN-US/ ) General Information on Windows 98 and SE Hotfixes

APPLIES TO
  • Microsoft Windows NT Server 4.0, Terminal Server Edition
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Server 4.0 Enterprise Edition
  • Microsoft Windows 98 Second Edition
  • Microsoft Windows 98 Standard Edition
  • Microsoft Windows 95
Keywords: 
kbhotfixserver kbqfe kbbug kbfix kbgraphxlinkcritical KB251002
 

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