You receive a "There was a problem that caused parts of the Microsoft Online Services Sign-in Assistant to be disabled" error

Article translations Article translations
Article ID: 2512032 - View products that this article applies to.
Expand all | Collapse all

On This Page

PROBLEM

You experience sign-in issues in a Microsoft cloud service such as Office 365, Microsoft Azure, or Windows Intune. Specifically, you see a pop-up dialog box that contains the following error message:
There was a problem that caused parts of the Microsoft Online Services Sign-in Assistant to be disabled. The problem may have been caused by a program that was recently installed.

CAUSE

This problem occurs when the Microsoft Online Services Sign-in Assistant detects that an issue occurred in the Microsoft Online Services Sign-in Assistant service. In this situation, the connection to the service is ended.

SOLUTION

To have us fix the problem for you, go to the "Fix it for me" section. If you prefer to fix this problem yourself, go to the "Let me fix it myself" section.

Fix it for me

To fix this problem, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.

For Windows 8

Collapse this imageExpand this image
assets fixit1
Fix this problem
Microsoft Fix it 20047
Collapse this imageExpand this image
assets fixit2


For Windows 7, Windows Vista, Windows XP, Windows Server 2008 or Windows Server 2003

Collapse this imageExpand this image
assets fixit1
Fix this problem
Microsoft Fix it 50931
Collapse this imageExpand this image
assets fixit2


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD, and then run it on the computer that has the problem.
Then, go to the "Did this fix the problem?" section.

Let me fix it myself

To restart the Microsoft Online Services Sign-in Assistant service, follow these steps:
  1. Click Start, and then click Run.
  2. In the Open box, type services.msc, and then press Enter.

    Collapse this imageExpand this image
    Screen shot of Run windows with services.msc typed
  3. In the list of services, locate and then double-click the Microsoft Online Services Sign-in Assistant service.

    Collapse this imageExpand this image
    Screen shot of Services windows, Microsoft Online Services Sign-in Assistant highlighted
  4. Stop the service. To do this, click Stop, and then wait until the service stops. The Service status should be displayed as Stopped.

    Collapse this imageExpand this image
    Screen shot of Microsoft Online Services Sign-in Assistant properties, showing Service status is stopped
  5. Start the service. To do this, click Start, and then wait until the service starts. The Service status should be displayed as Started.

    Collapse this imageExpand this image
    Screen shot of Microsoft Online Services Sign-in Assistant properties, showing Service status is started
  6. Verify that the issue is resolved and the pop-up dialog box is no longer displayed.
  7. If you continue to see the pop-dialog box, restart the computer, and then verify that the issue is resolved.
Did this fix the problem?
  • Check whether the problem is fixed.
    • If the problem is fixed, you are finished with these steps.
    • If the problem is not fixed, go to the Office 365 Community website, the Azure Active Directory Forums website, or contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email message.

MORE INFORMATION

For more information about related technical issues, see the following Microsoft Knowledge Base article:
2637629 How to troubleshoot non-browser apps that can’t sign in to Office 365, Azure, or Windows Intune  

Still need help? Go to the Office 365 Community website or the Azure Active Directory Forums website.

Properties

Article ID: 2512032 - Last Review: July 9, 2014 - Revision: 27.0
Applies to
  • Microsoft Azure
  • Microsoft Office 365
  • Windows Intune
  • CRM Online via Office 365 E Plans
  • Microsoft Azure Recovery Services
  • Microsoft Windows XP Professional
  • Microsoft Windows XP Home Edition
  • Office 365 User and Domain Management
  • Office 365 Identity Management
Keywords: 
o365 o365a o365e kbgraphxlink o365p kbfixme kbmsifixme o365m o365022013 kbgraphic KB2512032

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com