Artigo: 251274 - Última revisão: quarta-feira, 1 de Novembro de 2006 - Revisão: 2.3

Mensagem de erro quando tenta instalar o programa utilizando o programa de instalação do Windows

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Quando tenta instalar um produto num computador com o Windows NT 4.0 e do Windows Installer é iniciado, poderá receber uma das seguintes mensagens de erro:
  • O serviço Windows Installer falhou o arranque. Contacte o suporte técnico.
  • Erro 1631: O serviço Windows Installer não conseguiu iniciar. Contacte o suporte técnico.
  • Erro interno 2755: Contacte o suporte técnico para assistência.
Depois de receber a mensagem de erro, a instalação termina.

Causa

Este comportamento pode ocorrer quando tenta instalar um programa que é instalado através do Windows Installer. A seguinte chave de registo contém um valor de tipo de dados REG_EXPAND_SZ e a cadeia é nula:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
Userenv.dll devolve uma mensagem de erro quando tenta processar o valor e sai do programa de instalação do Windows. O exemplo seguinte mostra um valor nulo:
Nome do valor: CLASSPATH
Tipo de dados: REG_EXPAND_SZ
Cadeia:

Resolução

Agora é disponibilizada pela Microsoft uma correcção suportada, mas destina-se apenas a corrigir o problema descrito neste artigo. Aplique-a apenas em computadores que tenham este problema específico.

Para resolver este problema, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa de números de telefone do suporte técnico da Microsoft e informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms)
Nota : em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos normais do suporte serão aplicados a problemas adicionais e questões de suporte que não se enquadrem na atualização específica em questão.

A versão portuguesa desta correcção deverá ter os seguintes atributos de ficheiro ou posteriores:
   Date       Time       Size      File name     Platform
   ------------------------------------------------------
   1/18/2000  3:47p      76,048    Userenv.dll   Intel
   1/18/2000  3:47p     123,664    Userenv.dll   Alpha
				

Como contornar

Para contornar este comportamento, remova variáveis de ambiente nulo antes de instalar o programa.

Nota : O impacto potencial de remover essa variável desconhecido está neste momento.

Ponto Da Situação

A Microsoft confirmou que este é um problema no Windows NT 4.0.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kbmt kbhotfixserver kbqfe kbbug kbenv kberrmsg kbfix KB251274 KbMtpt
Tradução automáticaTradução automática
IMPORTANTE: Este artigo foi traduzido por um sistema de tradução automática (também designado por Machine translation ou MT), não tendo sido portanto revisto ou traduzido por humanos. A Microsoft tem artigos traduzidos por aplicações (MT) e artigos traduzidos por tradutores profissionais. O objectivo é simples: oferecer em Português a totalidade dos artigos existentes na base de dados do suporte. Sabemos no entanto que a tradução automática não é sempre perfeita. Esta pode conter erros de vocabulário, sintaxe ou gramática? erros semelhantes aos que um estrangeiro realiza ao falar em Português. A Microsoft não é responsável por incoerências, erros ou estragos realizados na sequência da utilização dos artigos MT por parte dos nossos clientes. A Microsoft realiza actualizações frequentes ao software de tradução automática (MT). Obrigado.
Clique aqui para ver a versão em Inglês deste artigo: 251274  (http://support.microsoft.com/kb/251274/en-us/ )