ID do artigo: 251274 - Última revisão: sexta-feira, 7 de maio de 2004 - Revisão: 2.0

Mensagem de erro ao tentar instalar um programa usando o Windows Installer

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Recolher tudo

Sintomas

Ao tentar instalar um produto em um computador que esteja executando o Windows NT 4.0 e o Windows Installer é iniciado, você pode receber uma das seguintes mensagens de erro:
  • O serviço do Windows Installer falhou ao iniciar. Entre em contato com a equipe de suporte.
  • Erro 1631: O serviço do Windows Installer falhou ao iniciar. Entre em contato com a equipe de suporte.
  • Erro Interno 2755: Entre em contato com o suporte ao produto para obter assistência.
Após receber a mensagem de erro, a instalação é encerrada.

Causa

Esse comportamento pode ocorrer quando você tenta instalar um programa que é instalado usando o Windows Installer. A seguinte chave do Registro contém um valor de tipo de dados REG_EXPAND_SZ e a seqüência é nula:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
O Userenv.dll retorna uma mensagem de erro ao tentar processar o valor e o Windows Installer fecha. O exemplo a seguir mostra um valor nulo:
Nome do valor: CLASSPATH
Tipo de dados: REG_EXPAND_SZ
Seqüência:

Resolução

Uma correção que recebe suporte já foi disponibilizada pela Microsoft, porém destina-se a corrigir somente o problema descrito neste artigo. Aplique-a somente nos computadores que estiverem enfrentando esse problema específico.

Para resolver esse problema, entre em contato com o Atendimento Microsoft para obter a correção. Para obter uma lista completa dos números de telefone do Atendimento Microsoft e as informações sobre os custos de suporte, visite o seguinte site da Microsoft:
http://support.microsoft.com/default.aspx?scid=fh;EN-US;CNTACTMS (http://support.microsoft.com/default.aspx?scid=fh;en-us;cntactms) (site em inglês)
OBSERVAÇÃO: Em casos especiais, as cobranças resultantes das chamadas de suporte podem ser canceladas se um profissional de Suporte Microsoft determinar que uma atualização específica resolverá o problema. Os custos normais de suporte serão aplicados a questões e problemas de suporte que não se qualifiquem à atualização específica em questão.

A versão em inglês dessa correção deverá ter os seguintes atributos de arquivo ou posteriores:
   Data        Hora    Tamanho    Nome de Arquivo    Plataforma
   ------------------------------------------------------
   18/1/2000  15:47      76.048    Userenv.dll   Intel
   18/1/2000  15:47     123.664    Userenv.dll   Alpha
				

Como Contornar

Com solução alternativa para esse comportamento, remova as variáveis de ambiente nulas antes de instalar o programa.

OBSERVAÇÃO: O possível impacto da remoção dessas variáveis é desconhecido nesse momento.

Situação

A Microsoft confirmou que esse é um problema no Windows NT 4.0.

A informação contida neste artigo aplica-se a:
  • Microsoft Windows NT 4.0 Service Pack 3
  • Microsoft Windows NT 4.0 Service Pack 4
  • Microsoft Windows NT 4.0 Service Pack 5
  • Microsoft Windows NT 4.0 Service Pack 6
  • Microsoft Windows NT 4.0 Service Pack 6a
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0
  • Microsoft Windows NT Workstation 4.0 Developer Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kberrmsg kbbug kbfix kbenv KB251274