Wenn die Hyper-V-Rolle auf einem Computer installiert ist, Intel Westmere oder Sandy Bridge Prozessoren verwendet, verringert Leistung in Windows Server 2008 R2

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Artikel-ID: 2517329 - Produkte anzeigen, auf die sich dieser Artikel bezieht
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Problembeschreibung

Betrachten Sie das folgende Szenario:
  • Sie haben einen Windows Server 2008 R2-basierten Computer, die eine große Menge des physischen Speichers und, hat Intel Westmere oder Sandy Bridge Prozessoren.

    Angenommen, Sie verfügen über einen Computer, auf dem 5600 für Intel-Xeon-Prozessoren der Serie verfügt sowie über 48 GB (Gigabyte) physischen Speicher.
  • Installieren Sie die Hyper-V-Rolle auf dem Computer.
In diesem Szenario kann die Leistung des Computers verringern.

Beispielsweise können die folgenden Performance-Probleme auftreten:
  • Die CPU-Auslastung hoch ist, und der Server reagiert langsam, wenn Sie große Dateien auf dem Computer kopieren. Kopieren Sie beispielsweise eine 10-GB-Datei.
  • Der Datenträger-e/a-Leistung der virtuellen Maschinen (VMs) ist langsam.
  • Windows dauert sehr lange, zu starten.

Ursache

Dieses Problem tritt auf, weil der Hypervisor nur acht Bereich Variable Speicher Typ Bereich registriert (MTRRs unterstützt). Darüber hinaus kann nicht der Hypervisor die zusätzliche variabler MTRRs zugreifen, die auf der neuesten Intel-Prozessoren eingeführt werden. Daher einige Bereiche des Systemspeichers auf den Standardwert festgelegt werden.Nicht zwischenspeicherbarerSpeichertyp und die Leistung des Computers erheblich verringert.

Notizen

  • MTRRs sind Prozessor Modell spezielle Register (MSRs), die die Standard-Zwischenspeicherung für Bereiche des physischen Speichers zu steuern.
  • Intel Westmere und Sandy Bridge Prozessoren einführen zusätzliche variabler MTRRs Systeme eine große Menge an Arbeitsspeicher verwenden aktivieren.

Lösung

Hotfix-Informationen

Es ist ein unterstützter Hotfix von Microsoft erhältlich. Dieser Hotfix ist jedoch vorgesehen, um nur das Problem zu beheben, das in diesem Artikel beschrieben wird. Installieren Sie diesen Hotfix nur auf Systemen, bei die dieses spezielle Problem auftritt.

Wenn der Hotfix zum Download zur Verfügung steht, ist ein Abschnitt "Hotfixdownload available" (Hotfixdownload verfügbar"am oberen Rand dieses Knowledge Base-Artikel. Wenn dieser Abschnitt nicht angezeigt wird, senden Sie eine Anfrage an Microsoft Customer Service and Support, um den Hotfix zu erhalten.

HinweisFalls weitere Probleme auftreten oder andere Schritte zur Problembehandlung erforderlich ist, müssen Sie möglicherweise eine separate Serviceanfrage erstellen. Die normalen Supportkosten gelten für zusätzliche Supportfragen und Probleme, die für diesen speziellen Hotfix nicht qualifizieren. Eine vollständige Liste der Microsoft-Kundendienst und Support-Telefonnummern oder eine separate Serviceanfrage erstellen finden Sie auf der folgenden Microsoft-Website:
http://Support.Microsoft.com/contactus/?WS=Support
HinweisDas Formular "Hotfixdownload available" (Hotfixdownload verfügbar"zeigt die Sprachen an, für die der Hotfix verfügbar ist. Wenn Sie Ihre Sprache nicht angezeigt werden, ist es da ein Hotfix nicht für diese Sprache verfügbar ist.

Voraussetzungen

Um diesen Hotfix installieren zu können, muss eine der folgenden Betriebssysteme ausgeführt werden:
  • WindowsServer 2008 R2
  • Windows Server 2008 R2 Servicepack 1 (SP1)
Weitere Informationen dazu, wie Sie ein Servicepack für Windows Server 2008 R2 zu erhalten finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
976932Informationen zum Servicepack 1 für Windows 7 und Windows Server 2008 R2

Registrierungsinformationen

Um den Hotfix in diesem Paket verwenden, müssen Sie keinen Änderungen an der Registrierung vornehmen.

Neustartanforderung

Sie müssen den Computer neu starten, nachdem Sie diesen Hotfix anwenden.

Ersetzte Hotfixes

Dieser Hotfix ersetzt keinen zuvor veröffentlichten Hotfix.

Dateiinformationen

Die internationale Version dieses Hotfixes installiert Dateien mit die Attributen, die in den folgenden Tabellen aufgeführt sind. Die Datumsangaben und Uhrzeiten für diese Dateien werden in Coordinated Universal Time (UTC) aufgeführt. Die Datumsangaben und Uhrzeiten für diese Dateien auf Ihrem lokalen Computer werden in Ihrer lokalen Zeit zusammen mit Ihren aktuellen Daylight Saving Time (DST)-Bias angezeigt. Darüber hinaus können die Datumsangaben und Uhrzeiten ändern, wenn Sie bestimmte Operationen auf Dateien anwenden.
Hinweise zu den Dateiinformationen für Windows Server 2008 R2
WichtigWindows 7-Updates und Windows Server 2008 R2-Updates sind im selben Paket enthalten. Allerdings werden Hotfixes auf der Hotfix-Anforderungsseite unter beiden Betriebssystemen aufgeführt. Um das Hotfix-Paket anzufordern, das auf einem oder beiden Betriebssystemen angewendet wird, wählen Sie den Hotfix, der auf der Seite unter "Windows 7/Windows Server 2008 r2" aufgeführt ist. Bezieht sich immer auf den Abschnitt "Gilt für" in Artikel, um das eigentliche Betriebssystem zu bestimmen, dem für jeden Hotfix gilt.
  • Die Dateien, die für ein bestimmtes Produkt SR_Level (RTM, SP geltenn), und Servicebereiche (LDR, GDR) kann identifiziert werden, durch die Versionsnummern der Datei untersuchen, wie in der folgenden Tabelle dargestellt.
    Tabelle minimierenTabelle vergrößern
    VersionProduktSR_LevelServicebereiche
    6.1.7600.16xxxWindowsServer 2008 R2RTMGDR
    6.1.7600.20xxxWindowsServer 2008 R2RTMLDR
    6.1.7601.17xxxWindowsServer 2008 R2SP1GDR
    6.1.7601.21xxxWindowsServer 2008 R2SP1LDR
  • Die MANIFESTEN-Dateien (. manifest) und MUM-Dateien (.mum), die installiert werden für jede Umgebung sindseparat aufgeführtim Abschnitt "Weitere Dateiinformationen für WindowsServer 2008 R2". MUM- und MANIFEST-Dateien sowie die zugeordneten (.cat) Sicherheitskatalogdateien, sind äußerst wichtig, den Status der aktualisierten Komponenten verwalten. Die Sicherheitskatalogdateien, deren Attribute nicht aufgelistet sind, sind mit einer digitalen Microsoft-Signatur signiert.
Für alle unterstützten x 64-basierten Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameDateiversionDateigrößeDatumZeitPlattform
Hvax64.exe6.1.7600.16792634,88009-Apr-201104: 07X 64
Bereitet "Hvboot.sys"6.1.7600.16792117,63209-Apr-201106: 45X 64
Hvix64.exe6.1.7600.16792687,10409-Apr-201104: 07X 64
Hvax64.exe6.1.7600.20941635,39209-Apr-201104: 12X 64
Bereitet "Hvboot.sys"6.1.7600.20941117,63209-Apr-201106: 54X 64
Hvix64.exe6.1.7600.20941687,61609-Apr-201104: 12X 64
Hvax64.exe6.1.7601.17592614,91209-Apr-201104: 05X 64
Bereitet "Hvboot.sys"6.1.7601.17592118,14409-Apr-201107: 02X 64
Hvix64.exe6.1.7601.17592652,80009-Apr-201104: 05X 64
Hvax64.exe6.1.7601.21701615,42409-Apr-201103: 59X 64
Bereitet "Hvboot.sys"6.1.7601.21701118,14409-Apr-201106: 50X 64
Hvix64.exe6.1.7601.21701653,31209-Apr-201103: 59X 64

Status

Microsoft hat bestätigt, dass dies ein Problem in Microsoft-Produkten handelt, die im Abschnitt "Beziehen sich auf" aufgeführt sind.

Weitere Informationen

Weitere Informationen zur Terminologie für Softwareupdates finden Sie in folgendem Artikel der Microsoft Knowledge Base anzuzeigen:
824684Beschreibung der Standardterminologie, die zum Beschreiben von Softwareupdates von Microsoft verwendet wird

Weitere Dateiinformationen

Weitere Dateiinformationen für Windows Server 2008 R2

Weitere Dateien für alle unterstützten x 64-basierten Versionen von Windows Server 2008 R2
Tabelle minimierenTabelle vergrößern
DateinameAmd64_67bea49f4b337c102608760a878b0956_31bf3856ad364e35_6.1.7601.17592_none_37ff42790a6900fc.Manifest
DateiversionNicht zutreffend
Dateigröße710
Datum (UTC)11-Apr-2011
Zeit (UTC)13: 43
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Datum (UTC)11-Apr-2011
Zeit (UTC)13: 43
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Datum (UTC)11-Apr-2011
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Datum (UTC)11-Apr-2011
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Datum (UTC)09-Apr-2011
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DateinameAmd64_microsoft-hyper-V-Treiber-hypervisor_31bf3856ad364e35_6.1.7600.20941_none_8cf729d998370acb.manifest
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Datum (UTC)09-Apr-2011
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Datum (UTC)09-Apr-2011
Zeit (UTC)07: 12

Eigenschaften

Artikel-ID: 2517329 - Geändert am: Donnerstag, 14. April 2011 - Version: 2.0
Die Informationen in diesem Artikel beziehen sich auf:
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Foundation
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kbautohotfix kbqfe kbHotfixServer kbfix kbsurveynew kbexpertiseinter kbexpertiseadvanced kbmt KB2517329 KbMtde
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Den englischen Originalartikel können Sie über folgenden Link abrufen: 2517329
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