L'UPN locale o l'ID di accesso alternativo non corrispondono a nomi utente di Office 365, Azure o Windows Intune

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PROBLEMA

Quando si esegue lo strumento di sincronizzazione di Active Directory di Microsoft Azure, si nota che il nome utente di un utente di Office 365, Azure o Windows Intune non corrisponde a nome principale di utente locale dell'utente (UPN) o alternativi ID di accesso. L'UPN o ID di accesso alternativo potrebbe essere un nome utente dell'utente, indirizzo di posta elettronica o un altro attributo.

CAUSA

Esistono tre possibili cause di questo problema:
  • Il dominio dell'azienda non Ŕ ancora verificato. Il dominio dell'ID di accesso alternativo o UPN locale Ŕ un dominio che non Ŕ ancora verificato nel tuo account organizzativa.
  • L'utente gestito dal cloud dispone di una licenza. L'utente nell'account organizzativa non Ŕ federato ed Ŕ stata assegnata una licenza.
  • Il suffisso del dominio dell'ID di accesso alternativo o UPN Ŕ stato modificato da un dominio federato a un altro dominio federato.

SOLUZIONE

Scenario 1: Il dominio dell'azienda non Ŕ ancora verificato

Assicurarsi che il suffisso del dominio dell'ID di accesso alternativo o UPN Ŕ verificato all'interno dell'organizzazione. Se si esegue la sincronizzazione degli utenti prima che si verifica del dominio, il nome utente dell'utente viene modificato di conseguenza.
Come determinare il suffisso di dominio per un UPN
In un controller di dominio o in un computer in cui Ŕ installato il Toolkit di amministrazione di Windows Server, attenersi alla seguente procedura:
  1. Aprire utenti e computer Active Directory. A tale scopo, fare clic su Start, scegliere Esegui, tipo DSA. msc, quindi scegliere OK.
  2. Il pulsante destro del dominio e quindi fare clic su Trova.
  3. Nella casella nome digitare il nome visualizzato dell'utente e fare clic su Trova.
  4. Il nome utente nei risultati della ricerca, fare doppio clic e la conto scheda.
  5. Nella casella nome di accesso utente, si noti la parte del dominio del nome di accesso utente. Ci˛ Ŕ noto come il suffisso UPN.

    Riduci l'immagineEspandi l'immagine
    Finestra di dialogo ProprietÓ utente con il nome di accesso utente
Come determinare il suffisso di dominio per un ID di accesso alternativo
In un controller di dominio o in un computer in cui Ŕ installato il Toolkit di amministrazione di Windows Server, Ŕ possibile utilizzare Active Directory Service Interfaces Editor (ADSI Edit) per determinare il suffisso di dominio per un ID di accesso alternativo. Per ulteriori informazioni su come eseguire questa operazione, vedereUtilizzo di ADSI Edit per modificare Active Directory attributi.

Nota. Se il suffisso di dominio non Ŕ un dominio registrato, Ŕ necessario registrare il dominio utilizzando un registro di dominio o cambiare il suffisso di dominio dell'utente a un dominio Ŕ stato registrato. Questo suffisso di dominio deve essere registrato mediante un registro di dominio prima di verificare il dominio del tuo account organizzativa.

Scenario 2: L'utente gestito dal cloud dispone di una licenza

Per aggiornare l'UPN di un utente gestito dal cloud che Ŕ stato assegnato una licenza, attenersi alla seguente procedura:
  1. Avviare il Azure Active Directory Module per Windows PowerShell e quindi connettersi a Azure Active Directory (AD Azure). Per ulteriori informazioni su come eseguire questa operazione, visitare il seguente sito Web Microsoft:
    Connessione ad AD Azure tramite Windows PowerShell
  2. Eseguire il seguente cmdlet Windows PowerShell:

    Set-MsolUserPrincipalName -UserPrincipalName [CurrentUPN] -NewUserPrincipalName [NewUPN]

Scenario 3: Il suffisso del dominio dell'ID di accesso alternativo o UPN modificato da un dominio federato a un altro dominio federato

Seguire i passaggi nel seguente articolo della Microsoft Knowledge Base:
2669550Modifiche non sono sincronizzate tramite lo strumento di sincronizzazione di Azure Active Directory dopo aver modificato l'UPN di un account utente per l'utilizzo di un altro dominio federato

ULTERIORI INFORMAZIONI

I comandi di Windows PowerShell in questo articolo richiedono la Azure Active Directory Module per Windows PowerShell. Per ulteriori informazioni, vedere il seguente sito Web Microsoft: Per ulteriori informazioni su come aggiungere e verificare un dominio in Office 365, vedere il seguente sito Web Microsoft:
Aggiungere il dominio a Office 365
Per ulteriori informazioni su come aggiornare altri attributi sincronizzati, fare clic sul numero dell'articolo riportato di seguito per visualizzare l'articolo della Microsoft Knowledge Base:
2643629Non sincronizzare uno o pi¨ oggetti quando si utilizza lo strumento di sincronizzazione di Azure Active Directory
Ulteriore assistenza? Vai al Community di Office 365 sito Web o il Forum di Azure Active Directory .

ProprietÓ

Identificativo articolo: 2523192 - Ultima modifica: lunedý 14 luglio 2014 - Revisione: 38.0
Le informazioni in questo articolo si applicano a:
  • Microsoft Azure
  • Microsoft Azure Active Directory
  • Microsoft Office 365
  • Windows Intune
  • CRM Online via Office 365 E Plans
  • Microsoft Azure Recovery Services
  • Office 365 Identity Management
Chiavi:á
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