Artikel-ID: 252332 - Geändert am: Freitag, 7. April 2006 - Version: 3.2

Ereignis-ID 3013 beim Kopieren von Dateien auf einen stark beanspruchten Server

Dieser Artikel wurde zuvor veröffentlicht unter D43648
Dieser Artikel ist eine Übersetzung des folgenden englischsprachigen Artikels der Microsoft Knowledge Base:
252332  (http://support.microsoft.com/kb/252332/EN-US/ ) Event ID 3013 When Copying Files to a Server Under Disk Stress
Bitte beachten Sie: Bei diesem Artikel handelt es sich um eine Übersetzung aus dem Englischen. Es ist möglich, dass nachträgliche Änderungen bzw. Ergänzungen im englischen Originalartikel in dieser Übersetzung nicht berücksichtigt sind. Die in diesem Artikel enthaltenen Informationen basieren auf der/den englischsprachigen Produktversion(en). Die Richtigkeit dieser Informationen in Zusammenhang mit anderssprachigen Produktversionen wurde im Rahmen dieser Übersetzung nicht getestet. Microsoft stellt diese Informationen ohne Gewähr für Richtigkeit bzw. Funktionalität zur Verfügung und übernimmt auch keine Gewährleistung bezüglich der Vollständigkeit oder Richtigkeit der Übersetzung.
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Problembeschreibung

Wenn Sie in großem Umfang (der ausreicht, um auf dem Server zu einer starken Datenträgerbeanspruchung zu führen) Dateien über das Netzwerk an einen Server übertragen, können im Ereignisprotokoll des Clients eine oder mehrere Instanzen der folgenden Fehlermeldung angezeigt werden:
   Fehler 3013, "Der Redirectordienst hat eine
   Anforderung an <Servername> wegen
   Zeitüberschreitung aufgegeben."
Wegen dieser Zeitüberschreitung des Redirectordienstes sind Schreibvorgänge auf dem Server möglicherweise nicht erfolgreich.

Ursache

Bei Fehlermeldungen zu Zeitüberschreitungen des Redirectordienstes handelt es sich um allgemeine Fehlermeldungen, die nur darauf hinweisen, dass der Server dem Client innerhalb des Zeitlimits für den Redirectordienst nicht geantwortet hat. Es gibt zwar diverse mögliche Ursachen für Zeitüberschreitungen des Redirectordienstes, wenn die folgenden Umstände vorliegen, kann dieser Fehler jedoch auch aufgrund eines Problems mit dem Cache-Manager auf dem Server auftreten:
  • Auf den Server werden extrem viele Dateien über das Netzwerk übertragen.
  • Der Server ist mit mehr als 128 MB Speicher konfiguriert.
  • Der Datenträgerdurchsatz ist aus irgendeinem Grund eingeschränkt (RAID 5).
Dieses Cache-Problem tritt auf, wenn Sie umfangreiche Dateien auf die Festplatte eines Computers schreiben, der über sehr viel Speicherplatz verfügt. Ist unter diesen Umständen die verfügbare Bandbreite für die Festplatte geringer als die, die der Thread "Verzögertes Schreiben" benötigt, um den Schreibvorgang in einem Zyklus komplett abzuschließen, kann dieser Thread die Dateiressourcen für einen sehr langen Zeitraum blockieren. Der Server Message Block (SMB), der den Schreibvorgang initiiert hat, benötigt zu viel Zeit, um den Vorgang abzuschließen, so dass für den Client-Redirector schließlich eine Zeitüberschreitung eintritt.

Bisher konnte dieses Problem nur reproduziert werden, wenn man von Windows NT 4.0-Clients aus eine Verbindung zu einem Server hergestellt hat, auf dem Windows 2000 ausgeführt wird. Dieses Problem wird am häufigsten dann beobachtet, wenn der Server mit Software- oder Hardware-RAID arbeitet, wie zum Beispiel RAID 5 (Striping mit Paritätsprüfung), durch den der Datenträgerdurchsatz verlangsamt wird.

Lösung

Windows 2000:
Installieren Sie das neueste Service Pack für Windows 2000, um dieses Problem zu beheben. Weitere Informationen finden Sie in folgendem Artikel der Microsoft Knowledge Base:
D43250  (http://support.microsoft.com/kb/D43250/DE/ ) So erhalten Sie das neueste Windows 2000 Service Pack

Windows NT 4.0:
Ein Update zur Behebung dieses Problems ist inzwischen von Microsoft erhältlich; dieses Update wurde jedoch ausschließlich zur Behebung des in diesem Artikel beschriebenen Problems entwickelt und sollte nur auf Systeme angewendet werden, die von einem Problem dieser Art betroffen sein könnten. Dieses Update wird unter Umständen zu einem späteren Zeitpunkt weiteren Tests unterzogen. Wenn Ihr System durch dieses Problem nicht schwerwiegend beeinträchtigt ist, empfiehlt Microsoft, auf das nächste Service Pack für Windows NT 4.0 zu warten, das dieses Update enthält.

Wenn Sie das Problem sofort beheben wollen, wenden Sie sich an den Microsoft-Produktsupport, um das Update zu erhalten. Die Telefonnummern des Technischen Supports lauten:
Deutschland: 0180 567 23 30
Österreich: 01 50222 23 30
Schweiz: 0848 80 23 30
Alternativ erhalten Sie auch eine vollständige Liste mit Telefonnummern des Microsoft Software Service unter der folgenden Adresse im World Wide Web:
http://support.microsoft.com/default.aspx?scid=fh;DE;PHONENUMBERS (http://support.microsoft.com/default.aspx?scid=fh;de;phonenumbers)

Status

Windows 2000:
Microsoft hat bestätigt, dass es sich dabei um ein Problem bei den Microsoft-Produkten handelt, die zu Beginn dieses Artikels aufgeführt sind. Dieses Problem wurde in Windows 2000 Service Pack 1 erstmals korrigiert.

Windows NT 4.0:
Microsoft hat bestätigt, dass es sich dabei um ein Problem in Windows NT 4.0 handelt.

Weitere Informationen

Weitere Informationen über mögliche Ursachen für Fehlermeldungen des Typs 3013 finden Sie im folgenden Artikel der Microsoft Knowledge Base:
148426  (http://support.microsoft.com/kb/148426/DE/ ) Troubleshooting Event ID 3013


Die Informationen in diesem Artikel beziehen sich auf:
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
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kbqfe kbhotfixserver kberrmsg KB252332
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