ID evento 3013 Copia di file in un server con disco sovraccarico

Traduzione articoli Traduzione articoli
Identificativo articolo: 252332 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo è stato precedentemente pubblicato con il codice di riferimento I252332
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Quando in un server si esegue una quantità di trasferimenti di file di rete tale da provocare un sovraccarico del disco, nei registri eventi del client potrebbe essere visualizzata una o più istanze di un messaggio di errore analogo al seguente:
Errore 3013, "Il redirector ha terminato una richiesta a nomeserver "
A causa di questi timeout del redirector, le operazioni di scrittura sul server potrebbero non riuscire.

Cause

I messaggi di errore di timeout del redirector sono errori generici che indicano semplicemente che il server non ha risposto al client prima del periodo di timeout del redirector. Nonostante le cause degli errori di timeout del redirector siano molteplici, questo messaggio di errore potrebbe verificarsi a causa di un problema di gestione della cache nel server in presenza delle seguenti condizioni:
  • Nel server viene eseguito un numero eccessivo di trasferimenti di file di rete.
  • Il server è configurato con più di 128 MB di memoria.
  • Per qualche motivo, la velocità effettiva del disco risulta limitata (RAID 5).
Questo problema a livello di cache viene riscontrato quando si scrivono file di grandi dimensioni in un disco di un computer che dispone di molta memoria. In tale situazione, se la larghezza di banda disponibile per il disco è inferiore a quella richiesta per scrivere completamente quanto necessario in un unico ciclo, le risorse del file possono essere bloccate per un periodo di tempo prolungato. L'SMB (Server Message Block) che ha iniziato l'operazione di scrittura impiega troppo tempo per completarla con un conseguente timeout del redirector client.

Questo problema è stato finora riscontrato solo durante l'utilizzo di client di Windows NT 4.0 per la connessione a un server che esegue Windows 2000, in particolare se il server utilizza un software o hardware RAID che rallenta la velocità effettiva del disco, come RAID 5 (striping con parità).

Risoluzione

Windows 2000

Per risolvere questo problema, richiedere il service pack di Windows 2000 più aggiornato. Per ulteriori informazioni, vedere l'articolo della Knowledge Base riportato di seguito (informazioni in lingua inglese):
260910Come ottenere il Service Pack più recente per Windows 2000

Windows NT 4.0

Microsoft ha messo attualmente a disposizione una correzione che risolve questo problema. Poiché tale correzione non è ancora stata completamente testata, deve essere utilizzata solo per i sistemi in cui si verifica questo problema specifico. Se questo problema non causa gravi difficoltà, si consiglia di attendere la versione successiva di Windows NT 4.0 che contiene tale correzione.

Per risolvere immediatamente il problema, contattare il Servizio Supporto Tecnico Clienti Microsoft per ottenere la correzione. Per un elenco completo dei servizi di supporto Microsoft e sui costi di assistenza, visitare il seguente sito Web (informazioni in lingua inglese):
http://support.microsoft.com/directory/overview.asp
La versione inglese di tale correzione dispone dei seguenti attributi del file o versioni successive:
   Data         Ora     Dimensione        Nome file     Piattaforma
   --------------------------------------------------------
   02/25/2000   03:55p   953,728     Ntkrnlmp.exe  Intel
   02/25/2000   03:54p   933,312     Ntoskrnl.exe  Intel
   02/25/2000   03:53p   1,401,472   Ntkrnlmp.exe  Alpha
   02/25/2000   03:53p   1,373,312   Ntoskrnl.exe  Alpha

Status

Windows 2000

Microsoft ha confermato che questo problema riguarda Windows 2000. Questo problema è stato già risolto in Windows 2000 Service Pack 1.

Windows NT 4.0

Microsoft ha confermato che si tratta di un problema di Windows NT 4.0.

Informazioni

Per ulteriori informazioni su altre possibili cause del messaggio di errore 3013, fare clic sul numero dell'articolo della Knowledge Base riportato di seguito (informazioni in lingua inglese):
148426 Troubleshooting Event ID 3013

Proprietà

Identificativo articolo: 252332 - Ultima modifica: venerdì 31 marzo 2006 - Revisione: 3.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Chiavi: 
kbqfe kbhotfixserver kbbug kbbug4.00 kberrmsg kbfix kbfix4.00 kbnetwork win2000presp1fix KB252332
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com