ID de evento 3013 ao copiar ficheiros para um servidor com uma elevada taxa de utilização

Traduções de Artigos Traduções de Artigos
Artigo: 252332 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT252332
Expandir tudo | Reduzir tudo

Nesta página

Sintomas

Ao executar uma grande quantidade de transferências de ficheiros de rede para um servidor (suficiente grande para causar uma elevada taxa de utilização do disco no servidor), podem ser apresentadas uma ou mais ocorrências da seguinte mensagem de erro nos registos de eventos de cliente:
Erro 3013, "O redireccionador excedeu o tempo limite para nome_do_servidor "
(Error 3013, "The redirector has timed out to nome_do_servidor Como resultado destes tempos limite excedidos do redireccionador, as operações de escrita no servidor poderão não ser efectuadas com êxito.

Causa

As mensagens de erro de tempo limite excedido do redireccionador são erros genéricos que indicam simplesmente que o servidor não estava a responder ao cliente antes do período de tempo limite excedido do redireccionador. Ainda que possam existir diversas causas para os erros de tempo limite excedido do redireccionador, esta mensagem de erro pode ocorrer por causa de um problema do gestor de cache no servidor, caso se verifiquem as seguintes condições:
  • Existe uma quantidade extremamente elevada de transferências de ficheiros de rede em curso no servidor.
  • O servidor está configurado com mais de 128 MB de memória.
  • O débito do disco está limitado por qualquer motivo (RAID 5).
Este problema da cache é encontrado quando escreve ficheiros de grandes dimensões no disco num computador que dispõe de uma elevada quantidade de memória. Nestas condições, se a largura de banda disponível para o disco for menor do que aquela de que o escritor lento necessita para escrever tudo o que pretende num ciclo, o escritor pode acabar por bloquear os recursos dos ficheiros durante longos períodos de tempo. O bloco de mensagens de servidor (SMB, Server Messages Block) que iniciou a operação de escrita demora demasiado tempo a concluir a operação e o redireccionador do cliente acaba por exceder o tempo limite.

Até à data, este problema só foi reproduzido em clientes Windows NT 4.0 utilizados para estabelecer ligação com um servidor com o Windows 2000. Este problema é registado com maior frequência quando o servidor está a utilizar software ou hardware RAID que diminui o débito do disco, como, por exemplo, o RAID 5 (repartição com paridade).

Resolução

Windows 2000

Para resolver este problema, obtenha o Service Pack mais recente para o Windows 2000. Para obter informações adicionais, clique no seguinte número de artigo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
260910 Como obter o Service Pack mais recente do Windows 2000
NOTA: Esta é uma correcção do lado do servidor e o Service Pack deve ser aplicado ao servidor nome_do_servidor indicado na mensagem de erro 3013 para resolver este problema.

Windows NT 4.0

Já existe uma correcção suportada da Microsoft disponível destinada apenas a corrigir o problema descrito neste artigo. Aplique-a apenas a sistemas que registam este problema específico. Esta correcção poderá ser sujeita a testes adicionais. Assim sendo, se não for afectado seriamente por este problema, a Microsoft recomenda que aguarde pelo próximo Windows NT 4.0 que contenha esta correcção.

Para resolver este problema imediatamente, contacte o suporte técnico da Microsoft para obter a correcção. Para obter uma lista completa dos números de telefone de suporte técnico da Microsoft, bem como informações sobre os custos de suporte, visite o seguinte Web site da Microsoft:
http://www.microsoft.com/portugal/mscorp/telefones.asp
NOTA: Em casos especiais, os custos normalmente inerentes às chamadas de suporte poderão ser anulados, se um técnico de suporte da Microsoft determinar que uma actualização específica resolverá o problema. Os custos de suporte normais referir-se-ão a perguntas de suporte adicionais e a problemas a que a actualização específica em questão não se aplique.

A versão inglesa desta correcção deverá ter os seguintes atributos de ficheiro, ou posteriores:
 
   Data         Hora      Tamanho   Nome do ficheiro  Plataforma
   --------------------------------------------------------
   02/25/2000   03:55p   953,728     Ntkrnlmp.exe  Intel
   02/25/2000   03:54p   933,312     Ntoskrnl.exe  Intel
   02/25/2000   03:53p   1,401,472   Ntkrnlmp.exe  Alpha
   02/25/2000   03:53p   1,373,312   Ntoskrnl.exe  Alpha 

NOTA: Esta é uma correcção do lado do servidor e o Service Pack deve ser aplicado ao servidor nome_do_servidor indicado na mensagem de erro 3013 para resolver este problema.

Ponto Da Situação

Windows 2000

A Microsoft confirmou que este problema existe no Windows 2000. Este problema foi corrigido pela primeira vez no Windows 2000 Service Pack 1.

Windows NT 4.0

A Microsoft confirmou que este problema existe no Windows NT 4.0.

Mais Informação

Para obter informações adicionais sobre outras causas possíveis para as mensagens de erro 3013, clique no número de artigo existente abaixo para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
148426 Troubleshooting Event ID 3013

Propriedades

Artigo: 252332 - Última revisão: 13 de abril de 2006 - Revisão: 3.0
A informação contida neste artigo aplica-se a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Server 4.0 Standard Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Palavras-chave: 
kbqfe kbhotfixserver kbbug kberrmsg kbfix kbnetwork kbqfe kbwin2000presp1fix kbwin2000sp1fix KB252332

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com