Fehlermeldung: Windows SIM konnte keine Katalog- oder Parameteranzahlkonflikt generieren

Dieser Artikel hilft beim Beheben von Fehlern, die beim Generieren eines Katalogs (CLG) in Windows System Image Manager (WSIM) auftreten.

Gilt für: Windows 7 Service Pack 1, Windows Server 2012 R2
Ursprüngliche KB-Nummer: 2524737

Symptome

Wenn Sie einen Katalog (.clg) in Windows System Image Manager (WSIM) generieren oder auf edit Unattend.xml in Microsoft Deployment Toolkit (MDT) klicken und versuchen, eine Katalogdatei zu generieren, kann es einen längeren Zeitraum dauern, bis die Fehlermeldung generiert wird. Möglicherweise erhalten Sie die folgenden Fehlermeldungen:

Windows SIM konnte keinen Katalog generieren. Unterstützung bei der Problembehandlung finden Sie im Thema "Windows System Image Manager Technical Reference" im Windows OPK oder Windows AIK-Benutzerhandbuch. System.InvalidOperationException: Der Vorgang konnte nicht abgeschlossen werden.

oder

Fehler bei der Ausführung von Windows System Image Manager. System.Reflection.TargetParameterCountException: Parameteranzahl stimmt nicht überein.

oder

Ausführen des Vorgangs "generate" für das Ziel "Catalog". Der Vorgang konnte nicht abgeschlossen werden.

Ursache

Der Windows-Systemimage-Manager weist das folgende Standardverhalten zum Generieren von Katalogdateien auf:

x86 Windows System Image Manager

Kann Kataloge für x86-, x64- und Itanium-basierte Windows-Images erstellen.

x64 Windows System Image Manager

Kataloge können nur für x64-Windows-Images erstellt werden.

Itanium-basiertes Windows System Image Manager

Kataloge können nur für Itanium-basierte Windows-Images erstellt werden

Lösung

Generieren Sie die Katalogdatei auf einer unterstützten Plattform. Für das Microsoft Deployment Toolkit ist es möglich, DeploymentShare von einem anderen Computer mit MDT und dem AIK mit der richtigen Architektur zu integrieren, um den Katalog zu generieren. Anschließend kann vom ursprünglichen MDT-Server darauf zugegriffen werden.

Weitere Informationen

Es handelt sich hierbei um ein beabsichtigtes Verhalten. Weitere Informationen finden Sie unter Grundlegendes zu Windows-Imagedateien und -Katalogdateien.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Bereitstellungsprobleme ausführen.