REVISIÓN: La funcionalidad de IntelliSense no funcione para un proyecto de Visual C++ en 2010 de Visual Studio en un equipo que ejecuta Windows XP

Seleccione idioma Seleccione idioma
Id. de artículo: 2526044 - Ver los productos a los que se aplica este artículo
Expandir todo | Contraer todo

En esta página

Síntomas

Cuando se edita un proyecto de Visual C++ en Microsoft Visual Studio 2010 en un equipo que ejecuta Windows XP, la funcionalidad de IntelliSense no funcionen.

Por ejemplo, la información de parámetros, información rápida, Autocompletar, lista de miembros y las características de las líneas de subrayado de errores no funcionen.

Causa

Este problema se produce si no se puede ejecutar el proceso de Vcpkgsrv.exe.

Después de aplica una actualización para el archivo Ole32.dll, el proceso de Vcpkgsrv.exe no puede manejar una interfaz COM en el archivo Ole32.dll. Por lo tanto, el proceso termina cuando se utiliza el archivo Ole32.dll y, a continuación, la funcionalidad de IntelliSense no está disponible.

NotaEl proceso de Vcpkgsrv.exe implementa la funcionalidad de IntelliSense.

Solución

Información de la revisión


Hay un hotfix compatible de Microsoft. Sin embargo, esta revisión se diseñó para corregir el problema descrito en este artículo. Esta revisión sólo se aplican a sistemas que experimenten este problema específico. Esta revisión podría ser sometida a comprobaciones adicionales. Por lo tanto, si no se ve muy afectado por este problema, recomendamos que espere a que la próxima actualización de software que contenga este hotfix.

Para descargar este hotfix desde MSDN Code Gallery, visite el siguiente sitio Web de Microsoft:
http://Code.msdn.Microsoft.com/KB2526044

Nota La Galerie de Code muestra los idiomas para los que la revisión está disponible. Si no ve su idioma en la lista, es porque la página de recursos de la Galería de códigos no está disponible para ese idioma.

Nota Si se producen problemas adicionales o si necesita solucionar un problema, es posible que deba crear una solicitud de servicio independiente. Los costos de soporte técnico usuales se aplicarán a las cuestiones y problemas que no reúnan los requisitos para esta revisión en cuestión. Para obtener una lista completa de los números de teléfono de soporte y servicio al cliente de Microsoft o para crear una solicitud de servicio independiente, visite el siguiente sitio Web de Microsoft:
http://support.Microsoft.com/contactus/?ws=support
Nota También puede descargar este hotfix desde el sitio Web de Microsoft siguiente:
¿http://Connect.Microsoft.com/VisualStudio/downloads/downloaddetails.aspx?DownloadID = 35735

Requisitos previos

Para aplicar este hotfix, debe tener el Microsoft Visual Studio 2010 Service Pack 1 (SP1) instalado.

Requisito de reinicio

No es necesario que reinicie el equipo después de aplicar este hotfix.

Información de reemplazo de hotfix

Esta revisión no sustituye a ninguna revisión publicada previamente.

Información de archivo

La versión global de esta revisión tiene los atributos de archivo (o atributos de archivo más reciente) mostrados en la tabla siguiente. Las fechas y horas de estos archivos se muestran en hora Universal coordinada (UTC). Al ver la información del archivo, se convierte en hora local. Para ver la diferencia entre la hora UTC y la hora local, utilice el Zona horaria ficha en la Fecha y hora elemento de Panel de Control.

Contraer esta tablaAmpliar esta tabla
Nombre de archivoVersión del archivoTamaño de archivoFechaTiempoPlataforma
Vcpkgsrv.exe10.0.40219.308100,17607-Abr-201104: 00x 86

Estado

Microsoft ha confirmado que se trata de un problema de los productos de Microsoft que se enumeran en la sección "Se refiere a:".

Propiedades

Id. de artículo: 2526044 - Última revisión: martes, 24 de mayo de 2011 - Versión: 2.0
La información de este artículo se refiere a:
  • Microsoft Visual Studio 2010 Premium with MSDN
  • Microsoft Visual Studio 2010 Professional
  • Microsoft Visual Studio 2010 Ultimate
  • Microsoft Visual Studio 2010 Service Pack 1
Palabras clave: 
kbqfe kbfix kbhotfixserver kbexpertiseadvanced kbsurveynew atdownload kbmt KB2526044 KbMtes
Traducción automática
IMPORTANTE: Este artículo ha sido traducido por un software de traducción automática de Microsoft (http://support.microsoft.com/gp/mtdetails) en lugar de un traductor humano. Microsoft le ofrece artículos traducidos por un traductor humano y artículos traducidos automáticamente para que tenga acceso en su propio idioma a todos los artículos de nuestra base de conocimientos (Knowledge Base). Sin embargo, los artículos traducidos automáticamente pueden contener errores en el vocabulario, la sintaxis o la gramática, como los que un extranjero podría cometer al hablar el idioma. Microsoft no se hace responsable de cualquier imprecisión, error o daño ocasionado por una mala traducción del contenido o como consecuencia de su utilización por nuestros clientes. Microsoft suele actualizar el software de traducción frecuentemente.
Haga clic aquí para ver el artículo original (en inglés): 2526044

Enviar comentarios

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com