Article ID: 2526776 - Last Review: March 31, 2012 - Revision: 5.0

An update that enables Windows 8 Consumer Preview or Windows Server "8" Beta to be hosted in a Hyper-V virtual machine on Windows Server 2008 R2

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SYMPTOMS

Consider the following scenario:
  • You install the Hyper-V server role on a computer that is running Windows Server 2008 R2.
  • You create a virtual machine on the Windows Server 2008 R2-based computer that is running Windows 8 Consumer Preview or Windows Server "8" Beta.
In this scenario, you may experience one or more of the following issues:
  • The Windows 8 Consumer Preview or Windows Server "8" Beta virtual machine stops responding.
  • The Windows Server 2008 R2 host computer displays a stop error message and restarts automatically. This behavior brings down all other running virtual machines together with the host computer.
Note This issue can also occur with virtual machines that are running Windows Developer Preview or Windows Server Developer Preview.

CAUSE

The issue occurs because the Hypervisor does not handle the one-shot synthetic timer that is also known as an aperiodic timer correctly.

RESOLUTION

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:
http://support.microsoft.com/contactus/?ws=support (http://support.microsoft.com/contactus/?ws=support)
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running Windows Server 2008 R2 or Windows Server 2008 R2 Service Pack 1 (SP1). Additionally, you must have the Hyper-V server role installed. For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932  (http://support.microsoft.com/kb/976932/ ) Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix, you do not have to change the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, milestone (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table:
    Collapse this tableExpand this table
    VersionProductMilestoneService branch
    6.1.760 0.20xxxWindows Server 2008 R2RTMLDR
    6.1.760 1.21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2" section. MANIFEST files and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Hvax64.exe6.1.7600.20930634,88022-Mar-201102:36x64
Hvboot.sys6.1.7600.20930117,63222-Mar-201105:27x64
Hvix64.exe6.1.7600.20930687,10422-Mar-201102:36x64
Hvax64.exe6.1.7601.21689614,91222-Mar-201102:23x64
Hvboot.sys6.1.7601.21689118,14422-Mar-201105:17x64
Hvix64.exe6.1.7601.21689652,80022-Mar-201102:23x64

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684  (http://support.microsoft.com/kb/824684/ ) Description of the standard terminology that is used to describe Microsoft software updates

Additional file information

Additional file information for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Amd64_5a198dcfe686a41c72d6dcd7fd790dcf_31bf3856ad364e35_6.1.7601.21689_none_d2751aaa2b528575.manifestNot applicable71022-Mar-201119:15Not applicable
Amd64_e8bc23d3a14cd1a9c52b78c5a31319f7_31bf3856ad364e35_6.1.7600.20930_none_93054bd671733ff7.manifestNot applicable71022-Mar-201119:15Not applicable
Amd64_microsoft-hyper-v-drivers-hypervisor_31bf3856ad364e35_6.1.7600.20930_none_8d00f97b982fd583.manifestNot applicable4,16322-Mar-201106:08Not applicable
Amd64_microsoft-hyper-v-drivers-hypervisor_31bf3856ad364e35_6.1.7601.21689_none_8eba47999576b40c.manifestNot applicable4,16322-Mar-201105:43Not applicable
Update.mumNot applicable1,95322-Mar-201119:15Not applicable

APPLIES TO
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Standard
  • Microsoft Hyper-V Server 2008 R2
Keywords: 
kbhotfixserver kbautohotfix kbqfe kbfix kbsurveynew kbexpertiseadvanced KB2526776