Comment éviter les problèmes relatifs à la sécurité des scripts inter-sites Internet Explorer et Outlook Express

Traductions disponibles Traductions disponibles
Numéro d'article: 253117 - Voir les produits auxquels s'applique cet article
Ancien nº de publication de cet article : F253117
Agrandir tout | Réduire tout

Sommaire

Résumé

Microsoft a identifié un problème de sécurité grave qui peut affecter un grand nombre de sites Web et d'utilisateurs de sites Web. Ce problème, connu sous le nom de « script inter-site », peut affecter tous les programmes qui autorisent les scripts, mais ne résulte pas d'un défaut propre à ces programmes. Ce problème provient en fait de certaines méthodes courantes de codage Web. Pour plus d'informations sur ce problème, reportez-vous au site Web de Microsoft à l'adresse suivante (en anglais) :
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/security/news/crssite.mspx
Cet article décrit des mesures qui vous permettent de continuer à parcourir le Web en toute sécurité pendant que les propriétaires de sites Web revoient leur code et apportent les modifications nécessaires. Tous les programmes qui utilisent des scripts peuvent être concernés par ce problème ; nous avons fourni des instructions pour limiter l'impact de ce problème lorsque vous utilisez les programmes Microsoft répertoriés au début de cet article. Si vous utilisez le programme d'un autre fabricant, nous vous recommandons de le contacter pour obtenir des informations sur la manière de configurer ce programme.

Plus d'informations

Vous pouvez prendre un certain nombre de mesures de précaution pour limiter l'impact de ce problème. Nous recommandons à tous les clients de suivre ces mesures.

IMPORTANT : Ces mesures sont fournies ci-dessous pour les versions prises en charge et non prises en charge de Microsoft Internet Explorer, Outlook et Outlook Express. Si vous exécutez une version non prise en charge d'un de ces produits, Microsoft recommande vivement, en plus des mesures suivantes, de procéder également à une mise à niveau vers une version prise en charge et d'appliquer les correctifs de sécurité les plus récents à partir du site Web Microsoft Windows Update suivant :
http://update.microsoft.com
Pour obtenir des informations supplémentaires sur des versions prises en charge de Microsoft Internet Explorer, Outlook et Outlook Express, reportez-vous aux sites Web Microsoft :
Microsoft Internet Explorer et Outlook Express
http://support.microsoft.com/gp/lifeselectintmsn
Microsoft Outlook
http://support.microsoft.com/gp/lifeselectoff

Comment faire pour éviter les scripts inter-sites dans les messages électroniques

Pour éviter les scripts inter-sites dans les messages électroniques, désactivez Active Scripting dans la zone restreinte et exécutez tous les messages électroniques que vous recevez dans cette zone.

REMARQUE Active Scripting est désactivé par défaut dans Outlook Express 6 et Outlook 2002.

Pour plus d'informations sur la manière de désactiver Active Scripting dans la zone restreinte et configurer tous les messages électroniques pour une exécution dans cette zone, cliquez sur les numéros ci-dessous pour afficher les articles correspondants dans la Base de connaissances Microsoft.
192846 OLEXP : Procédure de désactivation de Active Scripting dans Outlook Express
215774 OL2000 : les scripts incorporés dans les messages HTML s'exécutent sans avertissement
Pour plus d'informations sur les fonctionnalités antivirus dans Outlook Express 6, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
291387Utilisation des fonctionnalités antivirus dans Outlook Express 6

Précautions à prendre pour éviter les attaques lorsque vous parcourez le Web ou lisez des messages électroniques

  • Parcourez des sites Web dont le contenu n'utilise pas de code malveillant.
  • Soyez prudent lors de votre première visite sur un site Web. La méthode la plus sûre pour vous connecter à un site Web consiste à taper l'adresse Web directement dans le navigateur ou à utiliser un signet ou un lien favori stocké localement en lieu sûr. Cette méthode vous permet de réduire considérablement les risques tout en conservant la fonctionnalité.
  • Ne cliquez pas sur les liens hypertexte dans un message électronique, même si le message semble provenir d'une personne de confiance. Un utilisateur malveillant peut utiliser un faux nom et le faire apparaître dans la ligne De du message électronique.

Réparation après une attaque par scripts inter-sites

REMARQUE Vous ne devez accomplir les tâches suivantes que si vous êtes certain d'avoir parcouru un site Web qui utilise des scripts inter-sites. Une fois ces tâches accomplies, vous devez vous réinscrire et repersonnaliser les sites Web que vous parcourez de nouveau.

Pour arrêter les scripts inter-sites :
  1. Fermez Internet Explorer.
  2. Redémarrez Internet Explorer et parcourez un site Web sûr tel que :
    http://www.microsoft.com/france/
  3. Supprimez tous les fichiers cookies de votre ordinateur. Pour cela, suivez les étapes appropriées à votre version d'Internet Explorer.

    Internet Explorer 6 pour Windows 98, Windows NT 4.0, Windows 98 Deuxième Édition, Windows Millennium Edition, Windows XP ou Windows 2000

    1. Dans le menu Outils, cliquez sur Options Internet, puis sur l'onglet Général.
    2. Sous la section Fichiers Internet temporaires, cliquez sur Supprimer les cookies, puis cliquez sur OK à deux reprises.

    Internet Explorer 5.x pour Windows 95, Windows 98, Windows NT 4.0, Windows 98 Deuxième Édition ou Windows 2000

    1. Dans le menu Outils, cliquez sur Options Internet, puis sur l'onglet Général.
    2. Sous Fichiers Internet temporaires, cliquez sur Paramètres.
    3. Cliquez sur Visualiser les fichiers.
    4. Dans le menu Affichage, cliquez sur la commande Détails.
    5. Cliquez sur l'en-tête de colonne Adresse Internet, puis recherchez les adresses Internet des fichiers cookies. Par exemple, l'adresse Internet d'un cookie peut avoir un nom similaire au nom suivant :
      Cookie:nom_utilisateur@nom_site_Web.com
    6. Cliquez sur un fichier cookie et appuyez sur la touche SUPPR. Lorsque vous êtes invité à confirmer la suppression, cliquez sur Oui. Répétez cette étape pour chaque fichier cookie.

    Internet Explorer 4.x pour Windows 95, Windows 98 ou Windows NT 4.0

    1. Dans le menu Affichage, cliquez sur Options Internet, puis sur l'onglet Général.
    2. Sous Fichiers Internet temporaires, cliquez sur Paramètres.
    3. Cliquez sur Visualiser les fichiers.
    4. Dans le menu Affichage, cliquez sur la commande Détails.
    5. Cliquez sur l'en-tête de colonne Adresse Internet, puis recherchez les adresses Internet des fichiers cookies. Par exemple, l'adresse Internet d'un cookie peut avoir un nom similaire au nom suivant :
      Cookie:nom_utilisateur@nom_site_Web.com
    6. Cliquez sur un fichier cookie et appuyez sur la touche SUPPR. Lorsque vous êtes invité à confirmer la suppression, cliquez sur Oui. Répétez cette étape pour chaque fichier cookie.

    Internet Explorer 3.x pour Windows 95 ou Windows NT 4.0

    1. Dans le menu Affichage, cliquez sur Options, puis cliquez sur l'onglet Avancées.
    2. Sous Fichiers Internet temporaires, cliquez sur Visualiser les fichiers.
    3. Cliquez sur l'en-tête de colonne Nom, puis recherchez les fichiers cookies. Par exemple, un fichier cookie peut avoir un nom similaire au nom suivant :
      Cookie:nom_utilisateur@nom_site_Web.com
    4. Cliquez sur un fichier cookie et appuyez sur la touche SUPPR. Lorsque vous êtes invité à confirmer la suppression, cliquez sur Oui. Répétez cette étape pour chaque fichier cookie.

    Internet Explorer 3.x, 4.x ou 5 pour Window 3.1x et Windows NT 3.51

    1. Dans le Gestionnaire de fichiers, cliquez sur Rechercher dans le menu Fichier.
    2. Dans la zone Rechercher, tapez emcookie.dat.
    3. Dans la zone Démarrer à partir de, tapez la lettre du lecteur sur lequel Internet Explorer est installé, suivie de deux-points (:) et d'une barre oblique inverse (\). Par exemple, C:\.
    4. Activez la case à cocher Rechercher dans tous les sous-répertoires, puis cliquez sur OK.
    5. Dans la fenêtre Résultats de la recherche, cliquez sur le fichier Emcookie.dat, puis cliquez sur Supprimer dans le menu Fichier.
    6. Cliquez sur OK, sur Oui si vous êtes invité à confirmer la suppression, puis cliquez sur Oui pour mettre à jour la fenêtre Résultats de la recherche.

    Internet Explorer 4.x pour Macintosh

    1. Dans le menu Edition, cliquez sur Préférences.
    2. Sous Réception de fichiers, cliquez sur Cookies.
    3. Cliquez sur l'un des cookies affichés.
    4. Dans le menu Edition, cliquez sur Sélectionner tout, puis cliquez sur Supprimer.

    Internet Explorer 4 ou 5 pour UNIX sur HP-UX ou Sun Solaris

    1. Passez au répertoire .microsoft dans le répertoire de base de l'utilisateur.
    2. Passez au répertoire Cookies dans le répertoire .microsoft.
    3. Supprimez tous les fichiers .txt qui se trouvent dans ce répertoire. Par exemple, utilisateur@www.exemple.com.txt.
Pour plus d'informations sur les cookies, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft.
260971 Description des cookies

Propriétés

Numéro d'article: 253117 - Dernière mise à jour: dimanche 15 mai 2011 - Version: 9.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Outlook Express 5.0 Édition Macintosh
  • Microsoft Outlook Express 5.04 pour Macintosh
  • Microsoft Outlook Express 4.0 pour Macintosh
  • Microsoft Internet Explorer 4.0 for UNIX
  • Microsoft Internet Explorer 5.0 for Macintosh
  • Microsoft Internet Explorer 4.5 for Macintosh
  • Microsoft Internet Explorer 4.01 for Macintosh
  • Microsoft Internet Explorer 4.0 for Macintosh
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.0 for Macintosh
  • Microsoft Internet Explorer 2.0 for Macintosh
  • Microsoft Outlook Express 5.0
  • Microsoft Internet Explorer 6.0
Mots-clés : 
kbcssi kbhowto KB253117
L'INFORMATION CONTENUE DANS CE DOCUMENT EST FOURNIE PAR MICROSOFT SANS GARANTIE D'AUCUNE SORTE, EXPLICITE OU IMPLICITE. L'UTILISATEUR ASSUME LE RISQUE DE L'UTILISATION DU CONTENU DE CE DOCUMENT. CE DOCUMENT NE PEUT ETRE REVENDU OU CEDE EN ECHANGE D'UN QUELCONQUE PROFIT.

Envoyer des commentaires

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com