Zapobieganie problemom z zabezpieczeniami związanym ze skryptami krzyżowymi w programach Internet Explorer i Outlook Express

Tłumaczenia artykułów Tłumaczenia artykułów
Numer ID artykułu: 253117 - Zobacz jakich produktów dotyczą zawarte w tym artykule porady.
Ten artykuł został opublikowany wcześniej pod numerem PL253117
Rozwiń wszystko | Zwiń wszystko

Na tej stronie

Streszczenie

W firmie Microsoft stwierdzono poważną lukę w zabezpieczeniach, która może potencjalnie dotyczyć wielu witryn i użytkowników sieci Web. Luka znana jest pod nazwą „Cross-Site Scripting” (Skrypty krzyżowe) i może występować we wszystkich programach umożliwiających używanie skryptów, ale nie jest wynikiem wad tych programów. Luka związana jest raczej z typowymi praktykami dotyczącymi pisania programów w sieci Web. Dodatkowe informacje na temat tego problemu można znaleźć w następującej witrynie sieci Web firmy Microsoft:
http://www.microsoft.com/TechNet/itsolutions/security/topics/crssite.asp
W niniejszym artykule opisano czynności, jakie trzeba wykonać, aby w czasie przeglądania i modyfikacji kodu witryny sieci Web przez jej właścicieli mogli oni bezpiecznie przeglądać sieć Web. Luka dotyczy wszystkich programów korzystających ze skryptów; w tym artykule podaliśmy instrukcje, jak zabezpieczyć programy firmy Microsoft. Użytkownikom programów innych producentów zalecamy skontaktowanie się z nimi w sprawie instrukcji dotyczących konfigurowania tych programów.

Więcej informacji

Istnieje kilka czynności zapobiegawczych, które mogą zminimalizować efekty tego problemu. Zalecamy, aby wykonali je wszyscy klienci.

Jak zapobiegać skryptom krzyżowym w wiadomościach e-mail

Aby uniemożliwić występowanie skryptów krzyżowych w wiadomościach e-mail, wyłącz opcję Wykonywanie aktywnych skryptów w strefie Witryny z ograniczeniami.

Dodatkowe informacje o tym, jak wyłączyć opcję Wykonywanie aktywnych skryptów w strefie Witryny z ograniczeniami oraz jak konfigurować całą pocztę e-mail, aby działała w strefie Witryny z ograniczeniami, można uzyskać, klikając numery artykułów umieszczone poniżej, aby wyświetlić artykuły z bazy wiedzy Microsoft Knowledge Base:
192846 How to Disable Active Scripting in Outlook Express
215774 OL2000: Scripts Embedded in HTML Messages Run without Warning

Zachowywanie ostrożności w celu uniknięcia ataków podczas przeglądania sieci Web i czytania wiadomości e-mail

  • Przeglądaj witryny sieci Web, o których wiesz, że nie zawierają złośliwego kodu.
  • Zachowaj ostrożność podczas pierwszej wizyty w witrynie sieci Web. Najbezpieczniejszym sposobem połączenia się z witryną sieci Web jest wpisanie jej adresu bezpośrednio w przeglądarce lub użycie przechowywanej w bezpiecznym miejscu zakładki lub ulubionego elementu. Postępując tak, znacznie ograniczasz narażenie się na niebezpieczeństwo, zachowując funkcjonalność.
  • Nie klikaj hiperłączy w wiadomościach e-mail, nawet jeśli wiadomość wydaje się pochodzić od zaufanej osoby. Złośliwy użytkownik może użyć fałszywej nazwy w wierszu Od: wiadomości e-mail.

Naprawa po ataku skryptu krzyżowego

UWAGA: Następujące czynności należy wykonać jedynie wtedy, gdy ma się pewne dowody, że odwiedzana witryna sieci Web używa skryptów krzyżowych. Po ich wykonaniu należy ponownie zarejestrować się i ponownie dostosować swój profil we wszystkich witrynach, które planuje się odwiedzać.

Aby zatrzymać skrypt krzyżowy:
  1. Zamknij program Internet Explorer.
  2. Uruchom ponownie program Internet Explorer i odwiedź bezpieczną witrynę sieci Web, taką jak:
    http://www.microsoft.com
  3. Usuń z komputera wszystkie pliki cookie. W tym celu wykonaj czynności odpowiednie dla wersji programu Internet Explorer.

    Program Internet Explorer 6 dla systemów Windows 98, Windows NT 4.0, Windows 98 Wydanie drugie, Windows Millennium Edition lub Windows 2000

    1. W menu Narzędzia kliknij polecenie Opcje internetowe, a następnie kliknij kartę Ogólne.
    2. W sekcji Tymczasowe pliki internetowe kliknij przycisk Usuń pliki cookie, kliknij przycisk OK, a następnie ponownie kliknij przycisk OK.

    Program Internet Explorer 5.x dla systemów Windows 95, Windows 98, Windows NT 4.0, Windows 98 Wydanie drugie lub Windows 2000

    1. W menu Narzędzia kliknij polecenie Opcje internetowe, a następnie kliknij kartę Ogólne.
    2. W obszarze Tymczasowe pliki internetowe kliknij przycisk Ustawienia.
    3. Kliknij przycisk Wyświetl pliki.
    4. W menu Widok kliknij, aby zaznaczyć polecenie Szczegóły.
    5. Kliknij etykietę kolumny Adres internetowy, a następnie przewiń zawartość do pozycji adresów internetowych plików cookie. Na przykład adres internetowy pliku cookie może mieć nazwę podobną do poniższej:
      Cookie:jkowalski@nazwawitryny.com
    6. Kliknij plik cookie, a następnie naciśnij klawisz Usuń. Jeśli pojawi się monit o potwierdzenie usunięcia, kliknij przycisk Tak. Powtórz ten krok dla każdego pliku cookie.

    Program Internet Explorer 4.x dla systemów Windows 95, Windows 98 lub Windows NT 4.0

    1. W menu Widok kliknij polecenie Opcje internetowe, a następnie kliknij kartę Ogólne.
    2. W obszarze Tymczasowe pliki internetowe kliknij opcję Ustawienia.
    3. Kliknij przycisk Wyświetl pliki.
    4. W menu Widok kliknij, aby zaznaczyć polecenie Szczegóły.
    5. Kliknij etykietę kolumny Adres internetowy, a następnie przewiń zawartość do pozycji adresów internetowych plików cookie. Na przykład adres internetowy pliku cookie może mieć nazwę podobną do poniższej:
      Cookie:jkowalski@nazwawitryny.com
    6. Kliknij plik cookie, a następnie naciśnij klawisz Usuń. Jeśli pojawi się monit o potwierdzenie usunięcia, kliknij przycisk Tak. Powtórz ten krok dla każdego pliku cookie.

    Program Internet Explorer 3.x dla systemu Windows 95 lub Windows NT 4.0

    1. W menu Widok kliknij polecenie Opcje, a następnie kliknij kartę Zaawansowane.
    2. W obszarze Tymczasowe pliki internetowe kliknij przycisk Wyświetl pliki.
    3. Kliknij etykietę kolumny Nazwa, a następnie przewiń zawartość do pozycji plików cookie. Na przykład plik cookie może mieć nazwę podobną do poniższej:
      Cookie:jkowalski@nazwawitryny.com
    4. Kliknij plik cookie, a następnie naciśnij klawisz Usuń. Jeśli pojawi się monit o potwierdzenie usunięcia, kliknij przycisk Tak. Powtórz ten krok dla każdego pliku cookie.

    Program Internet Explorer 3.x, 4.x lub 5 dla systemu Windows 3.1x i dla systemu Windows NT 3.51

    1. W Menedżerze plików kliknij polecenie Wyszukaj w menu Plik.
    2. W polu Wyszukaj wpisz emcookie.dat.
    3. W polu Rozpocznij od wpisz literę dysku, na którym jest zainstalowany program Internet Explorer, oraz dwukropek (:) i kreskę ułamkową odwróconą (\). Na przykład C:\.
    4. Zaznacz pole wyboru Przeszukaj wszystkie podkatalogi, a następnie kliknij przycisk OK.
    5. W oknie Wyniki wyszukiwania kliknij plik Emcookie.dat, a następnie kliknij polecenie Usuń w menu Plik.
    6. Kliknij przycisk OK, kliknij przycisk Tak, jeśli pojawi się monit o potwierdzenie usunięcia, a następnie kliknij przycisk Tak, aby zaktualizować okno Wyniki wyszukiwania.

    Program Internet Explorer 4.x dla komputerów Macintosh

    1. W menu Edit kliknij polecenie Preferences.
    2. W obszarze Receiving Files kliknij przycisk Cookies.
    3. Kliknij jeden z wyświetlonych plików cookie.
    4. W menu Edit kliknij polecenie Select All, a następnie kliknij przycisk Delete.

    Program Internet Explorer 4 lub 5 dla systemu UNIX na komputerach HP-UX lub Sun Solaris

    1. Przejdź do katalogu .microsoft znajdującego się w katalogu macierzystym użytkownika.
    2. Przejdź do katalogu Cookies w katalogu .microsoft.
    3. Usuń wszystkie pliki .txt w tym katalogu. Na przykład uzytkownik@www.przyklad.com.txt.
Aby uzyskać dodatkowe informacje dotyczące plików cookie, kliknij numer artykułu poniżej w celu wyświetlenia tego artykułu z bazy wiedzy Microsoft Knowledge Base:
154360 Security Alert for Cookies in Internet Explorer and Outlook Express
223799 Description of Persistent and Per-Session Cookies
153417 Location of Cookies File in Internet Explorer
224304 Per-Session Cookies Are Not Cleared Until You Close Browser

Właściwości

Numer ID artykułu: 253117 - Ostatnia weryfikacja: 4 maja 2006 - Weryfikacja: 3.2
Informacje zawarte w tym artykule dotyczą:
  • Microsoft Outlook Express 6.0
  • Microsoft Outlook Express 5.01 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.5
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 6.0
  • Microsoft Outlook Express 4.01 Service Pack 1
  • Microsoft Outlook Express 4.01 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 5.5
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 6.0
  • Microsoft Outlook Express 5.01 Service Pack 1
  • Microsoft Outlook Express 4.01 Service Pack 2
  • Microsoft Outlook Express 5.01 Service Pack 2
  • Microsoft Outlook Express 5.5
  • Microsoft Outlook Express 5.5 Service Pack 1
  • Microsoft Outlook Express 4.0
  • Microsoft Outlook Express 4.0
  • Microsoft Outlook Express 4.01
  • Microsoft Outlook Express 4.01 Service Pack 1
  • Microsoft Outlook Express 4.01 Service Pack 2
  • Microsoft Outlook Express 4.01
  • Microsoft Outlook Express 4.01
  • Microsoft Outlook Express 4.0 for Macintosh
  • Microsoft Outlook Express 4.0 for Macintosh
  • Microsoft Outlook Express 4.02
  • Microsoft Outlook Express 4.0c for Macintosh
  • Microsoft Outlook Express 4.5 for Macintosh
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 4.0 (128-bitowy)
  • Microsoft Internet Explorer 4.01 (128-bitowy)
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 4.0 (128-bitowy)
  • Microsoft Internet Explorer 4.01 (128-bitowy)
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.01
  • Microsoft Internet Explorer 5.5
  • Microsoft Internet Explorer 5.5 Service Pack 1
  • Microsoft Internet Explorer 2.0
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 4.0 (128-bitowy)
  • Microsoft Internet Explorer 4.01 (128-bitowy)
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 3.0
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.02
  • Microsoft Internet Explorer 3.1
  • Microsoft Internet Explorer 4.0 (128-bitowy)
  • Microsoft Internet Explorer 4.01 (128-bitowy)
  • Microsoft Internet Explorer 4.01 Service Pack 1
  • Microsoft Internet Explorer 4.01 Service Pack 2
  • Microsoft Internet Explorer 4.01
  • Microsoft Internet Explorer 4.0 for UNIX
  • Microsoft Internet Explorer 2.0 for Macintosh
  • Microsoft Internet Explorer 2.1 for Macintosh
  • Microsoft Internet Explorer 3.0 for Macintosh
  • Microsoft Internet Explorer 3.0 for Macintosh
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 4.0 for Macintosh
  • Microsoft Internet Explorer 4.01 for Macintosh
  • Microsoft Internet Explorer 4.5 for Macintosh
  • Microsoft Internet Explorer 6.0
Słowa kluczowe: 
kbcssi kbgrpdsinet kbhowto KB253117

Przekaż opinię

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com