Evitar problemas de segurança relacionados com o processamento de scripts entre sites no Internet Explorer e Outlook Express

Traduções de Artigos Traduções de Artigos
Artigo: 253117 - Ver produtos para os quais este artigo se aplica.
Este artigo foi publicado anteriormente em PT253117
Expandir tudo | Reduzir tudo

Nesta página

Sumário

A Microsoft identificou uma vulnerabilidade grave a nível da segurança que pode afectar muitos Web sites e utilizadores de Web sites. A vulnerabilidade, conhecida por processamento de scripts entre sites ("Cross-Site Scripting"), é possível em todos os programas que permitem o processamento de scripts, mas não resulta de um defeito nesses programas. Pelo contrário, esta vulnerabilidade resulta de determinadas práticas comuns de codificação para a Web. Para obter informações adicionais sobre este problema, consulte o seguinte Web site da Microsoft:
http://www.microsoft.com/technet/treeview/default.asp?url=/technet/security/news/crssite.mspx
Este artigo descreve os passos para garantir que, durante o período em que os proprietários de Web sites estejam a rever o respectivo código e a efectuar as alterações necessárias, poderá continuar a navegar em segurança na Web. Todos os programas que utilizem processamento de scripts podem ser afectados por esta vulnerabilidade; a Microsoft forneceu instruções para minimizar os efeitos deste problema quando utilizar os programas da Microsoft listados no início deste artigo. Se estiver a utilizar um programa de outro fabricante, recomendamos que entre em contacto com o mesmo para obter instruções sobre como configurar esse programa.

Este artigo poderá conter hiperligações para conteúdo em inglês (ainda não traduzido).

Mais Informação

Existem várias medidas de precaução que poderá tomar para minimizar os efeitos deste problema. Recomendamos que todos os clientes procedam à aplicação destas medidas.

IMPORTANTE: as medidas de precaução são apresentadas abaixo para as versões suportadas e não suportadas do Microsoft Internet Explorer, Outlook e Outlook Express. Se estiver a executar uma versão não suportada de um destes produtos, a Microsoft recomenda vivamente que, além de aplicar as medidas apresentadas abaixo, actualize para uma versão suportada e aplique os mais recentes patches de segurança a partir do Web site Microsoft Windows Update:
http://update.microsoft.com
Para obter informações adicionais sobre versões suportadas do Microsoft Internet Explorer, Outlook e Outlook Express, consulte os seguintes Web sites da Microsoft:
Microsoft Internet Explorer e Outlook Express
http://support.microsoft.com/gp/lifeselectintmsn
Microsoft Outlook
http://support.microsoft.com/gp/lifeselectoff

Como impedir o processamento de scripts entre sites em mensagens de correio electrónico

Para impedir a ocorrência de processamento de scripts entre sites em mensagens de correio electrónico, desactive o processamento de scripts activo na zona de sites restritos e faça com que todas as mensagens de correio electrónico recebidas passem por esta zona.

NOTA: o processamento de scripts activo está desactivado por predefinição no Outlook Express 6 e no Outlook 2002.

Para obter informações adicionais sobre como desactivar o processamento de scripts activo na zona de sites restritos e configurar todas as mensagens de correio electrónico de modo a passarem por esta zona, clique nos seguintes números de artigo para visualizar os artigos na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
192846 How to Disable Active Scripting in Outlook Express
215774 OL2000: Scripts Embedded in HTML Messages Run without Warning
Para obter informações adicionais sobre funcionalidades de protecção contra vírus no Outlook Express 6, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
291387 Utilizar funcionalidades de protecção contra vírus no Outlook Express 6

Tomar medidas de precaução para evitar ataques enquanto navega na Web ou lê mensagens de correio electrónico

  • Navegue apenas em Web sites que considere não estarem a utilizar código nocivo.
  • Tenha cuidado relativamente à forma como visita inicialmente um Web site. O modo mais seguro de estabelecer ligação a um Web site consiste em escrever o endereço Web directamente no browser ou utilizar um marcador ou favorito local armazenado em segurança. Se proceder desta forma, poderá reduzir significativamente o perigo de exposição, mantendo ao mesmo tempo a funcionalidade.
  • Não clique em hiperligações contidas numa mensagem de correio electrónico, mesmo que esta aparente ter sido enviada por alguém em quem confia. Um utilizador mal intencionado poderá fazer com que seja apresentado um nome falso na linha De: de uma mensagem de correio electrónico.

Recuperar de um ataque de processamento de scripts entre sites

NOTA: só deverá tomar as seguintes medidas se tiver indícios credíveis de que visitou um Web site que utiliza o processamento de scripts entre sites. Depois de implementar estas medidas, terá de voltar a registar-se e de personalizar novamente todos os Web sites que visitar.

Para parar o processamento de scripts entre sites:
  1. Feche o Internet Explorer.
  2. Volte a iniciar o Internet Explorer e visite um Web site seguro, como por exemplo:
    http://www.microsoft.com/portugal
  3. Elimine todos os ficheiros de cookies do computador. Para o fazer, execute os passos apropriados para a versão do Internet Explorer que utiliza.

    Internet Explorer 6 para Windows 98, Windows NT 4.0, Windows 98 Segunda Edição, Windows Millennium Edition, Windows XP ou Windows 2000

    1. No menu Ferramentas, clique em Opções da Internet e clique no separador Geral.
    2. Na secção Ficheiros temporários da Internet, clique em Eliminar cookies, clique em OK e clique novamente em OK.

    Internet Explorer 5.x para Windows 95, Windows 98, Windows NT 4.0, Windows 98 Segunda Edição ou Windows 2000

    1. No menu Ferramentas, clique em Opções da Internet e clique no separador Geral.
    2. Em Ficheiros temporários da Internet, clique em Definições.
    3. Clique em Ver ficheiros.
    4. No menu Ver, clique para seleccionar o comando Detalhes.
    5. Clique no rótulo da coluna Endereço Internet e percorra-a para localizar os endereços Internet dos ficheiros de cookies. Por exemplo, o endereço Internet de um cookie poderá ter um nome semelhante ao seguinte:
      Cookie:jsilva@nomewebsite.com
    6. Clique num ficheiro de cookies e prima a tecla Delete. Se for pedido para confirmar a eliminação, clique em Sim. Repita este passo para cada ficheiro de cookies.

    Internet Explorer 4.x para Windows 95, Windows 98 ou Windows NT 4.0

    1. No menu Ver, clique em Opções da Internet e clique no separador Geral.
    2. Em Ficheiros temporários da Internet, clique em Definições.
    3. Clique em Ver ficheiros
    4. No menu Ver, clique para seleccionar o comando Detalhes.
    5. Clique no rótulo da coluna Endereço Internet e percorra-a para localizar os endereços Internet dos ficheiros de cookies. Por exemplo, o endereço Internet de um cookie poderá ter um nome semelhante ao seguinte:
      Cookie:jsilva@nomewebsite.com
    6. Clique num ficheiro de cookies e prima a tecla Delete. Se for pedido para confirmar a eliminação, clique em Sim. Repita este passo para cada ficheiro de cookies.

    Internet Explorer 3.x para Windows 95 ou Windows NT 4.0

    1. No menu Ver, clique em Opções e clique no separador Avançadas.
    2. Em Temporary Internet Files, clique em Ver ficheiros.
    3. Clique no rótulo da coluna Nome e percorra-a para localizar os ficheiros de cookies. Por exemplo, um ficheiro de cookies poderá ter um nome semelhante ao seguinte:
      Cookie:jsilva@nomewebsite.com
    4. Clique num ficheiro de cookies e prima a tecla Delete. Se for pedido para confirmar a eliminação, clique em Sim. Repita este passo para cada ficheiro de cookies.

    Internet Explorer 3.x, 4.x ou 5 para Windows 3.1x e Windows NT 3.51

    1. No File Manager, clique em Search no menu File.
    2. Na caixa Search For, escreva emcookie.dat.
    3. Na caixa Start From, escreva a letra da unidade na qual o Internet Explorer está instalado, seguida de dois pontos (:) e uma barra invertida (\). Por exemplo, C:\.
    4. Clique para seleccionar a caixa Search All Subdirectories e clique em OK.
    5. Na janela Search Results, clique no ficheiro Emcookie.dat e clique em Delete no menu File.
    6. Clique em OK, clique em Yes se for pedido para confirmar a eliminação e clique em Yes para actualizar a janela Search Results.

    Internet Explorer 4.x para Macintosh

    1. No menu Edit, clique em Preferences.
    2. Em Receiving Files, clique em Cookies.
    3. Clique num dos cookies apresentados.
    4. No menu Edit, clique em Select All e clique em Delete.

    Internet Explorer 4 ou 5 para UNIX em HP-UX ou Sun Solaris

    1. Mude para o directório .microsoft no directório raiz do utilizador.
    2. Mude para o directório Cookies dentro do directório .microsoft.
    3. Elimine todos os ficheiros .txt existentes neste directório. Por exemplo, utilizador@www.example.com.txt.
Para obter informações adicionais sobre cookies, clique no número de artigo que se segue para visualizar o artigo na base de dados de conhecimento da Microsoft (KB, Microsoft Knowledge Base):
260971 Descrição de cookies

Propriedades

Artigo: 253117 - Última revisão: 10 de maio de 2011 - Revisão: 10.0
A informação contida neste artigo aplica-se a:
  • Microsoft Outlook Express 5.0 Macintosh Edition
  • Microsoft Outlook Express 4.5 para Macintosh
  • Microsoft Outlook Express 4.0 para Macintosh
  • Microsoft Internet Explorer 4.0 for UNIX
  • Microsoft Internet Explorer 5.0 for Macintosh
  • Microsoft Internet Explorer 4.5 for Macintosh
  • Microsoft Internet Explorer 4.01 para Macintosh
  • Microsoft Internet Explorer 4.0 for Macintosh
  • Microsoft Internet Explorer 3.01
  • Microsoft Internet Explorer 3.0 para Macintosh
  • Microsoft Internet Explorer 2.0 for Macintosh
  • Microsoft Outlook Express 5.0
  • Microsoft Internet Explorer 6.0
Palavras-chave: 
kbcssi kbhowto KB253117

Submeter comentários

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com