CORRECTIF : La liste de prix d'un produit variant nouvellement ajouté est définie sur le prix de liste d'origine du produit après l'exécution d'un catalogue d'importation et d'une association de la catégorie modifient dans Commerce Server 2009

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Numéro d'article: 2532193 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Considérez le scénario suivant :
  • Dans Microsoft Commerce Server catalogue Manager 2009, vous créez un produit de type variant en ajoutant une propriété de composant à un produit. La liste de prix pour le produit variant diffère du prix liste d'origine du produit.
  • Vous utilisez le Type d'exportation complète format pour exporter le catalogue vers un fichier XML.
  • Vous importez le fichier XML exporté dans le catalogue à l'aide de la Remplacer type format.
  • Vous modifiez l'association de la catégorie du produit. Pour ce faire, vous ajouter, puis sélectionnez une catégorie sur leAssociations de catégorie onglet.
Dans ce scénario, la liste de prix du produit variant nouvellement ajouté est réinitialisé sur les tarifs d'origine du produit.

Remarque Le problème se produit également si vous utilisez l'API de Commerce Server pour effectuer ces actions.

Cause

Le problème se produit car le fichier de catalogue XML exporté produit variant ne contient-elle pas les propriétés de prix et le prix de la liste d'origine. Lorsque vous importez le fichier de catalogue XML à l'aide de la Remplacer type le format, les prix du produit d'origine propriétés sont utilisées pour remplir les propriétés manquantes dans le produit de type variant.

Résolution

Informations sur le correctif

Un correctif est disponible auprès de Microsoft. Toutefois, ce correctif est conçu uniquement pour corriger le problème décrit dans cet article. Appliquer ce correctif uniquement aux systèmes qui rencontrent le problème décrit dans cet article. Ce correctif peut subir des tests supplémentaires. Par conséquent, si vous n'êtes pas sérieusement concerné par ce problème, nous vous recommandons d'attendre la prochaine mise à jour de logiciels qui comprendra ce correctif.

Si le correctif est disponible au téléchargement, il existe une section « Téléchargement de correctif logiciel disponible » en haut de cet article de la Base de connaissances. Si cette section n'apparaît pas, contactez le Service clientèle de Microsoft et de Support pour obtenir le correctif.

Remarque Si des problèmes supplémentaires se produisent ou si des procédures de dépannage est nécessaire, il se peut que vous deviez créer une demande de service distinct. Les coûts habituels du support technique s'appliqueront aux autres questions et problèmes qui ne relèvent pas de ce correctif spécifique. Pour une liste complète des numéros de téléphone Microsoft Services de Support technique ou pour créer une demande de service distinct, visitez le site Web Microsoft suivant :
http://support.Microsoft.com/contactus/?ws=support
Remarque Le formulaire « Téléchargement de correctif logiciel disponible » affiche les langues pour lesquelles le correctif est disponible. Si vous ne voyez pas votre langue, il est dans la mesure où un correctif n'est pas disponible pour cette langue.

Conditions préalables

La liste suivante contient les conditions préalables pour le package de correctifs :
  • Microsoft Commerce Server 2009

Nécessité d'un redémarrage

Vous n'avez pas à redémarrer l'ordinateur après avoir appliqué ce correctif. Toutefois, vous devez redémarrer IIS (Internet Information Services) et l'application Commerce Server catalogue importation hôte COM + après avoir appliqué ce correctif. Pour redémarrer IIS, ouvrez une invite de commande, tapez la commande suivante et appuyez sur ENTRÉE :
IISRESET /RESTART
Remarque Cette procédure s'arrête et redémarre tous les services IIS en cours d'exécutant.

Informations sur le remplacement

Ce correctif ne remplace pas un correctif publié précédemment.

Informations sur les fichiers

La version internationale de ce correctif utilise un package Microsoft Windows Installer pour installer le correctif. Les dates et les heures de ces fichiers sont répertoriés dans le temps universel coordonné (UTC) dans le tableau suivant. Lorsque vous affichez les informations du fichier, la date est convertie en heure locale. Pour connaître la différence entre l'UTC et l'heure locale, utilisez la Fuseau horaire onglet dans l'élément de Date et heure dans le panneau de configuration.
Pour Commerce Server 2009
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Nom de fichierVersion du fichierTaille du fichierDateHeurePlate-forme
Cs2009hotfixhelper.exe6.0.4171.4612,13606-Avr-201112 : 03x 86
Microsoft.catalogserver.dll6.0.4171.46763,76006-Avr-201112 : 03x 86
Microsoft.CommerceServer.Runtime.dll6.0.4171.46849,79206-Avr-201112 : 03x 86
Microsoft.CommerceServer.Catalog.dll6.0.4171.46960,38406-Avr-201111 : 42x 86

Statut

Microsoft a confirmé qu'il s'agit d'un problème dans les produits Microsoft répertoriés dans la section « S'applique à ».

Propriétés

Numéro d'article: 2532193 - Dernière mise à jour: lundi 25 avril 2011 - Version: 1.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Microsoft Commerce Server 2009 Enterprise
  • Microsoft Commerce Server 2009 Standard
Mots-clés : 
kbautohotfix kbqfe kbhotfixserver kbfix kbexpertiseinter kbsurveynew kbmt KB2532193 KbMtfr
Traduction automatique
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La version anglaise de cet article est la suivante: 2532193
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