Article ID: 2535105 - Last Review: March 6, 2012 - Revision: 7.0

Outlook client applications cannot connect to public folders after you install Exchange Server 2010 SP1

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SYMPTOMS

Certain Microsoft Outlook client applications experience connectivity issues when many Microsoft Exchange RPC Client Access service threads on a public folder are waiting for responses from the Availability service. For example, this issue occurs when there are more than 500 threads waiting for responses on a public folder.  

Notes
  • There is no option to disable the Availability service on a server that is running Exchange Server 2010 Service Pack (SP1).
  • If you restart the Exchange RPC Client Access service on the Exchange Server 2010 SP1 public folder server, this issue is temporarily resolved.

CAUSE

This issue occurs because of a new feature in Exchange Server 2010 SP1. This new feature uses the Microsoft Exchange RPC Client Access service as a proxy for earlier versions of the Availability service (free/busy information). Therefore, if you have a public folder that is installed on an Exchange Server 2010 SP1 server, the Microsoft Exchange RPC Client Access service intercepts the free/busy information requests.

RESOLUTION

To resolve this issue, use one of the following methods.

Method 1

To resolve this issue, install the following update on the Exchange Server 2010 SP1 server:
2497453  (http://support.microsoft.com/kb/2497453/ ) FIX: Application may stop responding after several HTTP requests are aborted if you use the HttpWebRequest class to send requests in the .NET Framework

Method 2

Registry subkey information

Important This section, method, or task contains steps that tell you how to modify the registry. However, serious problems might occur if you modify the registry incorrectly. Therefore, make sure that you follow these steps carefully. For added protection, back up the registry before you modify it. Then, you can restore the registry if a problem occurs. For more information about how to back up and restore the registry, click the following article number to view the article in the Microsoft Knowledge Base:
322756  (http://support.microsoft.com/kb/322756/ ) How to back up and restore the registry in Windows
To resolve this issue, follow these steps:
  1. Install the update rollup that is described in the following article in the Microsoft Knowledge Base:

    2579150  (http://support.microsoft.com/kb/2579150/ ) Description of Update Rollup 4 for Exchange Server 2010 Service Pack 1
  2. Disable the Availability service.

    To have us disable the Availability service for you after you install this update, go to the "Fix it for me" section. If you prefer to disable the Availability service yourself, go to the "Let me fix it myself" section.

    Fix it for me

    To disable the Availability service automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


    Fix this problem
    Microsoft Fix it 50789


    Notes
    • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
    • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD, and then run it on the computer that has the problem.

    Then, go to the "Did this fix the problem?" section.



    Let me fix it myself

    After you install the update, follow these steps to disable the Availability service:
    1. Click Start, click Run, type regedit in the Open box, and then click OK.
    2. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\
    3. On the Edit menu, point to New, and then click Key.
    4. Type ParametersSystem, and then press Enter.
    5. Locate and then click the following registry subkey:
      HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\MSExchangeRPC\ParametersSystem
    6. On the Edit menu, point to New, and then click Dword Value.
    7. Type DisableAvailabilityServiceCalls, and then press Enter.
    8. In the details pane, right-click DisableAvailabilityServiceCalls, and then click Modify.
    9. In the Value data box, type 1, and then click OK.
    10. Exit Registry Editor.
    Note If you decide to wait for Update Rollup 4 for Exchange Server 2010 SP1, this version will revert the affected functionality to the functionality of the release version of Exchange Server 2010.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support (http://support.microsoft.com/contactus) .
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me (http://blogs.technet.com/fixit4me/) " blog or send us an email (mailto:fixit4me@microsoft.com?Subject=KB) message.

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

MORE INFORMATION

For more information about the Availability service, visit the following Microsoft TechNet website:
Understanding the Availability service (http://technet.microsoft.com/en-us/library/bb232134.aspx)

APPLIES TO
  • Microsoft Exchange Server 2010 Service Pack 1, when used with:
    • Microsoft Exchange Server 2010 Enterprise
    • Microsoft Exchange Server 2010 Standard
Keywords: 
kbqfe kbfix kbexpertiseinter kbsurveynew kbhotfixrollup kbfixme kbmsifixme KB2535105