FIX: Textual elements may appear blank when you run an XBAP that targets the .NET Framework 3.0 or the .NET Framework 3.5 if the .NET Framework 4 is installed

Article translations Article translations
Article ID: 2537599 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You run an XAML browser application (XBAP) on a computer that has the Microsoft .NET Framework 4 and the Microsoft .NET Framework 3.5 Service Pack 1 (SP1) installed.
  • The target framework for the application is the Microsoft .NET Framework 3.0 or the .NET Framework 3.5.
In this scenario, textual elements may appear blank in the application. 

If you try to print in the application, the application might encounter a DllNotFoundException exception and then crashes.

CAUSE

This issue occurs because of a C runtime loading issue.

The .NET Framework 3.0 and the .NET Framework 3.5 use C runtime version 8.0, and the .NET Framework 4.0 uses C runtime version 10.0. When the target framework is the .NET Framework 3.0 or the .NET Framework 3.5, the application has to load the version 8.0 before load the C runtime 10.0. However, both runtimes are used for the same application. Therefore, the issue that is mentioned in the "Symptoms" section occurs.

RESOLUTION

To resolve this issue, apply the hotfix package that is described in the following Microsoft Knowledge Base article:

2667241 An update rollup is available for Windows Presentation Foundation (WPF) for Microsoft .NET Framework 3.5



STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2537599 - Last Review: April 10, 2012 - Revision: 2.0
APPLIES TO
  • Microsoft .NET Framework 3.5
  • Microsoft .NET Framework 3.5 Service Pack 1
Keywords: 
kbqfe kbHotfixServer kbfix kbexpertiseadvanced kbsurveynew KB2537599

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com