Windows Phone 7 Developer Unlock Tool cannot detect the HTC Arrive Phone

Article ID: 2537993 - View products that this article applies to.
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SYMPTOMS

The developer completes these steps to register the phone:

1. Registers through the App Hub as per the steps described in the App Hub registration walkthrough here.
2. Downloads and successfully install the latest version of the Windows Phone Developer Tools.
3. Owns an activated Sprint Arrive in which they personalize their settings (including date and time, and selecting a language).
4. Registers the Sprint Arrive with the same Live account they used in the app hub registration.

Next, the developer follows these steps for Developer specific registration:

5. Connects the Sprint Arrive to the developer's PC with the USB cable included with their device.
6. Ensures that the Zune software is running/open.
7. Launches the Windows Phone Developer Registration Tool.
8. The registration tool ultimately fails to detect the phone upon launch, reporting the following message:

"Unable to connect to phone. Please check that the Zune software is running and that the Zune's sync partnership with your phone has been established."

CAUSE

This occurs due to a specific state setting in the HTC Arrive that results in the phone not being able to make a desktop passthrough connection. This state condition can be mitigated by following the steps below.

RESOLUTION

Use the following workaround.

1. If connected, unplug the phone device from the computer.

On the phone device:

2. Press the Windows button.
3. Press the right arrow button (on the top right of the screen) or swipe from right to left to expose the application list.
4. Scroll to and select  “Settings”. 
5. Scroll to and select “Cellular”.
6. Select “Change Network Profile" and then wait for this selection change to complete.
7. Press the Back or Windows key to exit the “Settings” menu.

After completing the above steps, follow through with the registration process:

8. Connect the Sprint Arrive to the development PC with the USB cable included with the phone device.
9. Launch the Windows Phone Developer Registration Tool  (Zune software must be running).
10. The window titled "Windows Phone Developer Registration" appears which establishes a connection to the phone device and the following status message:  "Status: Phone ready. Please enter your Windows Live ID and password and click Register to begin".
11. Enter the App Hub registered Windows Live ID and password, and then press the "Register" button.
12. The following status message appears in the window:

Status: Your phone has successfully been registered.
Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

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Article ID: 2537993 - Last Review: April 22, 2011 - Revision: 1.0
APPLIES TO
  • Windows Phone Developer Tools
Keywords: 
kbwindowsphone7 KB2537993

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