Funzionalità di reindirizzamento di acquisizione audio non funziona dopo la creazione di una seconda connessione desktop remota in Windows Server 2008 R2

Identificativo articolo: 2538047 - Visualizza i prodotti a cui si riferisce l?articolo.
Espandi tutto | Chiudi tutto

In questa pagina

Sintomi

Si consideri il seguente scenario:
  • Si attiva la funzionalità di reindirizzamento di acquisizione audio in un server di desktop remoto che esegue Windows Server 2008 R2.
  • Si crea una connessione desktop remoto al server.
  • Esecuzione di un'applicazione di registrazione audio in connessione desktop remoto.
  • Creazione di un'altra connessione desktop remota al server di desktop remoto.
In questo scenario, l'applicazione di registrazione audio si interrompe l'acquisizione dell'audio della prima connessione desktop remoto. Per risolvere questo problema, è necessario riavviare l'applicazione di registrazione audio.

Cause

Quando viene creata una nuova connessione desktop remota su un server di desktop remoto, vengono generati gli eventi di modifica del dispositivo nel computer. Questi eventi provocano la periferica audio per la ricezione di un nuovo identificatore. Questo nuovo identificatore disconnette la periferica da tutti i servizi esistenti o applicazioni che utilizzano il dispositivo e l'operazione di reimpostazione della periferica smette di software di acquisizione audio in connessione desktop remoto attiva.

Risoluzione

Informazioni sull'aggiornamento rapido

È disponibile un hotfix supportato. Tuttavia, questo hotfix è destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Applicare questo hotfix solo ai sistemi in cui si verificano questo problema specifico.

Se l'aggiornamento rapido è disponibile per il download, è presente una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di assistenza tecnica e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se è richiesta la risoluzione dei problemi, potrebbe essere necessario creare una richiesta di assistenza separata. I costi di supporto standard verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix. Per un elenco completo dei numeri di telefono del servizio clienti Microsoft e supporto tecnico o per creare una richiesta di assistenza separata, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui è disponibile l'aggiornamento rapido. Se non è disponibile la lingua, è perché un aggiornamento rapido non è disponibile per tale lingua.

Prerequisiti

Per applicare questo hotfix, è necessario che è in esecuzione Windows Server 2008 R2 Service Pack 1 (SP1).

Per ulteriori informazioni su come ottenere un service pack di Windows Server 2008 R2, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
976932Informazioni sul Service Pack 1 per Windows 7 e Windows Server 2008 R2

Informazioni del Registro di sistema

Per utilizzare l'hotfix in questo pacchetto, non si dispone di apportare modifiche al Registro di sistema.

Richiesta di riavvio

Dopo aver applicato questo hotfix, è necessario riavviare il computer.

Informazioni sulla sostituzione dell'hotfix

Questo hotfix non sostituisce un aggiornamento rapido precedentemente rilasciato.

Informazioni sui file

La versione globale di questo hotfix consente di installare i file con gli attributi elencati nelle tabelle seguenti. Le date e le ore dei file elencate UTC (Coordinated Universal Time). Le date e le ore dei file sul computer locale vengono visualizzate nell'ora locale con la differenza dell'ora legale. Inoltre, le date e gli orari cambiano quando si eseguono determinate operazioni sui file.
Note informative relative al file Windows Server 2008 R2
Importante Gli aggiornamenti rapidi di Windows Server 2008 R2 e aggiornamenti rapidi di Windows 7 sono inclusi nel pacchetto stesso. Tuttavia, gli aggiornamenti rapidi nella pagina di richiesta di aggiornamenti rapidi sono elencati in entrambi i sistemi operativi. Per richiedere il pacchetto di hotfix che si applica a uno o entrambi i sistemi operativi, selezionare l'aggiornamento rapido è elencato nella sezione "Windows 7 e Windows Server 2008 R2" nella pagina. Fare sempre riferimento alla sezione "Si applica A" negli articoli per determinare il sistema operativo effettivo che ogni aggiornamento rapido si applica a.
  • I file relativi a un prodotto specifico, SR_Level (RTM, SPn), e il ramo del servizio (LDR, GDR) può essere identificato esaminando i numeri di versione del file, come illustrato nella tabella riportata di seguito.
    Riduci questa tabellaEspandi questa tabella
    VersioneProdottoSR_LevelRamo del servizio
    6.1.760 1. 21xxxWindows Server 2008 R2SP1LDR
  • I file MANIFEST (manifest) e il MUM (mum) installati per ogni ambiente sono elencati separatamenteNella sezione "ulteriori informazioni sui file per Windows Server 2008 R2". MUM e file MANIFEST e i file di catalogo (CAT) di protezione associati sono estremamente importanti mantenere lo stato dei componenti aggiornati. I file del catalogo di protezione per i quali non sono elencati gli attributi, sono firmati mediante firma digitale Microsoft.
Per tutte le versioni basate su x64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileVersione del fileDimensione del fileDataOraPiattaforma
Winmm. dll6.1.7601.21718217,60002-Maggio-201105: 20x64
Winmm. dll6.1.7601.2171819404802-Maggio-201105: 42x86

Status

Microsoft ha confermato che questo è un problema con i prodotti elencati nella sezione "Si applica a".

Informazioni

Per ulteriori informazioni sulla terminologia degli aggiornamenti software, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito:
824684Descrizione della terminologia standard utilizzata per descrivere gli aggiornamenti software Microsoft
Per ulteriori informazioni su come configurare Reindirizzamento registrazione audio in un server Host sessione Desktop remoto, visitare il seguente sito Web di TechNet:

Ulteriori informazioni sui file

Ulteriori informazioni sui file per Windows Server 2008 R2

File aggiuntivi per tutte le versioni basate su x64 di Windows Server 2008 R2
Riduci questa tabellaEspandi questa tabella
Nome del fileAmd64_69660c267e57b7710c81647583a72b8d_31bf3856ad364e35_6.1.7601.21718_none_8e50197e722c3e9f.manifest
Versione del fileNon applicabile
Dimensione del file708
Data (UTC)02-Maggio-2011
Ora (UTC)09: 09
Nome del fileAmd64_70bc76b1dbe92cf6a37e7180669cddd9_31bf3856ad364e35_6.1.7601.21718_none_d31582571fdee841.manifest
Versione del fileNon applicabile
Dimensione del file1,060
Data (UTC)02-Maggio-2011
Ora (UTC)09: 09
Nome del fileAmd64_9020e727ca8bb2e401767c7f797b56e0_31bf3856ad364e35_6.1.7601.21718_none_a67cc81bb640ebd4.manifest
Versione del fileNon applicabile
Dimensione del file710
Data (UTC)02-Maggio-2011
Ora (UTC)09: 09
Nome del fileAmd64_microsoft-windows-audio-mmecore-base_31bf3856ad364e35_6.1.7601.21718_none_149361828169a815.manifest
Versione del fileNon applicabile
Dimensione del file3,188
Data (UTC)02-Maggio-2011
Ora (UTC)06: 53
Nome del fileX86_microsoft-windows-audio-mmecore-base_31bf3856ad364e35_6.1.7601.21718_none_b874c5fec90c36df.manifest
Versione del fileNon applicabile
Dimensione del file3,184
Data (UTC)02-Maggio-2011
Ora (UTC)06. 04

Proprietà

Identificativo articolo: 2538047 - Ultima modifica: mercoledì 15 giugno 2011 - Revisione: 1.0
Le informazioni in questo articolo si applicano a:
  • Windows Server 2008 R2 Service Pack 1 alle seguenti piattaforme
    • Windows Server 2008 R2 Standard
    • Windows Server 2008 R2 Enterprise
    • Windows Server 2008 R2 Datacenter
Chiavi: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter kbmt KB2538047 KbMtit
Traduzione automatica articoli
Il presente articolo è stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non è sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, più o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non è la sua. Microsoft non è responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 2538047
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti