Chyba sa vyskytuje, keď konfiguráciu klienta systém Microsoft Dynamics CRM 2011 pre program Outlook, počas "Profil programu Outlook nakládky" časť Sprievodcu konfiguráciou

Preklady článku Preklady článku
ID článku: 2538692 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Pri konfigurácii klienta systém Microsoft Dynamics CRM 2011 Outlook, vyskytne sa chyba po vstupe užívateľa Windows Live Id a počas "Profil programu Outlook nakládky" časť Sprievodcu konfiguráciou.

V Crm50ClientConfig.log, vyskytnúť nasledovná chyba:

Error| Výnimka: V Microsoft.Interop.Mapi.CRcwMsgServiceAdmin.CreateMsgServiceEx (NÁZOV_SLUŽBY reťazec, String DisplayName, IntPtr UIParam, IMsgServiceAdmin_CreateMsgService_Flags vlajky)
na Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.InstallCrmDatastore (Guid organizationId Guid userId, reťazec serverUrl, reťazec organizationName, reťazec displayName)
na Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure (IProgressEventHandler progressEventHandler)
na Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure (Object stateInfo)

Crm50ClientConfig.log sa nachádza v týchto adresároch:

Windows7/2008
%USERPROFILE%\AppData\Local\Microsoft\MSCRM\Logs

WindowsXP/2003
%USERPROFILE%\Local Settings\Application Data\MSCRM\Logs

PRICINA

Ak niektorá z týchto podmienok sú pravdivé, môže nastať chyba vyššie:

Príčinou 1:
MAPISVC.inf súbor neexistuje na správne miesto.

Príčinou 2:
systém Microsoft Dynamics CRM služby nie je registrovaná k súboru MAPISVC.inf

RIESENIE

Riešenie 1:

Aby nás vykonať rezolúcia 1 pre vás, prejdite na "Fix it pomoc"časť. Ak chcete vykonať rezolúcia 1 sami, choďte na "Chcem si to opraviť sám"časť.

Fix it pomoc



Vykonať automaticky rezolúcia 1, kliknite na tlačidlo Opraviť tlačidlo alebo prepojenie. Kliknite na tlačidlo Spustiť v Prevzatie súboru dialógové okno, a postupujte podľa sprievodcu opraviť .


Tento problém
Microsoft Fix it 50901


Poznámky
  • Tento sprievodca bude len v anglickom jazyku. Avšak, automatické opravy fungujú aj pri iných jazykových verziách systému Windows.
  • Ak nie ste na počítači, ktorý má problém, uložte Fix it riešenie na flash disk alebo CD a potom ho spustite na počítači, ktorý má problém.

Potom prejdite na "Opravil sa problém?"časť.



Chcem si to opraviť sám

1. Umiestnenie súboru MAPISVC.inf závisí od typu architektúry systému Windows, ako aj Outlook. Nižšie je, kde MAPISVC.inf súbor by mal existovať založené na typoch architektúry systému Windows a programu Outlook.

32-bitový alebo x 86 verzie systému Windows a programu Outlook:
C:\Windows\System32\mapisvc.INF
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf

64 bit alebo x 64 verzie systému Windows a programu Outlook:
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.INF

32-bitový alebo x 86 verzie programu Outlook s 64 bit alebo x 64 verzie systému Windows:
C:\Program Files (x 86) \Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.INF

2. Ak súboru MAPISVC.inf neexistuje v žiadnom z týchto umiestnení, skúste vyhľadávanie v UserProfile:
Windows7/2008
%USERPROFILE%\AppData\Local\Microsoft\Outlook

WindowsXP/2003
%USERPROFILE%\Local Settings\Application Data\Microsoft\Outlook

3. Ak MAPISVC.inf súbor existuje v UserProfile, potom skopírujte na riadne adresáre architektúra typu systému Windows a programu Outlook.

4. Ak si nie ste istí, aký typ architektúry, ktoré používate pre systém Windows alebo program Outlook, použite nasledovný postup:
Windows:
a. kliknite na tlačidlo Štart a systému Windows
b. Prejdite na programy > príslušenstvo
c., kliknite pravým tlačidlom myši na príkazový riadok a prejdite na "Spustiť ako správca"
d. spustite nasledovný príkaz:
reg query "HKLM\System\CurrentControlSet\Control\Session Manager\Environment" /V PROCESSOR_ARCHITECTURE

Ak sa vráti, tieto výsledky, to by naznačujú operačného systému je 64-bitový operačný systém:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ AMD64

Ak sa vráti, tieto výsledky, to by naznačujú operačného systému je 32-bitový operačný systém:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ x 86

Ak systém Windows 32-bitový operačný systém, program Outlook bude 32-bitová aplikácia. Avšak, 64-bitový operačný systém Windows sa Outlook možno 32-bitová aplikácia alebo 64-bitová aplikácia. Outlook 2003 a Outlook 2007 podporované sú len ako 32-bitových aplikácií. Outlook 2010 však oba typy architektúry:

Zistiť verziu Outlook 2010 je, použite nasledovný postup:
a. kliknite na tlačidlo Štart a systému Windows
b. Prejdite na programy > príslušenstvo
c., kliknite pravým tlačidlom myši na príkazový riadok a prejdite na "Spustiť ako správca"
d. spustite nasledovný príkaz na základe verzie balíka Office:
reg query "HKLM\Software\Microsoft\Office\14.0\Outlook" /V Bitness

Riešenie 2:

Ak systém Microsoft Dynamics CRM služby nie je registrovaná k súboru MAPISVC.inf, môžeme manuálne pridajte tieto položky do súboru MAPISVC.inf a vložte ich do správneho miesta.

Na riešenie tejto otázky, prosím kontaktujte podporu systém Microsoft Dynamics CRM.

Opravil sa problém?

  • Skontrolujte, či sa daný problém vyriešil. Ak sa problém vyriešil,skončili ste s touto sekciou. Ak sa problém nevyrieši, môžete obráťte sa na podporu.
  • Ocenili by sme vašu spätnú väzbu. Poskytovať spätnú väzbu alebo akékoľvek problémy s toto riešenie, prosím zanechať komentár k "Fix it pomoc"blog alebo nám pošlite email.

Vlastnosti

ID článku: 2538692 - Posledná kontrola: 4. júla 2012 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Microsoft Dynamics CRM 2011
Kľúčové slová: 
kbmbsmigrate kbsurveynew kbfixme kbmsifixme kbmt KB2538692 KbMtsk
Strojovo preložené
DÔLEŽITÉ: Tento článok bol preložený pomocou softvéru na strojový preklad od spoločnosti Microsoft, nie prekladateľom. Spoločnosť Microsoft ponúka články preložené prekladateľmi aj strojovo preložené články, vďaka čomu máte možnosť prístupu ku všetkým článkom databázy Knowledge Base vo svojom jazyku. Strojovo preložený článok však nie je vždy perfektný. Môže obsahovať chyby týkajúce sa slovnej zásoby, syntaxe alebo gramatiky, podobne ako cudzinec môže robiť chyby, keď rozpráva vašim jazykom. Spoločnosť Microsoft nenesie zodpovednosť za akékoľvek nepresnosti, chyby alebo škody spôsobené akýmkoľvek nepresným prekladom obsahu alebo jeho použitím zo strany zákazníkov. Spoločnosť Microsoft softvér na strojový preklad pravidelne aktualizuje.
Pokiaľ chcete vidieť anglickú verziu článku, kliknite sem: 2538692

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com