Microsoft Dynamics CRM Yapılandırma Sihirbazı'nın Outlook Profili Yükleniyor bölümünde hata oluşuyor

Bu makalede, Microsoft Dynamics CRM Yapılandırma Sihirbazı'nın Outlook Profili Yükleniyor bölümünde hata iletisi alabileceğiniz soruna yönelik çözümler sağlanır.

Şunlar için geçerlidir: Microsoft Dynamics CRM 2011
Özgün KB numarası: 2538692

Belirtiler

Microsoft Dynamics CRM 2011 Outlook istemcisini yapılandırırken, kullanıcının Windows Live ID'si girildikten sonra ve Yapılandırma Sihirbazı'nın Outlook Profili Yükleniyor bölümünde bir hata oluşur.

Crm50ClientConfig.log aşağıdaki hata oluşur:

Hata| Özel durum: Microsoft.Interop.Mapi.CRcwMsgServiceAdmin.CreateMsgServiceEx(String ServiceName, String DisplayName, IntPtr UIParam, IMsgServiceAdmin_CreateMsgService_Flags Bayrakları)
Microsoft.Crm.Application.Outlook.Config. OutlookCRMDatastoreInstaller.InstallCrmDatastore(Guid organizationId, Guid userId, String serverUrl, String organizationName, String displayName)
Microsoft.Crm.Application.Outlook.Config. OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
Microsoft.Crm.Application.Outlook.Config. ConfigEngine.Configure(Object stateInfo)

Crm50ClientConfig.log aşağıdaki dizinlerde bulunur:

  • Windows7/2008

    %userprofile%\AppData\Local\Microsoft\MSCRM\Logs

  • WindowsXP/2003

    %userprofile%\Local Settings\Application Data\MSCRM\Logs

Neden

Aşağıdaki koşullardan biri doğruysa yukarıdaki hata oluşabilir:

Neden 1:

MAPISVC.inf dosyası uygun konumda yok.

Neden 2:

Microsoft Dynamics CRM hizmetleri MAPISVC.inf dosyasına kaydedilmiyor

Çözüm

Çözüm 1:

  1. MAPISVC.inf dosyasının konumu, Windows'un mimari türüne ve Outlook'a bağlıdır. Aşağıda MAPISVC.inf dosyasının Windows ve Outlook mimari türlerine göre mevcut olması gerekir.

    Windows ve Outlook'un 32 bit veya x86 sürümü:
    C:\Windows\System32\mapisvc.inf
    C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf

    Windows ve Outlook'un 64 bit veya x64 sürümü:
    C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf
    C:\windows\SysWOW64\mapisvc.inf

    Windows'un 64 bit veya x64 sürümüyle Outlook'un 32 bit veya x86 sürümü:
    C:\Program Files (x86)\Common Files\System\MSMAPI\1033\mapisvc.inf
    C:\windows\SysWOW64\mapisvc.inf

  2. MAPISVC.inf dosyası bu konumların hiçbirinde yoksa, UserProfile içinde bu dosyayı bulmaya çalışın:

    Windows7/2008
    %userprofile%\AppData\Local\Microsoft\Outlook

    WindowsXP/2003
    %userprofile%\Local Settings\Application Data\Microsoft\Outlook

  3. MAPISVC.inf dosyası UserProfile içinde varsa, Windows ve Outlook'un mimari türüne göre uygun dizinlere kopyalayın.

  4. Windows veya Outlook için hangi mimari türünü kullandığınızdan emin değilseniz aşağıdaki adımları kullanın:

    Windows:

    1. Windows/Başlangıç düğmesini seçin.

    2. Programlar Donatıları'na> gidin.

    3. Komut İstemi'ne Right-Click ve Yönetici olarak çalıştır'ı seçin.

    4. Aşağıdaki komutu çalıştırın:

      reg query "HKLM\System\CurrentControlSet\Control\Session Manager\Environment" /V PROCESSOR_ARCHITECTURE

    Döndürürse, aşağıdaki sonuçlar İşletim Sistemi'nin 64 bit bir İşletim Sistemi olduğunu gösterir:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
    PROCESSOR_ARCHITECTURE REG_SZ AMD64

    Döndürürse, aşağıdaki sonuçlar İşletim Sistemi'nin 32 bit bir İşletim Sistemi olduğunu gösterir:

    HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
    PROCESSOR_ARCHITECTURE REG_SZ x86

    Windows 32 bit bir İşletim Sistemi ise, Outlook 32 bit bir uygulama olacaktır. Ancak, Windows 64 bit bir İşletim Sistemi ise, Outlook 32 bit bir uygulama veya 64 bit bir uygulama olabilir. Outlook 2003 ve Outlook 2007 yalnızca 32 bit uygulamalar olarak desteklenir. Ancak, Outlook 2010'da her iki mimari türü de vardır:

    Outlook 2010'un hangi sürümünün olduğunu belirlemek için aşağıdaki adımları kullanın:

    1. Windows/Başlangıç düğmesini seçin.

    2. Programlar Donatıları'na> gidin.

    3. Komut İstemi'ne Right-Click ve Yönetici olarak çalıştır'ı seçin.

    4. Office sürümüne göre aşağıdaki komutu çalıştırın:

      reg query "HKLM\Software\Microsoft\Office\14.0\Outlook" /V Bitness

Çözüm 2:

Microsoft Dynamics CRM hizmetleri MAPISVC.inf dosyasına kaydedilmiyorsa, bu girdileri MAPISVC.inf dosyasına el ile ekleyebilir ve uygun konumlara yerleştirebiliriz.

Bu sorunu gidermek için yardım için Microsoft Dynamics CRM desteğe başvurun.

Daha fazla bilgi

Sorunun giderilip giderilmediğini denetleyin. Sorun çözülmüşse, bu bölümle işiniz bitti demektir. Sorun düzeltilmemişse Microsoft Desteği başvurabilirsiniz.