An error occurs when configuring the Microsoft Dynamics CRM 2011 client for Outlook, during the "Loading Outlook Profile" portion of the Configuration Wizard

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Article ID: 2538692 - View products that this article applies to.
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SYMPTOMS

When configuring the Microsoft Dynamics CRM 2011 Outlook client, an error occurs after entering the user's Windows Live Id and during the "Loading Outlook Profile" portion of the Configuration Wizard.

In the Crm50ClientConfig.log, the following error occurs:

Error| Exception : at Microsoft.Interop.Mapi.CRcwMsgServiceAdmin.CreateMsgServiceEx(String ServiceName, String DisplayName, IntPtr UIParam, IMsgServiceAdmin_CreateMsgService_Flags Flags)
at Microsoft.Crm.Application.Outlook.Config.OutlookCRMDatastoreInstaller.InstallCrmDatastore(Guid organizationId, Guid userId, String serverUrl, String organizationName, String displayName)
at Microsoft.Crm.Application.Outlook.Config.OutlookConfigurator.Configure(IProgressEventHandler progressEventHandler)
at Microsoft.Crm.Application.Outlook.Config.ConfigEngine.Configure(Object stateInfo)

The Crm50ClientConfig.log is located in the following directories:

Windows7/2008
%userprofile%\AppData\Local\Microsoft\MSCRM\Logs

WindowsXP/2003
%userprofile%\Local Settings\Application Data\MSCRM\Logs

CAUSE

The above error might occur if the any of the following conditions are true:

Cause 1:
The MAPISVC.inf file does not exist in the proper location.

Cause 2:
The Microsoft Dynamics CRM services are not being registered to the MAPISVC.inf file

RESOLUTION

Resolution 1:

To have us perform resolution 1 for you, go to the "Fix it for me" section. If you prefer to perform resolution 1 yourself, go to the "Let me fix it myself" section.

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To perform resolution 1 automatically, click the Fix it button or link. Then click Run in the File Download dialog box, and follow the steps in the Fix it wizard.


Fix this problem
Microsoft Fix it 50901


Notes
  • This wizard may be in English only. However, the automatic fix also works for other language versions of Windows.
  • If you are not on the computer that has the problem, save the Fix it solution to a flash drive or a CD and then run it on the computer that has the problem.

Then, go to the "Did this fix the problem?" section.



Let me fix it myself

1. The location of the MAPISVC.inf file depends on the architecture type of Windows as well as Outlook. Below is where the MAPISVC.inf file should exist based on the architecture types of Windows and Outlook.

32 bit or x86 version of Windows and Outlook:
C:\Windows\System32\mapisvc.inf
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf

64 bit or x64 version of Windows and Outlook:
C:\Program Files\Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.inf

32 bit or x86 version of Outlook with a 64 bit or x64 version of Windows:
C:\Program Files (x86)\Common Files\System\MSMAPI\1033\mapisvc.inf
C:\windows\SysWOW64\mapisvc.inf

2. If the MAPISVC.inf file does not exist in any of these locations, try locating it in the UserProfile:
Windows7/2008
%userprofile%\AppData\Local\Microsoft\Outlook

WindowsXP/2003
%userprofile%\Local Settings\Application Data\Microsoft\Outlook

3. If the MAPISVC.inf file exists in the UserProfile, then copy it to the proper directories based on the architecture type of Windows and Outlook.

4. If you are not sure what architecture type you are using for Windows or Outlook, use the following steps:
Windows:
a. Click on Windows/Start button
b. Go to Programs > Accessories
c. Right-Click on Command Prompt and go to "Run as administrator"
d. Run the following command:
reg query "HKLM\System\CurrentControlSet\Control\Session Manager\Environment" /V PROCESSOR_ARCHITECTURE

If it returns, the following results, it would indicate the Operating System is a 64-bit Operating System:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ AMD64

If it returns, the following results, it would indicate the Operating System is a 32-bit Operating System:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Control\Session Manager\Environment
PROCESSOR_ARCHITECTURE REG_SZ x86

If Windows is a 32-bit Operating System, then Outlook will be a 32 bit application. However, if Windows is a 64-bit Operating System, Outlook can be either a 32 bit application or a 64-bit application. Outlook 2003 and Outlook 2007 only are supported as 32-bit applications. However, Outlook 2010 has both architecture types:

To determine which version Outlook 2010 is, use the following steps:
a. Click on Windows/Start button
b. Go to Programs > Accessories
c. Right-Click on Command Prompt and go to "Run as administrator"
d. Run the following command based on the version of Office:
reg query "HKLM\Software\Microsoft\Office\14.0\Outlook" /V Bitness

Resolution 2:

If the Microsoft Dynamics CRM services are not being registered to the MAPISVC.inf file, we can manually add these entries to the MAPISVC.inf file and place them in the proper locations.

To address this issue, please contact Microsoft Dynamics CRM support for assistance.

Did this fix the problem?

  • Check whether the problem is fixed. If the problem is fixed, you are finished with this section. If the problem is not fixed, you can contact support.
  • We would appreciate your feedback. To provide feedback or to report any issues with this solution, please leave a comment on the "Fix it for me" blog or send us an email.

Properties

Article ID: 2538692 - Last Review: July 4, 2012 - Revision: 4.0
APPLIES TO
  • Microsoft Dynamics CRM 2011
Keywords: 
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