Artigo: 253931 - Última revisão: segunda-feira, 3 de Dezembro de 2007 - Revisão: 4.2

Montar uma base de dados após a falha do restauro com a mensagem de erro c1041724

Dica do SistemaEste artigo aplica-se a um sistema operativo diferente do que está a utilizar. Foi desactivado o conteúdo do artigo, que pode não ser relevante para si.
Expandir tudo | Reduzir tudo

Sintomas

Depois de restaurar uma base de dados a partir de uma cópia de segurança online, quando tenta montar a base de dados utilizando o Exchange System Manager, poderá receber a seguinte mensagem de erro:
An internal processing error has occurred. Try restarting the Exchange System Manager or the Microsoft Exchange Information Store service, or both.

ID no: c1041724
Exchange System Manager
São registados os seguintes eventos no registo de aplicações:
   Tipo de evento:	Error
   Origem do evento:	ESE98
   Categoria do evento:	Logging/Recovery 
   ID do evento:	619

   Descrição:
   Information Store (nnnn) Attempted to attach database
   'D:\Exchsrvr\MyStorageGroup\MyDatabase.edb' but it is a database
   restored from a backup set on which hard recovery was not started
   or did not complete successfully. 

   For more information, click
   http://search.support.microsoft.com/search/?adv=1.

   Tipo de evento:	Error
   Origem do evento:	MSExchangeIS
   Categoria do evento:	General 
   ID do evento:	9519

   Descrição:
   Error 0xfffffde0 starting database "[GUID da base de dados]" on the Microsoft
   Exchange Information Store. 

   For more information, click
   http://search.support.microsoft.com/search/?adv=1.
				

Causa

A caixa de verificação Último conjunto de cópias de segurança não estava seleccionada durante o restauro, pelo que a recuperação de hardware não foi executada.

Resolução

Para que a base de dados possa ser montada, a recuperação de hardware tem de ser concluída. Pode executar a recuperação de hardware manualmente com o seguinte comando:
eseutil /cc [caminho do directório que contém Restore.env]
Por exemplo, se o caminho especificado para a "Localização temporária para ficheiros patch e de registo" durante o processo de restauro for C:\TempRest, o comando para executar a recuperação de hardware será:
eseutil /cc c:\temprest
Nota: tem de executar o eseutil.exe a partir do directório Exchsrvr\Bin.

Após a conclusão da recuperação de hardware, monte a base de dados utilizando o Exchange System Manager.

Mais Informação

Para evitar este problema, seleccione a caixa de verificação Último conjunto de cópias de segurança durante o processo de restauro.

A informação contida neste artigo aplica-se a:
  • Microsoft Exchange Server 2003 Enterprise Edition
  • Microsoft Exchange Server 2003 Standard Edition
  • Microsoft Exchange 2000 Server Standard Edition
  • Microsoft Windows Small Business Server 2003 Premium Edition
  • Microsoft Windows Small Business Server 2003 Standard Edition
Palavras-chave: 
kberrmsg kbprb KB253931