"MAPI_E_NOT_ENOUGH_RESOURCES" error code when you run an application that calls the NspiQueryRows method in Windows Server 2008 R2

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Article ID: 2545649 - View products that this article applies to.
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Symptoms

Consider the following scenario:
  • You configure a Windows Server 2008 R2-based domain controller as a global catalog server in a domain.
  • You run an application from another client computer to connect to the global catalog server.
  • The application calls the NspiQueryRows method.
In this scenario, the NspiQueryRows method fails, and the following error code is returned:
MAPI_E_NOT_ENOUGH_RESOURCES
When this issue occurs, the application cannot query information from Active Directory Domain Services (AD DS).

For example, assume that you use Microsoft Office Outlook from a client computer to browse a name list in the Address Book that is in a domain. When you try to scroll down the name list, you receive the following error message:
The operation failed due to a shortage in system resources
Therefore, you cannot view the complete name list.

Cause

This issue occurs because of a function that is related to AD DS.

The function uses a 255-byte array to store a search key. This issue occurs if the size of the search key is more than 255 bytes.

Resolution

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that is described in this article. Apply this hotfix only to systems that are experiencing this specific problem.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, submit a request to Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft Web site:
http://support.microsoft.com/contactus/?ws=support
Note The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:
  • Windows Server 2008 R2
  • Windows Server 2008 R2 Service Pack 1 (SP1)
Additionally, the Active Directory Domain Services (AD DS) role must be installed.

For more information about how to obtain a Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:
976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.
Windows Server 2008 R2 file information notes
Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.
  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.
    Collapse this tableExpand this table
    VersionProductSR_LevelService branch
    6.1.760 0 . 20xxxWindows Server 2008 R2RTMLDR
    6.1.760 1 . 21xxxWindows Server 2008 R2SP1LDR
  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.
For all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameFile versionFile sizeDateTimePlatform
Ntdsa.mofNot applicable227,76510-Jun-200920:34Not applicable
Ntdsai.dll6.1.7600.209562,725,88829-Apr-201105:48x64
Ntdsa.mofNot applicable227,76505-Nov-201001:54Not applicable
Ntdsai.dll6.1.7601.217172,725,88829-Apr-201105:37x64

Workaround

To work around this issue, follow these steps:
  1. Configure a Windows Server 2003-based domain controller as a global catalog server.
  2. Run the application to connect to the global catalog server and to query the information that is stored in AD DS.

Note To work around this issue in Microsoft Office Outlook, enable the Use Cached Exchange Mode option in Outlook.


Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:
824684 Description of the standard terminology that is used to describe Microsoft software updates
For more information about the NspiQueryRows method, visit the following MSDN website:
General information about the NspiQueryRows method
For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:
981465 "MAPI_E_NOT_ENOUGH_RESOURCES" error code when you run an application that calls the NspiQueryRows method in Windows Server 2008

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x64-based versions of Windows Server 2008 R2
Collapse this tableExpand this table
File nameAmd64_76905edc7f18b0f0a3edea023877aaa2_31bf3856ad364e35_6.1.7600.20956_none_30a5ceb13f130c17.manifest
File versionNot applicable
File size716
Date (UTC)29-Apr-2011
Time (UTC)10:56
PlatformNot applicable
File nameAmd64_dadab104f7aa4e71ed1e5a2ed1d28c38_31bf3856ad364e35_6.1.7601.21717_none_d860255dd175b1a6.manifest
File versionNot applicable
File size716
Date (UTC)29-Apr-2011
Time (UTC)10:56
PlatformNot applicable
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7600.20956_none_4d6649eaebd82257.manifest
File versionNot applicable
File size3,531
Date (UTC)29-Apr-2011
Time (UTC)06:35
PlatformNot applicable
File nameAmd64_microsoft-windows-d..toryservices-ntdsai_31bf3856ad364e35_6.1.7601.21717_none_4f78e6eae8dd37d6.manifest
File versionNot applicable
File size3,531
Date (UTC)29-Apr-2011
Time (UTC)06:53
PlatformNot applicable
File nameUpdate.mum
File versionNot applicable
File size3,741
Date (UTC)29-Apr-2011
Time (UTC)10:56
PlatformNot applicable

Properties

Article ID: 2545649 - Last Review: December 27, 2012 - Revision: 2.0
Applies to
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Foundation
  • Windows Server 2008 R2 Datacenter
Keywords: 
kbautohotfix kbqfe kbhotfixserver kbfix kbsurveynew kbexpertiseinter KB2545649

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