Comment faire pour activer la journalisation de Microsoft Installer et le journal documenté pour rassembler des informations de dépannage supplémentaires.

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Numéro d'article: 2545723 - Voir les produits auxquels s'applique cet article
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Sommaire

Symptômes

Windows Installer utilise la journalisation pour vous aider à résoudre les problèmes pouvant survenir lorsque vous installez les logiciels. Une fois que vous avez activé la journalisation, vous pouvez à nouveau essayer l'installation qui a échoué. Windows Installer suit la progression et enregistre les données dans un fichier journal. Ces journaux peuvent ensuite être examinés par des techniciens du support technique afin de déterminer le problème.

Cause

 Les problèmes de Microsoft Installer peuvent résulter de la détérioration des données, d'installations corrompues et de nombreux autres problèmes différents.

Résolution

Pour résoudre ces problèmes, vous devez activer la journalisation pour deux processus, puis réessayer d'installer les mises à jour. Lorsque vous activez la journalisation, les codes d'erreur réels qui sont générés par Windows Installer sont capturés. Dès que les codes d'erreur sont capturés, vous pouvez déterminer le problème réel et sa solution. Afin de résoudre le problème lié à ces erreurs, vous devez contacter le support technique Microsoft. Toutefois, vous devez effectuer plusieurs opérations avant de contacter le support technique Microsoft.

Pour activer et collecter les journaux de Windows Installer, exécutez la procédure correspondant à votre système d'exploitation.

Étape 1 : activer la journalisation de Microsoft Installer et le journal documenté de Windows Update

Afin que nous puissions activer la journalisation pour vous, consultez la section « Aidez-moi ». Si vous préférez activer la journalisation vous-même, consultez la section « Je résous le problème moi-même ».

Aidez-moi

Pour activer la journalisation automatiquement, cliquez sur le lien Résoudre ce problème, puis sur Exécuter dans la boîte de dialogue Téléchargement de fichier, et suivez la procédure de l'Assistant.

Résoudre ce problème
Microsoft Fix it 50473

Remarque Cet Assistant peut n'exister qu'en anglais. La correction automatique fonctionne toutefois pour les versions de Windows dans d'autres langues.

Remarque Si vous n'êtes pas sur l'ordinateur pour lequel le problème existe, vous pouvez enregistrer la résolution automatique sur un lecteur flash ou sur un CD-ROM afin de pouvoir l'exécuter sur l'ordinateur concerné par le problème.

Je résous le problème moi-même

Pour les ordinateurs sous Windows 2000, Windows XP ou Windows Server 2003

  1. Cliquez sur Démarrer et sur Exécuter, tapez Bloc-notes, puis cliquez sur OK.
  2. Tapez les commandes suivantes dans le Bloc-notes.
    Éditeur de Registre Windows version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"="voicewarmupx" 
    "Debug"=dword:00000007
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    "Flags"=dword:00000016
    "Level"=dword:00000004
    
  3. Dans le menu Fichier, cliquez sur Enregistrer sous.
  4. Dans la liste Enregistrer dans, cliquez sur Bureau.
  5. Dans la zone Nom du fichier, tapez LoggingOn.reg, cliquez sur Tous les fichiers dans la liste Type, puis sur Enregistrer.
  6. Sur le Bureau, double-cliquez sur le fichier LoggingOn.reg pour ajouter les clés de Registre au Registre Windows.
  7. Cliquez sur OK dans la boîte de message.
  8. Essayez à nouveau d'installer la mise à jour pour capturer les informations d'erreur supplémentaires dans le fichier .log de Windows Installer.

Pour les ordinateurs sous Windows Vista et Windows Server 2008

  1. Cliquez sur Démarrer
    Réduire cette imageAgrandir cette image
    le bouton Démarrer
    , puis tapez Bloc-notes dans la zone Rechercher.
  2. Dans la liste Programmes, cliquez sur Bloc-notes.
  3. Tapez les commandes suivantes dans le Bloc-notes.
    Éditeur de Registre Windows version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"="voicewarmupx" 
    "Debug"=dword:00000007
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    "Flags"=dword:00000016
    "Level"=dword:00000004
    
  4. Dans le menu Fichier, cliquez sur Enregistrer sous.
  5. Dans la liste Enregistrer dans, cliquez sur Bureau.
  6. Dans la zone Nom du fichier, tapez LoggingOn.reg, cliquez sur Tous les fichiers dans la liste Type, puis sur Enregistrer.
  7. Sur le Bureau, double-cliquez sur le fichier LoggingOn.reg pour ajouter les valeurs de Registre au Registre Windows.

    Réduire cette imageAgrandir cette image
    Autorisation Contrôle d'accès utilisateur
    Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez le mot de passe, ou cliquez sur Continuer.
  8. Cliquez sur Oui, puis sur OK.
  9. Essayez à nouveau d'installer la mise à jour pour capturer les informations d'erreur supplémentaires dans le fichier .log de Windows Installer.

Étape 2 : essayer à nouveau d'installer les mises à jour pour créer les fichiers journaux

Afin de tenter à nouveau l'installation des mises à jour, reportez-vous au site Web de Microsoft Update à l'adresse suivante :
http://www.update.microsoft.com/
Remarque La récupération de ces journaux peut prendre quelques minutes, et le processus de mise à jour peut ne pas sembler fonctionner correctement. Laissez au processus le temps nécessaire pour s'achever.

Étape 3 : désactiver la journalisation de Microsoft Installer et le journal documenté de Windows Update

Important Dès que Windows Update ou Microsoft Update a terminé, désactivez la journalisation de Windows Installer. Si la journalisation est activée, l'installation de chaque nouvelle mise à jour risque de prendre trop de temps. Cela peut également ralentir votre ordinateur et créer des fichiers journaux volumineux occupant un espace important sur le disque.

Afin que nous puissions désactiver la journalisation pour vous, consultez la section « Aidez-moi ». Si vous préférez désactiver la journalisation vous-même, consultez la section « Je résous le problème moi-même ».

Aidez-moi

Pour désactiver la journalisation automatiquement, cliquez sur le lien Résoudre ce problème, puis sur Exécuter dans la boîte de dialogue Téléchargement de fichier, et suivez la procédure de l'Assistant.

Résoudre ce problème
Microsoft Fix it 50474

Remarque Cet Assistant peut n'exister qu'en anglais. La correction automatique fonctionne toutefois pour les versions de Windows dans d'autres langues.

Remarque Si vous n'êtes pas sur l'ordinateur pour lequel le problème existe, vous pouvez enregistrer la résolution automatique sur un lecteur flash ou sur un CD-ROM afin de pouvoir l'exécuter sur l'ordinateur concerné par le problème.

Je résous le problème moi-même

Pour désactiver la journalisation de Windows Installer, exécutez la procédure correspondant à votre système d'exploitation.

Pour les ordinateurs sous Windows 2000, Windows XP ou Windows Server 2003

  1. Cliquez sur Démarrer et sur Exécuter, tapez Bloc-notes, puis cliquez sur OK.
  2. Tapez les commandes suivantes dans le Bloc-notes.
    Éditeur de Registre Windows version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    
  3. Dans le menu Fichier, cliquez sur Enregistrer sous.
  4. Dans la liste Enregistrer dans, cliquez sur Bureau.
  5. Dans la zone Nom du fichier, tapez LoggingOff.reg, cliquez sur Tous les fichiers dans la liste Type, puis sur Enregistrer.
  6. Sur le Bureau, double-cliquez sur le fichier LoggingOff.reg pour supprimer les valeurs de Registre du Registre Windows.
  7. Cliquez sur OK dans la boîte de message.
  8. Supprimez les fichiers LoggingOn.reg et LoggingOff.reg du Bureau
Contactez le support technique Microsoft pour obtenir de l'aide et mentionnez cet article de la Base de connaissances Microsoft à l'agent de support. Pour plus d'informations sur la façon de contacter le support technique Microsoft, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ln=fr&ws=support#tab0

Pour les ordinateurs sous Windows Vista et Windows Server 2008

  1. Cliquez sur Démarrer
    Réduire cette imageAgrandir cette image
    le bouton Démarrer
    , puis tapez Bloc-notes dans la zone Rechercher.
  2. Dans la liste Programmes, cliquez sur Bloc-notes.
  3. Tapez les commandes suivantes dans le Bloc-notes.
    Éditeur de Registre Windows version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    
  4. Dans le Bloc-Notes, cliquez sur Enregistrer sous dans le menu Fichier.
  5. Dans la liste Enregistrer dans, cliquez sur Bureau.
  6. Dans la zone Nom du fichier, tapez LoggingOff.reg, cliquez sur Tous les fichiers dans la liste Type, puis sur Enregistrer.
  7. Sur le Bureau, double-cliquez sur le fichier LoggingOff.reg pour supprimer les valeurs de Registre du Registre Windows.

    Réduire cette imageAgrandir cette image
    Autorisation Contrôle d'accès utilisateur
    Si vous êtes invité à entrer un mot de passe administrateur ou à confirmer une opération, entrez le mot de passe, ou cliquez sur Continuer.
  8. Cliquez sur Oui, puis sur OK.
  9. Supprimez les fichiers LoggingOn.reg et LoggingOff.reg du Bureau
Contactez le support technique Microsoft pour obtenir de l'aide et mentionnez cet article de la Base de connaissances Microsoft à l'agent de support. Pour plus d'informations sur la façon de contacter le support technique Microsoft, reportez-vous au site Web de Microsoft à l'adresse suivante :
http://support.microsoft.com/contactus/?ln=fr&ws=support#tab0

Plus d'informations

En général, le nom du journal de Windows Installer commence par msi, se termine par l'extension .log et comprend un groupe de caractères. En voici un exemple :
msib3a6g.log
Sur les ordinateurs sous Windows 2000, Windows XP ou Windows Server 2003, le journal se trouve dans le répertoire suivant :
C:\Documents and Settings\ {NomUtilisateur} \Local Settings\Temp\
Pour ouvrir ce répertoire, cliquez sur Démarrer et sur Exécuter, tapez %temp%, puis cliquez sur OK.

Remarque Ces informations supposent que Windows est installé sur le lecteur par défaut C. Si ce n'est pas le cas, modifiez la lettre du lecteur dans le chemin d'accès au dossier afin de la faire correspondre au lecteur d'installation.

Sur les ordinateurs sous Windows Vista ou Windows Server 2008, le journal se trouve dans le répertoire suivant :
C:\Users\{NomUtilisateur\AppData\Local\Temp
Pour ouvrir ce répertoire, cliquez sur Démarrer
Réduire cette imageAgrandir cette image
le bouton Démarrer
, tapez %temp% dans la zone Rechercher, puis appuyez sur Entrée.

Remarque Ces informations supposent que Windows est installé sur le lecteur par défaut C. Si ce n'est pas le cas, modifiez la lettre du lecteur dans le chemin d'accès au dossier afin de la faire correspondre au lecteur d'installation.

Références

Pour plus d'informations sur l'activation de la journalisation de Windows Installer, cliquez sur le numéro ci-dessous pour afficher l'article correspondant dans la Base de connaissances Microsoft :
314852 Comment faire pour activer la journalisation de Windows Installer dans Windows XP

Propriétés

Numéro d'article: 2545723 - Dernière mise à jour: vendredi 4 novembre 2011 - Version: 2.0
Les informations contenues dans cet article s'appliquent au(x) produit(s) suivant(s):
  • Windows 7 Édition Starter
  • Windows 7 Édition Familiale Basique
  • Windows 7 Édition Familiale Premium
  • Windows 7 Entreprise
  • Windows 7 Professionnel
  • Windows 7 Édition Integrale
Mots-clés : 
KB2545723
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