วิธีการบันทึกข้อมูลการเปิดใช้งานโปรแกรมติดตั้ง Microsoft และบันทึกการสร้างการรวบรวมข้อมูลการแก้ไขปัญหาเพิ่มเติม

การแปลบทความ การแปลบทความ
หมายเลขบทความ (Article ID): 2545723 - ผลิตภัณฑ์ที่เกี่ยวข้องในบทความนี้
ขยายทั้งหมด | ยุบทั้งหมด

เนื้อหาบนหน้านี้

อาการ

Windows Installer ใช้บันทึกข้อมูลเพื่อช่วยคุณแก้ไขปัญหาที่อาจเกิดขึ้นเมื่อคุณติดตั้งแพคเกจซอฟต์แวร์ หลังจากที่คุณเปิดใช้งานการบันทึกข้อมูล คุณสามารถลองติดตั้งไม่ประสบความสำเร็จอีกครั้ง Windows Installer ติดตามความคืบหน้า และบันทึกข้อมูลในแฟ้มบันทึก แล้วบันทึกเหล่านี้สามารถถูกตรวจทาน โดยผู้เชี่ยวชาญด้านการสนับสนุนการตรวจสอบปัญหา

สาเหตุ

โปรแกรมติดตั้ง Microsoft ปัญหาอาจมีสาเหตุจากความเสียหายของข้อมูล การติดตั้งเสียหาย และปัญหาต่าง ๆ มากมายอื่น ๆ

การแก้ไข

เมื่อต้องการแก้ไขปัญหาเหล่านี้ คุณจำเป็นต้องเปิดใช้งานการบันทึกข้อมูลสำหรับกระบวนการสอง ทางแล้ว ลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง เมื่อคุณเปิดใช้งานการบันทึกข้อมูล รหัสข้อผิดพลาดที่เกิดขึ้นจริงที่สร้างขึ้น โดย Windows Installer ถูกจับภาพไว้ รวมรหัสข้อผิดพลาดการจับภาพ คุณสามารถกำหนดว่าปัญหาเกิดขึ้นจริงและการแก้ปัญหา ข้อผิดพลาดเหล่านี้จะให้คุณติดต่อฝ่ายสนับสนุนของ Microsoft เมื่อต้องการแก้ไขปัญหา อย่างไรก็ตาม คุณต้องทำสิ่งต่าง ๆ ก่อนที่คุณติดต่อฝ่ายสนับสนุนของ Microsoft

เมื่อต้องการเปิดใช้งาน และการเก็บรวบรวมแฟ้มบันทึก Windows Installer ให้ทำตามขั้นตอนต่าง ๆ สำหรับระบบปฏิบัติการของคุณ

ขั้นตอนที่ 1: เปิดใช้งาน Microsoft Installer ล็อกและบันทึกการสร้าง Windows Update

ต้องการให้เราเปิดใช้งานการบันทึกข้อมูลสำหรับคุณ ไป "แก้ไขให้ฉัน"ส่วน ถ้าเป็นคุณจะช่วยให้การเข้าสู่ระบบด้วยตัวคุณเอง ไป "ให้ฉันแก้ไขด้วยตนเอง"ส่วน

แก้ไขให้ฉัน

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start expanded
เมื่อต้องการเปิดใช้งานการเข้าสู่ระบบโดยอัตโนมัติ การ การแก้ไขปัญหาดังกล่าว ปุ่มหรือการเชื่อมโยง แล้ว คลิก เรียกใช้ ในการ การดาวน์โหลดแฟ้ม กล่องโต้ตอบกล่อง และทำตามขั้นตอนในตัวช่วยสร้างการแก้ไขปัญหา

สำหรับ Windows 8, Windows 7
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start expanded
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit1
แก้ไขปัญหานี้
Microsoft Fix it 20095
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit2

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end

สำหรับ Windows Vista, Windows XP, Windows Server 2008, Windows Server 2003
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start expanded
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit1
แก้ไขปัญหานี้
Microsoft Fix it 50473
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit2
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end

บันทึกย่อ
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
  • ตัวช่วยสร้างนี้อาจเป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติยังสามารถใช้ได้กับ Windows รุ่นภาษาอื่น
  • ถ้าคุณไม่ได้กำลังใช้งานคอมพิวเตอร์ที่มีปัญหา ให้บันทึกโซลูชัน Fix it ลงในแฟลชไดรฟ์หรือซีดี แล้วเรียกใช้โซลูชันนี้บนคอมพิวเตอร์ที่มีปัญหา
  • เรายินดีรับทราบคำติชมของคุณ เมื่อต้อง การแสดงความคิดเห็น หรือรายงานปัญหาใด ๆ เกี่ยวกับการแก้ไขนี้ กรุณาฝากความคิดเห็นในการ "แก้ไขให้ฉัน"บล็อก หรือส่งให้เรามี อีเมล ข้อความ
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end

ให้ฉันแก้ไขด้วยตนเอง

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed

สำหรับคอมพิวเตอร์ที่กำลังเรียกใช้ Windows 2000, Windows XP หรือ Windows Server 2003

  1. คลิก เริ่มคลิก เรียกใช้ชนิด แผ่นจดบันทึกแล้ว คลิก ตกลง.
  2. พิมพ์คำสั่งต่อไปนี้ใน Notepad
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"="voicewarmupx" 
    "Debug"=dword:00000007
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    "Flags"=dword:00000016
    "Level"=dword:00000004
    
  3. ในการ แฟ้ม เมนู คลิก บันทึกเป็น.
  4. ในการ บันทึกใน รายการ คลิก เดสก์ท็อป.
  5. ในการ $$$$ ชื่อแฟ้ม กล่อง ชนิด LoggingOn.regคลิก แฟ้มทั้งหมด ในการ บันทึกเป็นชนิด รายการ และจากนั้น คลิก บันทึก.
  6. บนเดสก์ท็อป คลิกสองครั้งที่แฟ้ม LoggingOn.reg เมื่อต้องการเพิ่มคีย์รีจิสทรี Windows รีจิสทรี
  7. คลิก ตกลง ในกล่องข้อความ
  8. กำลังพยายามติดตั้งการปรับปรุงอีกครั้งเพื่อจับภาพข้อมูลข้อผิดพลาดเพิ่มเติมในแฟ้ม Windows Installer .log

สำหรับคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Vista และ Windows Server 2008

  1. คลิก เริ่ม
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่มเริ่มต้น
    และจากนั้นในการ เริ่มต้นค้นหา กล่อง ชนิด แผ่นจดบันทึก.
  2. ในการ โปรแกรม รายการ คลิก แผ่นจดบันทึก.
  3. พิมพ์คำสั่งต่อไปนี้ใน Notepad
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"="voicewarmupx" 
    "Debug"=dword:00000007
    [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    "Flags"=dword:00000016
    "Level"=dword:00000004
    
  4. ในการ แฟ้ม เมนู คลิก บันทึกเป็น.
  5. ในการ บันทึกใน รายการ คลิก เดสก์ท็อป.
  6. ในการ $$$$ ชื่อแฟ้ม กล่อง ชนิด LoggingOn.regคลิก แฟ้มทั้งหมด ในการ บันทึกเป็นชนิด รายการ และจากนั้น คลิก บันทึก.
  7. บนเดสก์ท็อป คลิกสองครั้งที่แฟ้ม LoggingOn.reg เมื่อต้องการเพิ่มค่ารีจิสทรี Windows รีจิสทรี

    ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิ์การควบคุมการเข้าถึงของผู้ใช้
    ถ้าคุณได้รับพร้อมท์สำหรับรหัสผ่านของผู้ดูแลระบบหรือยืนยัน ให้พิมพ์รหัสผ่าน หรือคลิก ดำเนินการต่อไป.
  8. คลิก ใช่แล้ว คลิก ตกลง.
  9. กำลังพยายามติดตั้งการปรับปรุงอีกครั้งเพื่อจับภาพข้อมูลข้อผิดพลาดเพิ่มเติมในแฟ้ม Windows Installer .log
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed

ขั้นตอนที่ 2: ลองติดตั้งโปรแกรมปรับปรุงอีกครั้งเพื่อสร้างแฟ้มบันทึก

เมื่อต้องการลองติดตั้งโปรแกรมปรับปรุงอีกครั้ง แวะไปที่ Microsoft Update เว็บไซต์ต่อไปนี้:
http://update.microsoft.com
หมายเหตุ ซึ่งอาจใช้เวลาหลายนาทีในการเก็บรวบรวมบันทึกเหล่านี้ และกระบวนการปรับปรุงอาจไม่ สามารถทำงานได้อย่างถูกต้อง อนุญาตให้ใช้สำหรับเวลาจำเป็นสำหรับกระบวนการจะเสร็จสิ้น

ขั้นตอนที่ 3: ปิดใช้งานการติดตั้ง Microsoft บันทึกและบันทึกการสร้าง Windows Update

สิ่งสำคัญ ทันทีที่ Windows Update หรือ Microsoft Update ได้เสร็จสิ้น การปิดใช้งานการบันทึก Windows Installer ไม่สามารถเปิดใช้งานการบันทึกข้อมูลที่จำเป็นต้องใช้เวลามากเกินไปทุกครั้งที่คุณติดตั้งโปรแกรมปรับปรุง สามารถทำให้ช้าลงคอมพิวเตอร์ของคุณ และสามารถสร้างแฟ้มล็อกที่มีขนาดใหญ่ที่จำเป็นต้องมีเนื้อที่ว่างบนดิสก์จำนวนมาก

ต้องการให้เราปิดใช้งานการบันทึกข้อมูลสำหรับคุณ ไป "แก้ไขให้ฉัน"ส่วน หากแต่คุณจะต้องยกเลิกการเข้าสู่ระบบด้วยตัวคุณเอง ไป "ให้ฉันแก้ไขด้วยตนเอง"ส่วน

แก้ไขให้ฉัน

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start expanded
เมื่อต้องการปิดใช้งานการเข้าสู่ระบบโดยอัตโนมัติ การ การแก้ไขปัญหาดังกล่าว ปุ่มหรือการเชื่อมโยง แล้ว คลิก เรียกใช้ ในการ การดาวน์โหลดแฟ้ม กล่องโต้ตอบกล่อง และทำตามขั้นตอนในตัวช่วยสร้างการแก้ไขปัญหา

สำหรับ Windows 8, Windows 7
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start expanded
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit1
แก้ไขปัญหานี้
Microsoft Fix it 20096
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit2

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end

สำหรับ Windows Vista, Windows XP, Windows Server 2008, Windows Server 2003
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start expanded
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit1
แก้ไขปัญหานี้
Microsoft Fix it 50474
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets fixit2
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end

บันทึกย่อ
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
  • ตัวช่วยสร้างนี้อาจเป็นภาษาอังกฤษเท่านั้น อย่างไรก็ตาม การแก้ไขอัตโนมัติยังสามารถใช้ได้กับ Windows รุ่นภาษาอื่น
  • ถ้าคุณไม่ได้กำลังใช้งานคอมพิวเตอร์ที่มีปัญหา ให้บันทึกโซลูชัน Fix it ลงในแฟลชไดรฟ์หรือซีดี แล้วเรียกใช้โซลูชันนี้บนคอมพิวเตอร์ที่มีปัญหา
  • เรายินดีรับทราบคำติชมของคุณ เมื่อต้อง การแสดงความคิดเห็น หรือรายงานปัญหาใด ๆ เกี่ยวกับการแก้ไขนี้ กรุณาฝากความคิดเห็นในการ "แก้ไขให้ฉัน"บล็อก หรือส่งให้เรามี อีเมล ข้อความ
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end

ให้ฉันแก้ไขด้วยตนเอง

ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding start collapsed
เมื่อต้องการปิดใช้งานการเข้าสู่ระบบ Windows Installer ให้ทำตามขั้นตอนต่าง ๆ สำหรับระบบปฏิบัติการของคุณ

สำหรับคอมพิวเตอร์ที่กำลังเรียกใช้ Windows 2000, Windows XP หรือ Windows Server 2003

  1. คลิก เริ่มคลิก เรียกใช้ชนิด แผ่นจดบันทึกแล้ว คลิก ตกลง.
  2. พิมพ์คำสั่งต่อไปนี้ใน Notepad
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    
  3. ในการ แฟ้ม เมนู คลิก บันทึกเป็น.
  4. ในการ บันทึกใน รายการ คลิก เดสก์ท็อป.
  5. ในการ $$$$ ชื่อแฟ้ม กล่อง ชนิด LoggingOff.regคลิก แฟ้มทั้งหมด ในการ บันทึกเป็นชนิด รายการ และจากนั้น คลิก บันทึก.
  6. บนเดสก์ท็อป คลิกสองครั้งที่แฟ้ม LoggingOff.reg เมื่อต้องการลบค่ารีจิสทรีจากรีจิสทรีของ Windows
  7. คลิก ตกลง ในกล่องข้อความ
  8. ลบแฟ้ม LoggingOn.reg และ LoggingOff.reg จากเดสก์ท็อป
ติดต่อฝ่ายสนับสนุนของ Microsoft สำหรับความช่วยเหลือ และการอ้างอิงบทความฐานความรู้ของ Microsoft นี้เมื่อคุณพูดกับตัวแทนฝ่ายสนับสนุน สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการติดต่อฝ่ายสนับสนุนของ Microsoft แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=support

สำหรับคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Vista และ Windows Server 2008

  1. คลิก เริ่ม
    ยุบรูปภาพนี้ขยายรูปภาพนี้
    ปุ่มเริ่มต้น
    และจากนั้น พิมพ์ แผ่นจดบันทึก ในการ เริ่มต้นค้นหา กล่อง
  2. ในการ โปรแกรม รายการ คลิก แผ่นจดบันทึก.
  3. พิมพ์คำสั่งต่อไปนี้ใน Notepad
    Windows Registry Editor Version 5.00
    
    [HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
    "Logging"=-
    "Debug"=-
    [-HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\WindowsUpdate\Trace]
    
  4. ใน Notepad คลิก บันทึกเป็น ในการ แฟ้ม เมนู
  5. ในการ บันทึกใน รายการ คลิก เดสก์ท็อป.
  6. ในการ $$$$ ชื่อแฟ้ม กล่อง ชนิด LoggingOff.regคลิก แฟ้มทั้งหมด ในการ บันทึกเป็นชนิด รายการ และจากนั้น คลิก บันทึก.
  7. บนเดสก์ท็อป คลิกสองครั้งที่แฟ้ม LoggingOff.reg เมื่อต้องการลบค่ารีจิสทรีจากรีจิสทรีของ Windows

    ยุบรูปภาพนี้ขยายรูปภาพนี้
    สิทธิ์การควบคุมการเข้าถึงของผู้ใช้
    ถ้าคุณได้รับพร้อมท์สำหรับรหัสผ่านของผู้ดูแลระบบหรือยืนยัน ให้พิมพ์รหัสผ่าน หรือคลิก ดำเนินการต่อไป.
  8. คลิก ใช่แล้ว คลิก ตกลง.
  9. ลบแฟ้ม LoggingOn.reg และ LoggingOff.reg จากเดสก์ท็อป
ยุบรูปภาพนี้ขยายรูปภาพนี้
assets folding end collapsed
ติดต่อฝ่ายสนับสนุนของ Microsoft สำหรับความช่วยเหลือ และการอ้างอิงบทความฐานความรู้ของ Microsoft นี้เมื่อคุณพูดกับตัวแทนฝ่ายสนับสนุน สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการติดต่อฝ่ายสนับสนุนของ Microsoft แวะไปที่เว็บไซต์ต่อไปนี้ของ Microsoft:
http://support.microsoft.com/contactus/?ws=support

ข้อมูลเพิ่มเติม

ในกรณีส่วนใหญ่ แฟ้มบันทึกการติดตั้ง Windows Start ด้วย msi ลงท้าย ด้วยนามสกุลเป็น.log และรวมกลุ่มของอักขระ ตัวอย่างเช่น การบันทึก Windows Installer จะมีชื่อแฟ้มที่มีลักษณะต่อไปนี้:
msib3a6g.log
บนคอมพิวเตอร์ที่กำลังเรียกใช้ Windows 2000, Windows XP หรือ Windows Server 2003 แฟ้มบันทึกการติดตั้งจะอยู่ในไดเรกทอรีดังต่อไปนี้:
C:\Documents and \Local Settings\Temp\ Settings\ {ชื่อผู้ใช้}
เมื่อต้องเปิดไดเรกทอรีนี้ เริ่มคลิก เรียกใช้ชนิด % temp %แล้ว คลิก ตกลง.

หมายเหตุ ข้อมูลนี้ถือว่า มีการติดตั้ง Windows เมื่อต้องการเริ่มต้นไดรฟ์ c ถ้าไม่เป็น ปรับเปลี่ยนอักษรชื่อไดรฟ์สำหรับเส้นทางของโฟลเดอร์ให้ตรงกับไดรฟ์ติดตั้ง

บนคอมพิวเตอร์ที่กำลังเรียกใช้ Windows Vista หรือ Windows Server 2008 แฟ้มบันทึกการติดตั้งจะอยู่ในไดเรกทอรีดังต่อไปนี้:
C:\Users\{UserName\AppData\Local\Temp
เมื่อต้องการเปิดไดเรกทอรีนี้ ให้คลิกเริ่มต้น
ยุบรูปภาพนี้ขยายรูปภาพนี้
ปุ่มเริ่มต้น
ชนิด % temp % ในการ เริ่มต้นค้นหา กล่อง และจากนั้น กด ENTER

หมายเหตุ ข้อมูลนี้ถือว่า มีการติดตั้ง Windows เมื่อต้องการเริ่มต้นไดรฟ์ c ถ้าไม่เป็น ปรับเปลี่ยนอักษรชื่อไดรฟ์สำหรับเส้นทางของโฟลเดอร์ให้ตรงกับไดรฟ์ติดตั้ง

ข้อมูลอ้างอิง

สำหรับข้อมูลเพิ่มเติมเกี่ยวกับวิธีการเปิดใช้งานการเข้าสู่ระบบ Windows Installer คลิกหมายเลขบทความต่อไปนี้เพื่อดูบทความในฐานความรู้ของ Microsoft:
314852วิธีการเปิดใช้งาน Windows Installer ที่เข้าสู่ระบบใน Windows XP

คุณสมบัติ

หมายเลขบทความ (Article ID): 2545723 - รีวิวครั้งสุดท้าย: 22 พฤษภาคม 2556 - Revision: 2.0
ใช้กับ
  • Windows 7 Starter
  • Windows 7 Home Basic
  • Windows 7 Home Premium
  • Windows 7 Enterprise
  • Windows 7 Professional
  • Windows 7 Ultimate
Keywords: 
kbmt KB2545723 KbMtth
แปลโดยคอมพิวเตอร์
ข้อมูลสำคัญ: บทความนี้แปลโดยซอฟต์แวร์การแปลด้วยคอมพิวเตอร์ของ Microsoft แทนที่จะเป็นนักแปลที่เป็นบุคคล Microsoft มีบทความที่แปลโดยนักแปลและบทความที่แปลด้วยคอมพิวเตอร์ เพื่อให้คุณสามารถเข้าถึงบทความทั้งหมดในฐานความรู้ของเรา ในภาษาของคุณเอง อย่างไรก็ตาม บทความที่แปลด้วยคอมพิวเตอร์นั้นอาจมีข้อบกพร่อง โดยอาจมีข้อผิดพลาดในคำศัพท์ รูปแบบการใช้ภาษาและไวยากรณ์ เช่นเดียวกับกรณีที่ชาวต่างชาติพูดผิดเมื่อพูดภาษาของคุณ Microsoft ไม่มีส่วนรับผิดชอบต่อความคลาดเคลื่อน ความผิดพลาดหรือความเสียหายที่เกิดจากการแปลเนื้อหาผิดพลาด หรือการใช้บทแปลของลูกค้า และ Microsoft มีการปรับปรุงซอฟต์แวร์การแปลด้วยคอมพิวเตอร์อยู่เป็นประจำ
ต่อไปนี้เป็นฉบับภาษาอังกฤษของบทความนี้:2545723

ให้ข้อเสนอแนะ

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com