[NT]一部の [ネットワークとダイヤルアップ接続] アイコンが表示されない

文書翻訳 文書翻訳
文書番号: 254631 - 対象製品
この記事は、以前は次の ID で公開されていました: JP254631
すべて展開する | すべて折りたたむ

目次

現象

[スタート] メニューをクリックし、[設定] をポイントしてから [ネットワークとダイヤルアップ接続] をクリ ックしたとき、以下の現象が発生することがあります。
  • ネットワーク アダプタでリソースの競合が発生しているため、[ローカル エリア接続] アイコンが表示されません。なお、その場合でもデバイス マネージャは不正にデバイスが正常に動作していると表示します。
  • [ローカル エリア接続] アイコンが表示されない。
  • [新しい接続の作成] アイコンが表示されない。
  • [新しい接続の作成] をダブルクリックすると、以下のエラー メッセージが表示される。
    指定した接続を作成できません。原因としてディスク領域の不足、またはメモリ不足などが考えられます。

原因

この現象は、以下の 1 つまたは複数の原因によって発生することがあります。
  • プラグ アンド プレイ サービスが実行していないため、[ローカル エリア接続] アイコンが表示されない。
  • リモート プロシージャ コール (RPC) サービスが実行していないため、[新しい接続の作成] アイコンが表示されない。
  • DCOM の既定の設定を変更するために Dcomcnfg.exe ツールを使用したため、この資料で前述したエラー メッセージが表示される。
  • 以下のいずれかのネットワーク dll が正しく登録されていない。
    • Netcfgx.dll
    • Netman.dll
    • Netshell.dll

解決方法

この現象を解決するには、以下の適切な方法を使用します。

デバイス リソースの設定の確認

この現象を解決するには、以下の手順で行ってください。
  1. ネットワーク アダプタの製造元から、ネットワーク アダプタの構成ユーティリティを入手します。通常、これらのユーティリティを実行するには、MS-DOS もしくは Windows 95/98 のスタートアップ ディスクからコンピュ ータを起動する必要があります。
  2. ネットワーク アダプタの設定にジャンパが使用されている場合、別のデバイスと競合を起こさないことを確認した上で手動で使用されていないリソースに設定にします。

    : デットワーク アダプタがどのデバイスと競合を起こしているかを判別するには、NIC 以外のデバイスをすべてはずし、1 つずつ挿入しなおしてください。

プラグ アンド プレイ サービスを起動する

この現象を解決するには、以下の手順で行ってください。
  1. [スタート] メニューをクリックし、[プログラム] 、[管理ツール] をポイントしてから [コンピュータの管理] をクリックします。
  2. [サービスとアプリケーション] をダブルクリックし、[サービス] をクリックしてから [Plug and Play] をダブルクリックします。
  3. [スタートアップの種類] ダイアログ ボックスで [自動] をクリックし、[OK] をクリックしてからコンピュータを再起動します。

    注意: この手順を実行しても [ローカル エリア接続] アイコンが表示されない場合は、F5 を数回押して画面を更新します。また、ネットワークを使ったセーフ モードでコンピュータを再起動する必要がある場合もあります。

RPC サービスを起動する

この現象を解決するには、以下の手順で行ってください。
  1. [スタート] メニューをクリックし、[プログラム] 、[管理ツール] をポイントしてから [コンピュータの管理] をクリックします。
  2. [サービスとアプリケーション] をダブルクリックし、[サービス] をクリックしてから [Remote Procedure Call (RPC)] をダブルクリックします。
  3. [スタートアップの種類] ダイアログ ボックスで [自動] をクリックし、[OK] をクリックしてからコンピュータを再起動します。

    注意: RPC サービスを使用できない場合は、回復コンソールを使用する必要がある場合があります。回復コンソールの起動と使用方法の詳細については、以下の Microsoft Knowledge Base アーティクルを参照してください。
    229716 Description of the Windows 2000 Recovery Console
  4. 回復コンソールで「Enable RPCSS Service_Auto_Start」 (かっこを除く) を実行してからコンピュータを再起動します。

    注意: この手順を実行しても [新しい接続の作成] アイコンが表示されない]場合は、F5 を数回押して画面を更新します。また、ネットワークを使ったセーフ モードでコンピュータを再起動する必要がある場合もあります。

DCOM の既定のアクセス権をリセットする

この現象を解決するには、以下の手順で行ってください。
  1. [スタート] メニューをクリックし、[ファイル名を指定して実行] をクリックしてから「dcomcnfg」 (かっこを除く) を入力し、[OK] をクリックします。
  2. [既定のプロパティ] タブの [既定の偽装レベル] ボックスで [匿名] 以外の任意の設定をクリックします。既定の設定は [識別する] です。

以下の Dll を登録する

  1. [スタート] メニューをクリックし、[ファイル名を指定して実行] をクリックしてから [名前] 行に「cmd.exe」 (かっこを除く) を入力します。
  2. 以下の行を入力し、各行の入力後 ENTER を押します。
         regsvr32 netshell.dll
         regsvr32 netcfgx.dll
         regsvr32 netman.dll
    
  3. コンピュータを再起動します。

状況

弊社では、これを本資料の冒頭に記した Microsoft 製品の問題として認識しております。

詳細

この問題は、Network Connections サービスのプロパティの [ログオン] タブの [デスクトップとの対話をサー ビスに許可] チェック ボックスがオフになっている場合も発生します。

関連情報

この資料は米国 Microsoft Corporation から提供されている Knowledge Base の Article ID 254631 (最終更新日 2000-06-30) をもとに作成したものです。

プロパティ

文書番号: 254631 - 最終更新日: 2004年5月10日 - リビジョン: 3.0
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Datacenter Server
  • Microsoft Windows 2000 Professional
  • Microsoft Windows 2000 Advanced Server
キーワード:?
kberrmsg kbtool kbui kbprb KB254631
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com