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Symptoms

Consider the following scenario:

  • You enable the following Group Policy settings on a computer that is running Windows 7 or Windows Server 2008 R2:

    • Computer Configuration\Administrative Templates\Windows Components\Event Log Service\Security\Backup log automatically when full

    • Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options\Audit: Shut down system immediately if unable to log

  • You select the Archive the log when full, do not overwrite events option for the Security log properties in Event Viewer.

  • The Security log reaches the maximum log size.

In this scenario, the computer crashes, and you receive a Stop error message that resembles the following:

0xc0000244 - {Audit Failed}
An attempt to generate a security audit failed.


Note The expected behavior is that the computer backs up the Security log when the log reaches its maximum size, and the computer does not crash.

Cause

This issue occurs because the Windows Event Log service incorrectly generates the "0xc0000244" Stop code before the service backs up the Security log.

Resolution

To resolve this issue, install the following hotfix package on the affected computer that is running Windows 7 or Windows Server 2008 R2.

After you install the following hotfix package, the Windows Event Log service generates the "0xc0000244" Stop code only if the service cannot back up the Security log.

Hotfix information

A supported hotfix is available from Microsoft. However, this hotfix is intended to correct only the problem that described in this article. Apply this hotfix only to systems that are experiencing the problem described in this article. This hotfix might receive additional testing. Therefore, if you are not severely affected by this problem, we recommend that you wait for the next software update that contains this hotfix.

If the hotfix is available for download, there is a "Hotfix download available" section at the top of this Knowledge Base article. If this section does not appear, contact Microsoft Customer Service and Support to obtain the hotfix.

Note If additional issues occur or if any troubleshooting is required, you might have to create a separate service request. The usual support costs will apply to additional support questions and issues that do not qualify for this specific hotfix. For a complete list of Microsoft Customer Service and Support telephone numbers or to create a separate service request, visit the following Microsoft website:

http://support.microsoft.com/contactus/?ws=supportNote The "Hotfix download available" form displays the languages for which the hotfix is available. If you do not see your language, it is because a hotfix is not available for that language.

Prerequisites

To apply this hotfix, you must be running one of the following operating systems:

  • Windows 7

  • Windows 7 Service Pack 1 (SP1)

  • Windows Server 2008 R2

  • Windows Server 2008 R2 Service Pack 1 (SP1)

For more information about how to obtain a Windows 7 or Windows Server 2008 R2 service pack, click the following article number to view the article in the Microsoft Knowledge Base:

976932 Information about Service Pack 1 for Windows 7 and for Windows Server 2008 R2

Registry information

To use the hotfix in this package, you do not have to make any changes to the registry.

Restart requirement

You must restart the computer after you apply this hotfix.

Hotfix replacement information

This hotfix does not replace a previously released hotfix.

File information

The global version of this hotfix installs files that have the attributes that are listed in the following tables. The dates and the times for these files are listed in Coordinated Universal Time (UTC). The dates and the times for these files on your local computer are displayed in your local time together with your current daylight saving time (DST) bias. Additionally, the dates and the times may change when you perform certain operations on the files.

Windows 7 and Windows Server 2008 R2 file information notes


Important Windows 7 hotfixes and Windows Server 2008 R2 hotfixes are included in the same packages. However, hotfixes on the Hotfix Request page are listed under both operating systems. To request the hotfix package that applies to one or both operating systems, select the hotfix that is listed under "Windows 7/Windows Server 2008 R2" on the page. Always refer to the "Applies To" section in articles to determine the actual operating system that each hotfix applies to.

  • The files that apply to a specific product, SR_Level (RTM, SPn), and service branch (LDR, GDR) can be identified by examining the file version numbers as shown in the following table.

    Version

    Product

    SR_Level

    Service branch

    6.1.760
    0.
    20xxx

    Windows 7 and Windows Server 2008 R2

    RTM

    LDR

    6.1.760
    1.
    21xxx

    Windows 7 and Windows Server 2008 R2

    SP1

    LDR

  • The MANIFEST files (.manifest) and the MUM files (.mum) that are installed for each environment are listed separately in the "Additional file information for Windows Server 2008 R2 and for Windows 7" section. MUM and MANIFEST files, and the associated security catalog (.cat) files, are extremely important to maintain the state of the updated components. The security catalog files, for which the attributes are not listed, are signed with a Microsoft digital signature.

For all supported x86-based versions of Windows 7

File name

File version

File size

Date

Time

Platform

Wevtsvc.dll

6.1.7600.21010

1,087,488

16-Jul-2011

04:28

x86

Wevtsvc.dll

6.1.7601.21772

1,087,488

16-Jul-2011

04:58

x86

For all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Wevtsvc.dll

6.1.7600.21010

1,647,616

16-Jul-2011

05:25

x64

Wevtsvc.dll

6.1.7601.21772

1,646,080

16-Jul-2011

05:32

x64

For all supported IA-64–based versions of Windows Server 2008 R2

File name

File version

File size

Date

Time

Platform

Wevtsvc.dll

6.1.7600.21010

2,901,504

16-Jul-2011

04:06

IA-64

Wevtsvc.dll

6.1.7601.21772

2,901,504

16-Jul-2011

04:18

IA-64

Status

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

More Information

For more information about software update terminology, click the following article number to view the article in the Microsoft Knowledge Base:

824684 Description of the standard terminology that is used to describe Microsoft software updates

For more information about a similar issue, click the following article number to view the article in the Microsoft Knowledge Base:

2492505 Computer does not crash when the disk is full after CrashOnAuditFail is set in Windows 7 or in Windows Server 2008 R2

Additional file information

Additional file information for Windows 7 and for Windows Server 2008 R2

Additional files for all supported x86-based versions of Windows 7

File name

X86_1ba495bf981ffa9fb64fd4b5d5264f48_31bf3856ad364e35_6.1.7600.21010_none_db05eae4e6f174df.manifest

File version

Not applicable

File size

696

Date (UTC)

16-Jul-2011

Time (UTC)

11:27

File name

X86_9ead3e9c713ea63467b31cecee5065c5_31bf3856ad364e35_6.1.7601.21772_none_72cd87392a286f22.manifest

File version

Not applicable

File size

696

Date (UTC)

16-Jul-2011

Time (UTC)

11:27

File name

X86_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7600.21010_none_dd6adeaa8d16477a.manifest

File version

Not applicable

File size

40,903

Date (UTC)

16-Jul-2011

Time (UTC)

04:59

File name

X86_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7601.21772_none_df12849a8a6b5a78.manifest

File version

Not applicable

File size

40,903

Date (UTC)

16-Jul-2011

Time (UTC)

05:25

Additional files for all supported x64-based versions of Windows 7 and of Windows Server 2008 R2

File name

Amd64_b4f5693eea031cff8f78102815b10dab_31bf3856ad364e35_6.1.7600.21010_none_27d6594f96bc9c1e.manifest

File version

Not applicable

File size

700

Date (UTC)

16-Jul-2011

Time (UTC)

11:27

File name

Amd64_df2e9dd558da4008f22c1f7eb5039adf_31bf3856ad364e35_6.1.7601.21772_none_c65e21577fd73a22.manifest

File version

Not applicable

File size

700

Date (UTC)

16-Jul-2011

Time (UTC)

11:27

File name

Amd64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7600.21010_none_39897a2e4573b8b0.manifest

File version

Not applicable

File size

40,907

Date (UTC)

16-Jul-2011

Time (UTC)

05:55

File name

Amd64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7601.21772_none_3b31201e42c8cbae.manifest

File version

Not applicable

File size

40,907

Date (UTC)

16-Jul-2011

Time (UTC)

06:13

Additional files for all supported IA-64–based versions of Windows Server 2008 R2

File name

Ia64_007138a1fa8358ddcc1bb11f4a196674_31bf3856ad364e35_6.1.7600.21010_none_53dc8c5a58ca62c8.manifest

File version

Not applicable

File size

698

Date (UTC)

16-Jul-2011

Time (UTC)

11:27

File name

Ia64_4f3331d8048f5eb9506b914ea17b02c3_31bf3856ad364e35_6.1.7601.21772_none_c7733be1fdcb7189.manifest

File version

Not applicable

File size

698

Date (UTC)

16-Jul-2011

Time (UTC)

11:27

File name

Ia64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7600.21010_none_dd6c82a08d145076.manifest

File version

Not applicable

File size

40,905

Date (UTC)

16-Jul-2011

Time (UTC)

05:45

File name

Ia64_microsoft-windows-eventlog_31bf3856ad364e35_6.1.7601.21772_none_df1428908a696374.manifest

File version

Not applicable

File size

40,905

Date (UTC)

16-Jul-2011

Time (UTC)

06:12

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