Windows Server 2008 R2: Administrator auf RDSH erhält einen Fehler in Lizenzierungsdiagnose: Lizenzen sind für diesen Remotedesktop-Sitzungshostserver nicht verfügbar

In diesem Artikel wird ein entwurfsbasiertes Verhalten beschrieben, bei dem Windows Server 2008 R2 Administrator auf RDSH in der Lizenzierungsdiagnose einen Fehler erhält.

Gilt für: Windows Server 2008 R2 Service Pack 1
Ursprüngliche KB-Nummer: 2546583

Symptome

Betrachten Sie das folgende Szenario:

  1. Sie installieren den Rollendienst "Remotedesktoplizenzierung" auf einem Computer, auf dem Windows Server 2008 R2 ausgeführt wird.
  2. Sie installieren den Rollendienst "Remotedesktopsitzungshost" auf einem anderen Computer, auf dem Windows Server 2008 R2 ausgeführt wird.
  3. Sie öffnen die MMC-Fenster "Remotedesktop-Sitzungshostkonfiguration" (tsconfig.msc) auf dem Computer mit der RDSH-Rolle.
  4. Klicken Sie im linken Bereich auf das Element Lizenzierungsdiagnose .

In diesem Szenario wird möglicherweise die folgende Fehlermeldung angezeigt:

Lizenzen sind für diesen Remotedesktop-Sitzungshostserver nicht verfügbar, und die Lizenzierungsdiagnose hat Lizenzierungsprobleme für den RD-Sitzungshostserver identifiziert.
Anzahl der für Clients verfügbaren Lizenzen: 0
...

Informationen zur Lizenzierungsdiagnose – 1 Fehler...
Problem: Um mögliche Lizenzierungsprobleme zu identifizieren, sind Administratoranmeldeinformationen für den Lizenzserver %servername% erforderlich.
Lösungsvorschläge: Geben Sie Administratoranmeldeinformationen für den Lizenzserver für Remotedesktopdienste an.

Ursache

Das Problem tritt auf, da das aktuelle Abfragebenutzerkonto nicht über die Administratorrechte auf dem Remotedesktoplizenzierungsserver verfügt.

Die Lizenzierungsdiagnose verwendet eine WMI-Methode, um die Lizenzierungsinformationen abzufragen. Diese Methode erfordert Administratorrechte auf dem Remotedesktoplizenzserver. Es handelt sich hierbei um ein beabsichtigtes Verhalten.

Lösung

Fügen Sie das abfragende Benutzerkonto der lokalen Gruppe Administratoren auf dem Remotedesktoplizenzierungsserver hinzu.

Datensammlung

Wenn Sie Unterstützung vom Microsoft-Support benötigen, empfehlen wir Ihnen, die Informationen zu sammeln, indem Sie die Schritte unter Sammeln von Informationen mithilfe von TSS für Fragen der Benutzerfreundlichkeit ausführen.