Pesan galat pengandar perangkat virtual di subsistem MS-DOS 16-Bit

Terjemahan Artikel Terjemahan Artikel
ID Artikel: 254914 - Melihat produk di mana artikel ini berlaku.
Pemberitahuan
Artikel ini berlaku untuk Windows 2000. Dukungan untuk Windows 2000 berakhir pada 13 Juli 2010. The Pusat Solusi Windows 2000 akhir dukungan adalah titik awal untuk perencanaan strategi migrasi dari Windows 2000. Untuk informasi lebih lanjut lihat Microsoft Support Lifecycle Policy.
Untuk versi Microsoft Windows XP dari artikel ini, baca 314452.
Pemberitahuan
Artikel ini berlaku untuk Windows 2000. Dukungan untuk Windows 2000 berakhir pada 13 Juli 2010. The Pusat Solusi Windows 2000 akhir dukungan adalah titik awal untuk perencanaan strategi migrasi dari Windows 2000. Untuk informasi lebih lanjut lihat Microsoft Support Lifecycle Policy.
Perbesar semua | Perkecil semua

GEJALA

Setelah Anda menginstal beberapa program, salah satu pesan galat berikut akan muncul ketika Anda mencoba untuk menjalankan program 16-bit:
Subsistem MS-DOS 16 bit
drive:\program jalan
XXXX. Diinstal Virtual Device Driver gagal inisialisasi DLL. Pilih 'Tutup' untuk mengakhiri aplikasi.
-atau-
Subsistem MS-DOS 16 bit
drive:\program jalan
SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers. VDD. Virtual Device Driver format di registri tidak sah. Pilih 'Tutup' untuk mengakhiri aplikasi.
Dalam beberapa kasus, mengklik Mengabaikan memungkinkan program untuk menjalankan dengan benar, tetapi pesan galat terus ditampilkan ketika Anda mulai program 16-bit.

PENYEBAB

Perilaku ini dapat terjadi apabila nilai registri berikut menjadi rusak:
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers\VDD
Masalah ini dapat terjadi setelah Anda menginstal program 16-bit, atau program yang menggunakan program 16-bit instalasi, yang tidak kompatibel Windows 2000.

PEMECAHAN MASALAH

Penting Bagian ini, metode, atau tugas yang memuat langkah-langkah yang memberitahu Anda bagaimana memodifikasi registri. Namun, masalah yang serius dapat terjadi apabila Anda salah memodifikasi registri. Oleh karena itu, pastikan Anda mengikuti langkah-langkah tersebut dengan seksama. Untuk perlindungan tambahan, buat cadangan registri sebelum Anda memodifikasi. Kemudian, Anda dapat memulihkan registri apabila terjadi masalah. Untuk informasi selengkapnya tentang cara membuat cadangan dan memulihkan registri, klik nomor artikel berikut ini untuk melihat artikel di Pangkalan Pengetahuan Microsoft:
322756 Cara membuat cadangan dan memulihkan registri di Windows
  1. Mulai Penyunting Registri (Regedt32.exe).
  2. Cari dan klik nilai berikut:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\VirtualDeviceDrivers\VDD
  3. Pada Mengedit menu, klik Hapus.
  4. Pada Mengedit menu, klik Tambahkan nilai.
  5. Jenis VDD dalam Nama nilai kotak, klik REG_MULTI_SZ untuk Jenis Data, lalu klik Oke.
  6. Multi-String editor muncul. Entri ini kosong dan klik Oke.
  7. Tutup Penyunting Registri.
Jika langkah-langkah di atas tidak bekerja, atau jika Anda tidak dapat membuat kunci VDD, mungkin perlu juga menghapus dan menciptakan seluruh VirtualDeviceDrivers kunci registri.

STATUS

Microsoft telah mengkonfirmasi bahwa ini adalah masalah di dalam produk Microsoft sebagaimana tercantum di bagian "Berlaku untuk".

INFORMASI LEBIH LANJUT

Pesan kesalahan ini juga dapat terjadi pada Microsoft Windows NT 4.0 jika kunci ini secara manual dihapus untuk tujuan pengujian.

Properti

ID Artikel: 254914 - Kajian Terakhir: 21 September 2011 - Revisi: 2.0
Berlaku bagi:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Windows NT Workstation 4.0 Developer Edition
Kata kunci: 
kb3rdparty kbappdev kberrmsg kbprb w2000apps kbmt KB254914 KbMtid
Penerjemahan Mesin
PENTING: Artikel ini diterjemahkan menggunakan perangkat lunak mesin penerjemah Microsoft dan bukan oleh seorang penerjemah. Microsoft menawarkan artikel yang diterjemahkan oleh seorang penerjemah maupun artikel yang diterjemahkan menggunakan mesin sehingga Anda akan memiliki akses ke seluruh artikel baru yang diterbitkan di Pangkalan Pengetahuan (Knowledge Base) dalam bahasa yang Anda gunakan. Namun, artikel yang diterjemahkan menggunakan mesin tidak selalu sempurna. Artikel tersebut mungkin memiliki kesalahan kosa kata, sintaksis, atau tata bahasa, hampir sama seperti orang asing yang berbicara dalam bahasa Anda. Microsoft tidak bertanggung jawab terhadap akurasi, kesalahan atau kerusakan yang disebabkan karena kesalahan penerjemahan konten atau penggunaannya oleh para pelanggan. Microsoft juga sering memperbarui perangkat lunak mesin penerjemah.
Klik disini untuk melihat versi Inggris dari artikel ini:254914

Berikan Masukan

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com