Installation of Windows Live ID Sign-in Assistant failed Exit code 1603 when installing Microsoft Dynamics CRM 2011 client for Outlook
This article provides a resolution for the error Installation of Windows Live ID Sign-in Assistant failed that occurs when installing Microsoft Dynamics CRM 2011 client for Outlook.
Applies to: Microsoft Dynamics CRM Online
Original KB number: 2549386
Symptoms
During the process of installing the prerequisites for the Microsoft Dynamics CRM 2011 client for Outlook, the Windows Live ID Sign-in Assistant installation fails, causing the Microsoft Dynamics CRM 2011 client for Outlook installation to end prematurely. Examination of the crm50setup.log file will report the following error message:
Installation of Windows Live ID Sign-in Assistant failed. Exit code: 1603. Result: Fatal error during installation.
Cause
On some systems, the Windows Live ID Sign-in Assistant install will fail if an additional installation parameter is not specified. By default, the Microsoft Dynamics CRM 2011 client for Outlook does not specify this additional parameter.
Resolution
To resolve the issue, perform the following steps:
- Download the Windows Live ID Sign-in Assistant and save it to a folder on the local hard drive.
- Go to Start > Programs > Accessories > Command Prompt.
- Type in
cd c:\<folder name>
.<folder name>
is the location where you downloaded the Assistant to. - Type in
Msiexec /i wllogin_32.msi /l*v C:\setupLogs.log NOMU=1
. - Once the Windows Live ID Sign-in Assistant installation is complete, start the installation of the Microsoft Dynamics CRM 2011 client for Outlook again.
Feedback
https://aka.ms/ContentUserFeedback.
Coming soon: Throughout 2024 we will be phasing out GitHub Issues as the feedback mechanism for content and replacing it with a new feedback system. For more information see:Submit and view feedback for