COM + non raggiungere SetMaxThreads per il pacchetto

Traduzione articoli Traduzione articoli
Identificativo articolo: 255054 - Visualizza i prodotti a cui si riferisce l?articolo.
Questo articolo Ŕ stato archiviato. L?articolo, quindi, viene offerto ?cosý come Ŕ? e non verrÓ pi¨ aggiornato.
Espandi tutto | Chiudi tutto

Sintomi

Potrebbe che un'applicazione, ad esempio ASP in Internet Information Services (IIS) 5.0, che utilizza COM + per gestire un pool di thread verificarsi una riduzione delle prestazioni, in quanto COM + non aumenta il numero di thread nel pool. In condizioni normali, COM + aumenta il thread del pool thread fino al limite massimo di thread impostato dal metodo SetMaxThreads per il pacchetto. Tuttavia, se i thread di lavoro iniziale nel pool di sono troppo occupati, questo problema pu˛ verificarsi.

Ad esempio, quando il carico di lavoro ASP in un computer di IIS 5.0 aumenta in modo che ogni thread di lavoro utilizzi una considerevole quantitÓ di tempo per completare ogni richiesta, COM + potrebbe non creare qualsiasi numero di thread anche se il lavoro nella coda condivisa sempre aumenta, determinando in questo caso, Accodamento si verifica di ASP. Questo problema pu˛ essere identificato mediante il monitoraggio dell'utilizzo della CPU. Questo problema verrÓ visualizzato quando utilizzo della CPU da Inetinfo Ŕ molto basso, in genere sulle chiamate di blocco in tempo.

Cause

In caso carico elevato, Ŕ possibile che il thread di monitoraggio del pool di thread non selezione di. In questo caso, thread aggiuntivi non vengono aggiunti secondo le necessitÓ. Thread di pool di thread di monitoraggio deve essere sempre attivo.

Risoluzione

Per risolvere questo problema Ŕ necessario ottenere la versione pi¨ recente del service pack per Windows 2000. Per ulteriori informazioni, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
260910Come ottenere Windows 2000 Service Pack pi¨ recente
╚ disponibile un hotfix supportato. Questo hotfix Ŕ tuttavia destinato esclusivamente alla risoluzione del problema descritto in questo articolo. Consente di applicare questo aggiornamento rapido (hotfix) solo ai sistemi in cui si verifica questo problema specifico.

Se l'hotfix Ŕ disponibile per il download, Ŕ una sezione "Hotfix disponibile per il download" all'inizio di questo articolo della Knowledge Base. Se non viene visualizzato in questa sezione, inviare una richiesta di servizio clienti Microsoft e supporto tecnico per ottenere l'hotfix.

Nota Se si verificano ulteriori problemi o se la risoluzione dei problemi Ŕ necessario, potrebbe essere necessario creare una richiesta di servizio separato. I costi di supporto normale verranno applicati per eventuali ulteriori domande e problemi che non dovessero rientrare nello specifico hotfix in questione. Per un elenco completo, di Microsoft Customer Service and Support numeri di telefono o a creare una richiesta di servizio distinto, visitare il seguente sito Web Microsoft:
http://support.microsoft.com/contactus/?ws=support
Nota Il modulo "Hotfix disponibile per il download" Visualizza le lingue per cui Ŕ disponibile l'aggiornamento rapido. Se non viene visualizzata la lingua, Ŕ perchÚ un aggiornamento rapido (hotfix) non Ŕ disponibile per tale lingua.Sono disponibili i file seguenti dall'Area download Microsoft:
ITALIANO
Riduci l'immagineEspandi l'immagine
DOWNLOAD
Download Q262259_w2k_sp1_x86_en.exe now

francese
Riduci l'immagineEspandi l'immagine
DOWNLOAD
Download Q262259_w2k_sp1_x86_fr.exe now

tedesco
Riduci l'immagineEspandi l'immagine
DOWNLOAD
Download Q262259_w2k_sp1_x86_de.exe now

italiano
Riduci l'immagineEspandi l'immagine
DOWNLOAD
Download Q262259_w2k_sp1_x86_it.exe now

giapponese
Riduci l'immagineEspandi l'immagine
DOWNLOAD
Download Q262259_w2k_sp1_x86_ja.exe now

Spagnolo
Riduci l'immagineEspandi l'immagine
DOWNLOAD
Download Q262259_w2k_sp1_x86_es.exe now

Per ulteriori informazioni su come scaricare file di supporto Microsoft, fare clic sul numero dell'articolo della Microsoft Knowledge Base riportato di seguito riportato:
119591Come ottenere file di supporto Microsoft dai servizi online
Microsoft analizzati questo file per individuare eventuali virus. Microsoft ha utilizzato il software antivirus pi¨ recente disponibile alla data di pubblicazione del file. Il file Ŕ archiviato in server con protezione avanzata per impedire modifiche non autorizzate al file.


Status

Microsoft ha confermato che questo problema riguarda i prodotti Microsoft elencati all'inizio di questo articolo.

Questo problema Ŕ stato corretto per la prima volta nel Service Pack 1 per Windows 2000.

ProprietÓ

Identificativo articolo: 255054 - Ultima modifica: martedý 11 febbraio 2014 - Revisione: 3.8
Le informazioni in questo articolo si applicano a:
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional Edition
  • Microsoft Internet Information Services 5.0
Chiavi:á
kbnosurvey kbarchive kbmt kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbthread KB255054 KbMtit
Traduzione automatica articoli
Il presente articolo Ŕ stato tradotto tramite il software di traduzione automatica di Microsoft e non da una persona. Microsoft offre sia articoli tradotti da persone fisiche sia articoli tradotti automaticamente da un software, in modo da rendere disponibili tutti gli articoli presenti nella nostra Knowledge Base nella lingua madre dell?utente. Tuttavia, un articolo tradotto in modo automatico non Ŕ sempre perfetto. Potrebbe contenere errori di sintassi, di grammatica o di utilizzo dei vocaboli, pi¨ o meno allo stesso modo di come una persona straniera potrebbe commettere degli errori parlando una lingua che non Ŕ la sua. Microsoft non Ŕ responsabile di alcuna imprecisione, errore o danno cagionato da qualsiasi traduzione non corretta dei contenuti o dell?utilizzo degli stessi fatto dai propri clienti. Microsoft, inoltre, aggiorna frequentemente il software di traduzione automatica.
Clicca qui per visualizzare la versione originale in inglese dell?articolo: 255054
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com