COM+ がパッケージの SetMaxThreads に到達しない

文書翻訳 文書翻訳
文書番号: 255054 - 対象製品
この記事は、以前は次の ID で公開されていました: JP255054
この資料は、アーカイブされました。これは "現状のまま" で提供され、更新されることはありません。
すべて展開する | すべて折りたたむ

現象

インターネット インフォメーション サービス (IIS) 5.0 の ASP のように、COM+ を使用してスレッド プールを管理するアプリケーションでは、COM+ がスレッド プール内のスレッド数を増やさないため、パフォーマンスが低下することがあります。通常、COM+ は、パッケージの SetMaxThreads メソッドで設定されるスレッドの上限までスレッド プール内のスレッド数を増やします。ただし、プール内の初期ワーカー スレッドがビジー状態の場合は、この問題が発生する可能性があります。

たとえば、IIS 5.0 コンピュータ上の ASP の作業負荷が増大することにより、各ワーカー スレッドが各要求を完了するためにかなりの時間がかかるとき、共有キューの作業は常に増加しますが、COM+ はスレッドをこれ以上作成しない可能性があります。この場合、ASP のキューイングが発生します。この問題は、CPU 使用率を監視することで識別できます。この問題が発生するのは、Inetinfo の CPU 使用率が非常に低く、通常は呼び出しが長時間ブロックされている場合です。

原因

大きな負荷がかかると、スレッド プールを監視するスレッドが動作しない可能性があります。この状態が発生すると、必要な新しいスレッドが追加されません。スレッド プールを監視するスレッドは、常にアクティブである必要があります。

解決方法

この問題を解決するには、Windows 2000 の最新の Service Pack を入手します。関連情報を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
260910 最新の Windows 2000 Service Pack の入手方法
マイクロソフトでは、この問題を修正する修正プログラムを提供しています。ただし、この修正プログラムは、ここで説明する問題のみを修正することを目的としたものです。この修正プログラムは、ここで説明する問題が発生しているシステムにのみ適用してください。

修正プログラムをダウンロードできる場合は、この「サポート技術情報」 (Microsoft Knowledge Base) の資料の上部に「修正プログラムのダウンロード」セクションがあります。このセクションが表示されていない場合は、Microsoft Customer Service and Support にリクエストを送信し、修正プログラムを入手してください。

: 別の問題が発生した場合、またはトラブルシューティングが必要な場合には、別のサービス リクエストを作成しなければならない場合があります。特定の修正プログラムの対象とならない追加の質問および問題については、通常のサポート料金が適用されます。Microsoft Customer Service and Support の電話番号一覧または別のサービス リクエストの作成については、次のマイクロソフト Web サイトを参照してください。
http://support.microsoft.com/contactus/?ws=support
:「ダウンロード」フォームには、修正プログラムを入手できる言語が表示されます。使用している言語が表示されない場合は、その言語の修正プログラムが存在しないことになります。下記のファイルは、「Microsoft ダウンロード センター」からダウンロードできます。
英語 (米国)
元に戻す画像を拡大する
DOWNLOAD
Q262259_w2k_sp1_x86_en.exe

フランス語
元に戻す画像を拡大する
DOWNLOAD
Q262259_w2k_sp1_x86_fr.exe

ドイツ語版
元に戻す画像を拡大する
DOWNLOAD
Q262259_w2k_sp1_x86_de.exe

イタリア語
元に戻す画像を拡大する
DOWNLOAD
Q262259_w2k_sp1_x86_it.exe

日本語
元に戻す画像を拡大する
DOWNLOAD
Q262259_w2k_sp1_x86_ja.exe

スペイン語
元に戻す画像を拡大する
DOWNLOAD
Q262259_w2k_sp1_x86_es.exe

マイクロソフトのサポート ファイルのダウンロード方法を参照するには、以下の「サポート技術情報」 (Microsoft Knowledge Base) をクリックしてください。
119591 オンライン サービスからマイクロソフトのサポート ファイルを入手する方法
マイクロソフトでは、アップロード時点の最新のウイルス検査プログラムを使用して、配布ファイルのウイルス チェックを行っています。配布ファイルはセキュリティで保護されたサーバー上に置かれており、権限のない第三者が無断でファイルを変更できないようになっています。


状況

マイクロソフトでは、この問題をこの資料の冒頭に記載したマイクロソフト製品の問題として認識しています。

この問題は、Windows 2000 Service Pack 1 で修正済みです。

プロパティ

文書番号: 255054 - 最終更新日: 2014年2月2日 - リビジョン: 3.8
この資料は以下の製品について記述したものです。
  • Microsoft Windows 2000 Server
  • Microsoft Windows 2000 Advanced Server
  • Microsoft Windows 2000 Professional
  • Microsoft Internet Information Services 5.0
キーワード:?
kbnosurvey kbarchive kbautohotfix kbhotfixserver kbqfe kbbug kbfix kbqfe kbthread KB255054
"Microsoft Knowledge Baseに含まれている情報は、いかなる保証もない現状ベースで提供されるものです。Microsoft Corporation及びその関連会社は、市場性および特定の目的への適合性を含めて、明示的にも黙示的にも、一切の保証をいたしません。さらに、Microsoft Corporation及びその関連会社は、本文書に含まれている情報の使用及び使用結果につき、正確性、真実性等、いかなる表明・保証も行ないません。Microsoft Corporation、その関連会社及びこれらの権限ある代理人による口頭または書面による一切の情報提供またはアドバイスは、保証を意味するものではなく、かつ上記免責条項の範囲を狭めるものではありません。Microsoft Corporation、その関連会社 及びこれらの者の供給者は、直接的、間接的、偶発的、結果的損害、逸失利益、懲罰的損害、または特別損害を含む全ての損害に対して、状況のいかんを問わず一切責任を負いません。(Microsoft Corporation、その関連会社 またはこれらの者の供給者がかかる損害の発生可能性を了知している場合を含みます。) 結果的損害または偶発的損害に対する責任の免除または制限を認めていない地域においては、上記制限が適用されない場合があります。なお、本文書においては、文書の体裁上の都合により製品名の表記において商標登録表示、その他の商標表示を省略している場合がありますので、予めご了解ください。"

フィードバック

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com