文章编号: 2551525 - 查看本文应用于的产品
展开全部 | 关闭全部

本文内容

概要

为提高函数的准确性、一致性功能以满足预期要求,并使函数名更准确地描述其功能,已对 Microsoft Excel 2010、Microsoft Excel Services 2010 和 Microsoft Excel Online 2010 函数库中的若干 Excel 函数进行了更新、重命名并添加了一些函数

此外,还将一些常用函数重新本地化为 10 种不同语言(捷克语、丹麦语、荷兰语、意大利语、挪威语、葡萄牙语、葡萄牙语(巴西)、西班牙语、瑞典语和土耳其语)。这会导致在 Excel 2010 中输入类似的 Microsoft Excel 2007 函数名而不是更新的函数名时,出现 #NAME? 错误。当您在 Excel 2010、Excel Services 2010 或 Excel Online 中打开一个工作簿时,如果该工作簿中包含 Excel 早期版本中的函数名,则会显示更新的函数名。

根据客户的反馈,Microsoft 决定将这些常用函数还原为相应的 Excel 2007 本地化名称。若要将函数名还原为相应的 2007 函数名,请下载 Microsoft Office 2010 Service Pack 1。

示例

西班牙语 VLOOKUP 函数在 Excel 2007 中名为 BUSCARV。但在 Excel 2010 中,该西班牙语名称更改为 CONSULTAV。如果您在 SP1 之前的 Excel 2010 版本中输入 BUSCARV 而不是 CONSULTAV,则会收到 #NAME? 错误。

若要重现此行为,请在西班牙语版 Excel 2010 中按照下列步骤操作:
  1. 新建一个 Excel 工作簿。
  2. 在单元格 A1 中键入 1,然后在单元格 A2 中键入 2。
  3. 在单元格 B1 中键入 a,然后在单元格 B2 中键入 b。
  4. 在单元格 D1 中键入 1,然后在单元格 D2 中键入 =BUSCARV(D1,A1:B2,2)。
如果尚未安装 Service Pack 1,则在 Excel 2010 中输入 =BUSCARV(D1,A1:B2,2) 时将收到错误 #?NOMBRE?。在 SP1 之前的 Excel 2010 版本中输入的正确函数是 =CONSULTAV(D1,A1:B2,2)。

不过,在安装 Service Pack 1 之后,如果在 Excel 2010 中输入 =CONSULTAV(D1,A1:B2,2),则会收到错误 #?NOMBRE?。在 SP1 之后的 Excel 2010 版本中输入的正确函数是 =BUSCARV(D1,A1:B2,2)。




更多信息

安装 Service Pack 1 之后,在 Excel 的早期版本中创建的所有工作簿(包括 SP1 之前的 Excel 2010 工作簿)都会自动显示更新的函数名。不需要重新输入这些函数就可以看到更新名称。

若要下载并安装 Office 2010 SP1,请访问以下 Microsoft 知识库文章:

2460049 - 描述 Office 2010 SP1


对于企业客户,访问以下任意或所有 Microsoft 知识库文章取决于您的环境:

2460043 - 描述 Office 2010 语言包 SP1
2460073 - 描述 Office Online SP1
2460056 - 描述 Office Servers 2010 语言包 SP1
2460044 - 描述 Office 语言界面包 2010 SP1
2460045 - 描述 SharePoint Server 2010 SP1
2460047 - 描述 SharePoint 和 Project Server 2010 SP1

函数和语言表

下面的部分提供了 Service Pack 1 更新的语言和函数。

捷克语
下表列出了 Service Pack 1 中更改的捷克语工作表函数:

收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
IFERRORCHYBHODNIFERROR
LEFTVLEVOZLEVA
NOTNEN?NE
RIGHTVPRAVOZPRAVA
TEXTTEXTHODNOTA.NA.TEXT


丹麦语
下表列出了 Service Pack 1 中更改的丹麦语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
AVERAGEGENNEMSNITMIDDEL
AVERAGEIFGENNEMSNIT.HVISMIDDEL.HVIS
AVERAGEIFSGENNEMSNIT.HVISSMIDDEL.HVISER
COUNTIFST?L.HVISST?L.HVISER
CUBEKPIMEMBERKUBEKPIMEDLEMKUBE.KPI.MEDLEM
CUBEMEMBERPROPERTYKUBEMEDLEMSEGENSKABKUBEMEDLEM.EGENSKAB
CUBERANKEDMEMBERKUBERANGERETMEDLEMKUBERANGERET.MEDLEM
CUBESETKUBE.ANGIVKUBES?T
CUBESETCOUNTKUBE.ANGIV.ANTALKUBES?T.ANTAL
DAVERAGEDGENNEMSNITDMIDDEL
DOLLARVALUTAKR
FLOORGULVAFRUND.GULV
GCDF?LLES.DIVISORST?RSTE.F?LLES.DIVISOR
HYPERLINKLINKHYPERLINK
IFERRORHVISFEJLHVIS.FEJL
INTHELHELTAL
ISERRER.FEER.FJL
LOOKUPOPSLAGSL?.OP
MODETILSTANDHYPPIGST
NNTAL
OCT2DECOCT.TIL.DECOKT.TIL.DEC
RECEIVEDMODTAGETMODTAGET.VED.UDL?B
RIGHTBH?JRE_BH?JREB
SUMIFSSUM.HVISSSUM.HVISER

下表列出了 Service Pack 1 中更改的丹麦语宏工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
RESET.TOOLBARNULSTIL.V?RKT?JSLINJEGENDAN.V?RKT?JSLINJE
TEXT.BOXTEKSTFELTTEKSTBOKS

荷兰语
下表列出了 Service Pack 1 中更改的荷兰语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
CHOOSEKIESKIEZEN
CLEANSCHOONWISSEN.CONTROL
DAVERAGEDGEMIDDELDEDBGEMIDDELDE
DAYS360D360DAGEN360
DCOUNTDAANTALDBAANTAL
DGETDHAALDBLEZEN
DOLLARVALUTAEURO
DSTDEVDSTDEVDBSTDEV
DSUMDSOMDBSOM
FINDVINDEN.ALLESVIND.ALLES
LOOKUPOPZOEKENZOEKEN
LOWERKLEINELETTKLEINE.LETTERS
MIDMIDDENDEEL
NPVHNWNHW
PMTAFLOSSINGBET
PROPERBEGINKAPBEGINLETTERS
REPLACEVERVANGVERVANGEN
ROUNDAFRONDINGAFRONDEN
SLNRAALIN.AFSCHR
SQRTVWORTELWORTEL
UPPERHOOFDLETTHOOFDLETTERS
VALUEGETALWAARDE
VDBVAPVDB

下表列出了 Service Pack 1 中更改的荷兰语宏工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
BREAKEINDEONDERBREKEN
FORVOORVAN
GOTOGANAARGA.NAAR
GROUPGROEPGROEPEREN
NOTEOPMERKINGNOTITIE
RESTARTOPNIEUWOPNIEUW.STARTEN

意大利语
下表列出了 Service Pack 1 中更改的意大利语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
FINDRICERTROVA
MINUTEMINUTIMINUTO
SECONDSECONDISECONDO


挪威语
下表列出了 Service Pack 1 中更改的挪威语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
CHARTEGNTEGNKODE
CLEANRYDDRENSK
IPMTRANNUITETRAVDRAG
ISPMTER.ANNUITETER.AVDRAG
MAXMAKSST?RST
PMTANNUITETAVDRAG

下表列出了 Service Pack 1 中更改的挪威语宏工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
NEXTNEXTNESTE

葡萄牙语
下表列出了 Service Pack 1 中更改的葡萄牙语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
FIXEDFIXOFIXA
NANDN?O.DISP
USDOLLARMOEDA2MOEDA.EUA

葡萄牙语(巴西)
下表列出了 Service Pack 1 中更改的葡萄牙语(巴西)工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
COLUMNCOLUNACOL
FACTFATOFATORIAL
FIXEDFIXODEF.N?M.DEC
FREQUENCYFREQU?NCIAFREQ??NCIA
MINM?NM?NIMO
PRODUCTPRODUTOMULT
RECEIVEDRECEBIDORECEBER
SEARCHPESQUISARLOCALIZAR
SERIESSUMSOMAS?RIESOMASEQ??NCIA
STDEVDESVPAD.NDESVPAD
TRUNCTRUNCTRUNCAR
VARVARESTVAR

下表列出了 Service Pack 1 中更改的葡萄牙语(巴西)宏工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
DATE.STRINGCADEIA.DATADATA.S?RIE
ENABLE.COMMANDHABILITAR.COMANDOATIVAR.COMANDO
ENABLE.TOOLHABILITAR.FERRAMENTAATIVAR.FERRAMENTA
EXECUTEEXECUTAREXECUTE
FCLOSEARQ.FECHARARQN.FECHAR
GET.WORKSPACEINFO.ESPA?O.TRABALHOINFO.?REA.TRABALHO
LINKSLINKSV?NCULOS
NUMBER.STRINGCADEIA.N?MEROSEQ??NCIA.N?MERO
REGISTERREGISTRARREGISTRO
RESUMECONINTUARREINIC

西班牙语
下表列出了 Service Pack 1 中更改的西班牙语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
CHARCARCARACTER
CONVERTCONVERTCONVERTIR
DATEVALUEVALFECHAFECHANUMERO
DAYS360D?AS360DIAS360
DCOUNTBDCUENTABDCONTAR
HLOOKUPCONSULTAHBUSCARH
IFERRORSIERRORSI.ERROR
MIDMEDEXTRAE
MODRESTORESIDUO
MODEMODOMODA
NANDNOD
SQRTRCUADRAIZ
TBILLEQLETRA.DE.TES.EQV.A.BONOLETRA.DE.TEST.EQV.A.BONO
TIMETIEMPONSHORA
TIMEVALUEVALHORAHORANUMERO
TRIMRECORTARESPACIOS
VLOOKUPCONSULTAVBUSCARV

下表列出了 Service Pack 1 中更改的西班牙语宏工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
GOTOIRIR.A
NEXTSIGUIENTESALIR.BUCLE
RETURNDEVOLVERVOLVER

瑞典语
下表列出了 Service Pack 1 中更改的瑞典语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
CLEANRENSAST?DA
DAYS360D360DAGAR360
DDBDFAVDEGAVSKR
FALSEFALSKFALSKT
HLOOKUPHTS?KLETAKOLUMN
HOURTIMTIMME
ISNA?RET?RSAKNAD
ISNUMBER?RNUM?RTAL
ISTHAIDIGIT?RTHAISIFFRAISTHAIDIGIT
LEFTV?NSTERPILV?NSTER
LOWERSM?GEMENER
MIDMITTEXTEXT
MODEL?GETYPV?RDE
NIN
NAETSAKNAS
NPVNVLFNETNUV?RDE
PMTAVBETBETALNING
PVNVNUV?RDE
RATEPRSR?NTA
RIGHTH?GERPILH?GER
SLNLNALINAVSKR
SYD?ATP?RSAVSKR
TRIMST?DARENSA
TRUESANNSANT
UPPERSTORAVERSALER
VLOOKUPVTS?KLETARAD

土耳其语
下表列出了 Service Pack 1 中更改的土耳其语工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
SUMTOPLAMTOPLA

下表列出了 Service Pack 1 中更改的土耳其语宏工作表函数:
收起该表格展开该表格
2010 英语版函数Excel 2010Excel 2010 SP1
GET.MOVIEAL.FILMGET.MOVIE
MOVIE.COMMANDFILM.KOMUTMOVIE.COMMAND






注意:本篇“快速发布”文章是从 Microsoft 支持组织直接创建的。 文中包含的信息按原样提供,用于响应紧急问题。 由于发布仓促,材料可能包含印刷错误,并且可能随时修订,恕不另行通知。 有关其他注意事项,请参阅使用条款

属性

文章编号: 2551525 - 最后修改: 2014年4月17日 - 修订: 2.1
这篇文章中的信息适用于:
  • Microsoft Excel 2010
关键字:?
KB2551525
Microsoft和/或其各供应商对于为任何目的而在本服务器上发布的文件及有关图形所含信息的适用性,不作任何声明。 所有该等文件及有关图形均"依样"提供,而不带任何性质的保证。Microsoft和/或其各供应商特此声明,对所有与该等信息有关的保证和条件不负任何责任,该等保证和条件包括关于适销性、符合特定用途、所有权和非侵权的所有默示保证和条件。在任何情况下,在由于使用或运行本服务器上的信息所引起的或与该等使用或运行有关的诉讼中,Microsoft和/或其各供应商就因丧失使用、数据或利润所导致的任何特别的、间接的、衍生性的损害或任何因使用而丧失所导致的之损害、数据或利润不负任何责任。

提供反馈

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com