Chyba „Stránka sa nedá zobraziť“ v programe Internet Explorer v dôsledku uplynutia časového limitu zoznamu neplatných serverov proxy

Preklady článku Preklady článku
ID článku: 2551554 - Zobraziť produkty, ktorých sa tento článok týka.
Rozbaliť všetko | Zbaliť všetko

PRIZNAKY

Vo veľmi zriedkavých prípadoch je možné, že po výskyte určitých chýb pripojenia k serveru sa servery proxy nesprávne pridajú do zoznamu neplatných serverov proxy, v dôsledku čoho bude program Internet Explorer prechádzať zadaným zoznamom serverov proxy, až kým sa všetky servery dočasne nezakážu. Po zakázaní serverov program Internet Explorer zobrazí chybu „Stránka sa nedá zobraziť“, až kým sa zoznam neplatných serverov proxy nevymaže (v predvolenom nastavení o 30 minút).


PRICINA

Ak program Internet Explorer nemôže vytvoriť pripojenie k serveru proxy, s cieľom zachovania výkonu sa daný server proxy pridá do zoznamu neplatných serverov proxy, aby sa istú dobu znova nepoužíval. V predvolenom nastavení je táto doba 30 minút. Ak skript na automatickú konfiguráciu serverov proxy vráti zoznam serverov proxy, ktorý obsahuje viacero serverov proxy, program sa pokúsi pripojiť k ďalšiemu serveru proxy v zozname. Ak toto pripojenie zlyhá, proces sa opakuje, až kým sa nevytvorí pripojenie alebo nepoužijú všetky servery v zozname. Ak sa použili všetky servery v zozname a nevytvorilo sa žiadne pripojenie, používateľovi sa v programe Internet Explorer zobrazí chybové hlásenie Stránka sa nedá zobraziť.


RIESENIE

Spoločnosť Microsoft skúma tento problém a dostupné možnosti. Ak sa stretnete s týmto problémom, môžete použiť alternatívne riešenia na obnovenie pripojenia.

K dispozícii sú nasledujúce alternatívne riešenia:

Postup 1
Vymažte zoznam neplatných serverov proxy reštartovaním programu Internet Explorer.


Postup 2
Upozornenie: Ak databázu Registry upravíte nesprávne pomocou Editora databázy Registry alebo iným spôsobom, môžete spôsobiť vážne problémy. Tieto problémy môžu vyžadovať preinštalovanie operačného systému. Spoločnosť Microsoft nemôže zaručiť odstránenie takýchto problémov. Úpravy databázy Registry vykonávate na vlastné riziko.

Ak chcete, aby sme tento problém vyriešili za vás, prejdite do časti Opravte to za mňa. Ak chcete tento problém vyriešiť sami, prejdite do časti Vyriešim problém sám.

Opravte to za mňa



Ak chcete tento problém vyriešiť automaticky, kliknite na prepojenie alebo tlačidlo Fix it. Potom kliknite na položku Spustiť v dialógovom okne Prevzatie súboru a postupujte podľa pokynov sprievodcu Fix it.


Opraviť tento problém
Microsoft Fix it 50746


Poznámky
  • Tento sprievodca môže byť dostupný iba v angličtine. Automatickú opravu je však možné použiť aj pre ostatné jazykové verzie systému Windows.
  • Ak nepracujete s počítačom, v ktorom sa vyskytol problém, môžete riešenie Fix it uložiť na jednotku flash alebo na disk CD a potom ho môžete spustiť v problémovom počítači.

Potom prejdite do časti Vyriešil sa problém?



Vyriešim problém sám

Pomocou nasledujúceho kľúča databázy Registry nastavte vlastný interval opätovného použitia neplatných serverov proxy:


HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Internet Settings




Vytvorte v tomto kľúči hodnotu DWORD s názvom BadProxyExpiresTime a priraďte jej hodnotu 0. Táto hodnota je v sekundách.
Ak túto hodnotu nastavíte na 0, servery proxy sa nebudú pridávať do zoznamu neplatných serverov proxy.

Vyriešil sa problém?

  • Skontrolujte, či sa problém vyriešil. Ak sa problém vyriešil, úspešne ste dokončili postupy v tejto časti. Ak sa problém nepodarilo vyriešiť, môžete sa obrátiť na oddelenie technickej podpory.
  • Oceníme vaše pripomienky. Ak chcete poskytnúť pripomienky alebo nahlásiť ľubovoľný problém súvisiaci s týmto riešením, pridajte komentár na blog Fix it for me alebo nám pošlite e-mailovú správu.


DALSIE INFORMACIE

Hodnota BadProxyExpiresTime bola prvýkrát použitá v programe Internet Explorer 5.01. Ďalšie informácie získate v nasledujúcom článku:

Program Internet Explorer nepoužíva neplatný server proxy po dobu 30 minút
http://support.microsoft.com/kb/320507



Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Vlastnosti

ID článku: 2551554 - Posledná kontrola: 22. novembra 2011 - Revízia: 1.0
Informácie v tomto článku sa týkajú nasledujúcich produktov:
  • Windows Internet Explorer 7
  • Windows Internet Explorer 8
  • Windows Internet Explorer 9
Kľúčové slová: 
kbmsifixme kbfixme KB2551554

Odošlite odozvu

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com