You are not returned to the Search Results page after you create an alert warning in an extranet environment in SharePoint Server 2010

Article translations Article translations
Article ID: 2551695 - View products that this article applies to.
Expand all | Collapse all

SYMPTOMS

Consider the following scenario:
  • You create a site in Microsoft SharePoint Foundation 2010 or in Microsoft SharePoint Server 2010.
  • You extend the site to an extranet environment by setting Alternate Access Mappings (AAM).
  • You access the extranet site, and then you perform a search on the site.
  • You click the Alert Me link on the Search Results page.
  • You click OK to create the alert warning.
In this scenario, the Alert Me page does not return you to the Search Results page as expected.

RESOLUTION

To resolve this issue, apply the following hotfix packages:
2536591 Description of the SharePoint Foundation 2010 hotfix package (sts-x-none.msp): June 30, 2011
2536588 Description of the SharePoint Server 2010 hotfix package (osrchwfe-x-none.msp): June 28, 2011

STATUS

Microsoft has confirmed that this is a problem in the Microsoft products that are listed in the "Applies to" section.

Properties

Article ID: 2551695 - Last Review: August 15, 2011 - Revision: 3.0
APPLIES TO
  • Microsoft SharePoint Server 2010 Service Pack 1
  • Microsoft SharePoint Server 2010
  • Microsoft SharePoint 2010 For Internet Sites Enterprise
  • Microsoft SharePoint 2010 For Internet Sites Standard
  • Microsoft SharePoint Foundation 2010
Keywords: 
kbqfe kbsurveynew kbexpertiseinter KB2551695

Give Feedback

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com