Visualizzazione del messaggio di errore "NTLDR mancante" quando si effettua l'aggiornamento o l'installazione di Windows 2000 in computer che eseguono Windows 95, Windows 98 o Windows Millennium Edition

Traduzione articoli Traduzione articoli
Identificativo articolo: 255220 - Visualizza i prodotti a cui si riferisce l?articolo.
Per la versione di questo articolo relativa a Microsoft Windows XP, vedere il seguente articolo della Microsoft Knowledge Base: 314057.
Espandi tutto | Chiudi tutto

Sintomi

Quando si cerca di installare Windows 2000 o di effettuare l'aggiornamento a Windows 2000 in un computer che esegue Microsoft Windows 95, Microsoft Windows 98 o Microsoft Windows Millennium Edition (Me), Ŕ possibile ricevere il seguente messaggio di errore dopo il primo riavvio:
NTLDR mancante.
Premere un tasto per riavviare.
Questo problema si verifica solo se Windows 95, Windows 98 o Windows Me Ŕ installato in un'unitÓ ad alta capacitÓ che utilizza il file system FAT32.

Cause

Questo comportamento si verifica quando l'installazione di Windows 95, Windows 98 o Windows Me esistente Ŕ stata clonata su un'unitÓ con specifiche diverse e sono presenti le seguenti condizioni:
  • La partizione di sistema/avvio Ŕ formattata con il file system FAT32.
  • Il computer viene avviato utilizzando estensioni INT-13 (una partizione con dimensioni superiori a 7,8 gigabyte con OC di tipo System-ID nella tabella delle partizioni).
  • Il valore Heads (sides) nel BPB (BIOS Parameter Block) del file system FAT32 Ŕ inesatto. Tale valore deve, infatti, corrispondere alle specifiche dell'unitÓ.
Il codice di avvio di Windows 95, Windows 98 o Windows Me ignora il valore Heads nel BPB e determina il riavvio anche se il valore non Ŕ valido. Il codice di avvio di Windows 2000 richiede invece tale valore e il processo di avvio non pu˛ essere completato se il valore non Ŕ valido.

Risoluzione

Per risolvere il problema, correggere il valore Heads (sides) non valido nel BPB del file system FAT32 per consentire al processo di avvio di Windows 2000 di proseguire. Il modo pi¨ semplice per aggiornare il campo Ŕ ricompilare il codice di avvio di Windows 95, Windows 98 o Windows Me utilizzando la seguente procedura:
  1. Riavviare il computer utilizzando un disco di avvio di Windows 95, Windows 98 o Windows Me contenente il file Sys.com (tale file Ŕ incluso in base all'impostazione predefinita).
  2. Al prompt dei comandi digitare sys c:. Questo comando consente di ricompilare il codice di avvio di Windows 95, Windows 98 o Windows Me con informazioni accurate relative al BPB. Se il comando viene eseguito correttamente, procedere al passaggio 3.

    Se si utilizza un disco di avvio di Windows Me e si riceve un messaggio di errore analogo a "Impossibile trovare il file di sistema nei percorsi standard sull'unitÓ C:", significa che uno o pi¨ file nell'installazione di Windows Me sono stati rimossi. Utilizzare la seguente procedura per spostare i file corretti sull'unitÓ affinchÚ siano accessibili al comando sys:
    1. Al prompt dei comandi, passare alla cartella c:\Windows mediante i seguenti comandi:
      c:
      cd\windows
      NOTA: se Windows Ŕ installato in una directory diversa, modificare in modo appropriato comandi precedentemente indicati.
    2. Provare a passare alla directory Command mediante il comando seguente:
      cd command
      Se viene visualizzato un messaggio di errore che indica che non Ŕ possibile trovare il percorso specificato, utilizzare il seguente comando per creare la cartella, quindi ripetere il comando precedente:?
      md command
    3. Passare alla cartella EBD mediante il seguente comando:
      cd ebd
      Se viene visualizzato un messaggio di errore che indica che non Ŕ possibile trovare il percorso specificato, utilizzare il seguente comando per creare la cartella, quindi ripetere il comando precedente:
      md ebd
    4. Nella cartella EBD utilizzare i seguenti comandi per copiare il file io.sys dalla directory principale del disco rigido e rinominarlo winboot.sys, che Ŕ il file necessario per trasferire il sistema mediante il comando sys.com:
      attrib -s -h -r c:\io.sys
      copy c:\io.sys winboot.sys
    5. Passare nuovamente all'unitÓ A ed eseguire il comando sys per l'unitÓ disco rigido mediante i seguenti comandi:
      a:
      sys c:
  3. Riavviare il computer con Windows 95, Windows 98 o Windows Me, quindi effettuare nuovamente l'installazione o l'aggiornamento a Windows 2000.

    NOTA: in alternativa, dopo avere eseguito il comando sys c:, Ŕ possibile effettuare l'avvio sulla Console di ripristino di emergenza, quindi utilizzare il comando fixboot per riscrivere il codice di avvio di Windows 2000. Questa procedura consente il proseguimento dell'installazione originale.

Status

Microsoft ha confermato che questo problema si verifica con i prodotti elencati alla fine di questo articolo.

ProprietÓ

Identificativo articolo: 255220 - Ultima modifica: venerdý 31 marzo 2006 - Revisione: 3.1
Le informazioni in questo articolo si applicano a
  • Microsoft Windows 2000 Professional Edition
Chiavi:á
kbqfe kbhotfixserver kbenv kberrmsg kbprb kbsetup KB255220
LE INFORMAZIONI CONTENUTE NELLA MICROSOFT KNOWLEDGE BASE SONO FORNITE SENZA GARANZIA DI ALCUN TIPO, IMPLICITA OD ESPLICITA, COMPRESA QUELLA RIGUARDO ALLA COMMERCIALIZZAZIONE E/O COMPATIBILITA' IN IMPIEGHI PARTICOLARI. L'UTENTE SI ASSUME L'INTERA RESPONSABILITA' PER L'UTILIZZO DI QUESTE INFORMAZIONI. IN NESSUN CASO MICROSOFT CORPORATION E I SUOI FORNITORI SI RENDONO RESPONSABILI PER DANNI DIRETTI, INDIRETTI O ACCIDENTALI CHE POSSANO PROVOCARE PERDITA DI DENARO O DI DATI, ANCHE SE MICROSOFT O I SUOI FORNITORI FOSSERO STATI AVVISATI. IL DOCUMENTO PUO' ESSERE COPIATO E DISTRIBUITO ALLE SEGUENTI CONDIZIONI: 1) IL TESTO DEVE ESSERE COPIATO INTEGRALMENTE E TUTTE LE PAGINE DEVONO ESSERE INCLUSE. 2) I PROGRAMMI SE PRESENTI, DEVONO ESSERE COPIATI SENZA MODIFICHE, 3) IL DOCUMENTO DEVE ESSERE DISTRIBUITO INTERAMENTE IN OGNI SUA PARTE. 4) IL DOCUMENTO NON PUO' ESSERE DISTRIBUITO A SCOPO DI LUCRO.

Invia suggerimenti

 

Contact us for more help

Contact us for more help
Connect with Answer Desk for expert help.
Get more support from smallbusiness.support.microsoft.com