How to manually rebuild Performance Counters for Windows Server 2008 64bit or Windows Server 2008 R2 systems

Article ID: 2554336 - View products that this article applies to.
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Symptoms

When you use the Performance Monitor tool, some counters may be missing or do not contain counter data. The performance counter libraries may become corrupted and need to be rebuilt.

Cause

This behavior may occur if certain extensible counters corrupt the registry, or if Windows Management Instrumentation (WMI)-based programs modify the registry. 

Resolution

Ensure that the counters are not disabled in the registry


The counters may be disabled via registry settings. Please check the following registry locations to ensure that the counters have not been disabled.

HKLM\System\CurrentControlSet\Services\%servicename%\Performance

%servicename% represents any service with a performance counter. For example: PerfDisk, PerfOS, etc.


There may be registry keys for "DisablePerformanceCounters" in any of these locations. As per the following TechNet article, this value should be set to 0. If the value is anything other than 0 the counter may be disabled.


Disable Performance Counters
http://technet.microsoft.com/en-us/library/cc784382.aspx

A value of 1 means the counter is disabled.
A value of 2 means the 32-bit counter is disabled.
A value of 4 measn the 64-bit counter is disabled.

 

Rebuilding all performance counters including extensible and third-party counters


To rebuild all Performance counters including extensible and third-party counters, type the following commands at an Administrative command prompt. Press ENTER after each command.

Rebuilding the counters:
     cd c:\windows\system32
     lodctr /R
     cd c:\windows\sysWOW64
     lodctr /R

Resyncing the counters with Windows Management Instrumentation (WMI):
     WINMGMT.EXE /RESYNCPERF

Stop and restart the Performance Logs and Alerts service. 
Stop and restart the Windows Management Instrumentation service.

Create a new Data Collector Set (do not use an existing Data Collector Set).

 

More Information

Please note, there is a hotfix for known issues with PerfDisk.dll on Windows Server 2008 and Vista systems. This hotfix has been rolled into SP2 for these operating systems. If you are at SP1 or below, please apply the following hotfix:

961382 An application crashes after the application loads the Perfdisk.dll file on a computer that is running Windows Server 2008 or Windows Vista if there are lots of disk devices on the computer
http://support.microsoft.com/default.aspx?scid=kb;EN-US;961382

 

Additional Information:

971714 The report generation process may stop responding when you run Perfmon.exe with the Active Directory Diagnostics template to generate a report on a Windows Server 2008-based domain controller
http://support.microsoft.com/default.aspx?scid=kb;EN-US;971714

969639 Error message when you try to access the Performance Monitor (Perfmon.exe) on a remote computer: "Access Is Denied"
http://support.microsoft.com/default.aspx?scid=kb;EN-US;969639

300956 How to manually rebuild Performance Counter Library values
http://support.microsoft.com/default.aspx?scid=kb;EN-US;300956

Note This is a "FAST PUBLISH" article created directly from within the Microsoft support organization. The information contained herein is provided as-is in response to emerging issues. As a result of the speed in making it available, the materials may include typographical errors and may be revised at any time without notice. See Terms of Use for other considerations.

Properties

Article ID: 2554336 - Last Review: May 19, 2011 - Revision: 2.0
APPLIES TO
  • Windows Server 2008 Datacenter
  • Windows Server 2008 Enterprise
  • Windows Server 2008 R2 Datacenter
  • Windows Server 2008 R2 Enterprise
  • Windows Server 2008 R2 Service Pack 1
  • Windows Server 2008 R2 Standard
  • Windows Server 2008 Service Pack 2
  • Windows Server 2008 Standard
Keywords: 
KB2554336

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