Article ID: 255507 - Last Review: March 1, 2007 - Revision: 3.2 No Local Ports Are Available for PrintersThis article was previously published under Q255507 IMPORTANT: This article contains information about modifying the registry. Before you
modify the registry, make sure to back it up and make sure that you understand how to restore
the registry if a problem occurs. For information about how to back up, restore, and edit the
registry, click the following article number to view the article in the Microsoft Knowledge Base:
256986
(http://support.microsoft.com/kb/256986/EN-US/
)
Description of the Microsoft Windows Registry
SYMPTOMS
There may be no local ports available when you are configuring printers. Any printers that are connected to a local port may stop working with the following error message:
Failed to open, retrying
CAUSE
The driver for the local port monitor (Localspl.dll) may have been replaced by a third-party local port monitor. This print monitor may have been designed for previous versions of Windows and installed as part of a printer driver for your device.
RESOLUTIONWARNING: If you use Registry Editor incorrectly, you may cause serious problems that may
require you to reinstall your operating system. Microsoft cannot guarantee that you can solve
problems that result from using Registry Editor incorrectly. Use Registry Editor at your own
risk. To resolve this issue:
STATUSMicrosoft has confirmed that this is a problem in the Microsoft products that are listed at the beginning of this article. MORE INFORMATION
When you are using the standard local port monitor (Localspl.dll), the available ports are LPT1 through LPT4, COM1 through COM4, and FILE.
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