"Cannot use this ID to access this service. Please sign-in with a different ID" error when you try to access Outlook Web App by using Safari in Office 365

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Article ID: 2555521 - View products that this article applies to.
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PROBLEM

In Microsoft Office 365, when you try to open Microsoft Outlook Web App by using a web browser such as Safari, you receive the following error message:

Cannot use this ID to access this service. Please sign-in with a different ID.

When you use Windows Internet Explorer, Outlook Web App opens successfully.

CAUSE

This issue occurs when you try to open Outlook Web App by using a URL that points to a site that requires Microsoft account (formerly Windows Live ID) credentials. And, this site doesn't accept a user ID. For example, you use the following URL: 

http://www.outlook.com/<username>

SOLUTION

To resolve this issue, use a URL that resembles the following to access Outlook Web App in Office 365:

https://www.outlook.com/<domainname>

For example if your domain is contoso.onmicrosoft.com, the URL that you'd use is as follows: 
https://www.outlook.com/contoso.onmicrosoft.com
Still need help? Go to the Office 365 Community website.

The third-party products that this article discusses are manufactured by companies that are independent of Microsoft. Microsoft makes no warranty, implied or otherwise, about the performance or reliability of these products

Properties

Article ID: 2555521 - Last Review: July 9, 2014 - Revision: 17.0
Applies to
  • Microsoft Exchange Online
Keywords: 
o365 o365a o365e o365p o365m o365022013 kb3rdparty KB2555521

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